Results 1 to 6 of 6

Thread: XFCE and keep session

  1. #1
    jr223 NNTP User

    Default XFCE and keep session


    Howdy!

    I have SUSE 11.0 running and have found some issues with Compiz fusion
    and kde 4.0.

    So I have been enjoying using Gnome and especially XFCE.

    The problem I'm having with XFCE is each time a log out and log in the
    default is not Allow XFCE to manage desktop, and is somehow using KDE.

    To fix this as mentioned every time I log in I have to go to the XFCE
    Manage Settings -> Desktop Prfreneces and select the tick box Allow XFCE
    to manage desktop.

    How can I make this perminent?

    Thanks
    Cheers


    --
    jr223
    ------------------------------------------------------------------------
    jr223's Profile: http://forums.opensuse.org/member.php?userid=3994
    View this thread: http://forums.opensuse.org/showthread.php?t=407443


  2. #2
    conram NNTP User

    Default Re: XFCE and keep session


    jr223;1942139 Wrote:
    > Howdy!
    >
    > I have SUSE 11.0 running and have found some issues with Compiz fusion
    > and kde 4.0.
    >
    > So I have been enjoying using Gnome and especially XFCE.
    >
    > The problem I'm having with XFCE is each time a log out and log in the
    > default is not Allow XFCE to manage desktop, and is somehow using KDE.
    >
    > To fix this as mentioned every time I log in I have to go to the XFCE
    > Manage Settings -> Desktop Prfreneces and select the tick box Allow XFCE
    > to manage desktop.
    >
    > How can I make this perminent?
    >
    > Thanks
    > Cheers


    My guess is in the session and startup your automatically save session
    on logout is enable. Try disabling it and logout and login.


    --
    *People who do not break things first will never learn to create
    anything*
    ------------------------------------------------------------------------
    conram's Profile: http://forums.opensuse.org/member.php?userid=872
    View this thread: http://forums.opensuse.org/showthread.php?t=407443


  3. #3
    jr223 NNTP User

    Default Re: XFCE and keep session


    Thanks for the help.

    I already did this, still the same issue.
    Also something else weird is happening.
    As above after I logon and change to the Enbale XFCE to manage tick
    box, the manager is still KDE.

    I can see the XFCE sesion manager running for just a second then KDE
    takes hold, and back to the Green Suse background that is default KDE.


    --
    jr223
    ------------------------------------------------------------------------
    jr223's Profile: http://forums.opensuse.org/member.php?userid=3994
    View this thread: http://forums.opensuse.org/showthread.php?t=407443


  4. #4
    conram NNTP User

    Default Re: XFCE and keep session


    Which kde?kde 4 or kde 3?
    If it is kde 4 you may run killall plasma
    If it is kde 3 then killall kwin.
    Or you can just run xfwm4 --replace.

    One more thing to look at is that it seems from your original post you
    are not running kde but gnome so in this case it is nautilus desktop
    running in the background,unless you installed the kde packages to
    enable kwin. What I am seeing is, it is gnome running on top of xfce in
    this case.
    I am not sure enough with gnome because I haven't use it for a long
    time.
    There is a command for gnome to stop taking your desktop. I am not
    really sure with the command exactly but it goes to something like
    killall nautilus or killall metacity. additionally you can configure
    nautilus to run with no desktop only that it might not be advisable
    because your main de is gnome.

    If this problem persist you can add individually xfwm4 and xfdesktop in
    your autostarted applications in xfce. How to add is give it a name and
    in the command parameter put xfwm4 and for the other xfdesktop.

    Please post what you are seeing in your desktop to see exactly what it
    is e.g right click your mouse if something pop up read and post it here
    so we can determine what is really running.

    One more scennario is it is actually compiz at work. You can run the
    compiz-fusion icon and when you see it in the system tray do a right
    mouse click to see the window manager being use, the choice probably are
    metacity, kwin, icewm, xfwm4 and compiz, there you can select xfwm4 if
    you want it to run xfce, the next time you reboot or logout login it
    will be using xfwm4 minus the compiz effects.


    --
    *People who do not break things first will never learn to create
    anything*
    ------------------------------------------------------------------------
    conram's Profile: http://forums.opensuse.org/member.php?userid=872
    View this thread: http://forums.opensuse.org/showthread.php?t=407443


  5. #5
    jr223 NNTP User

    Default Re: XFCE and keep session


    Thanks for all your help!

    I have all three window managers installed, KDE 4.0, Gnome my least
    favorite and XFCE which I'm really liking.

    I have found some issues with the new KDE 4.0, I think they are bugs
    and I have managed to reproduce them in the KDE 4.0.

    That is one of the reasons why I switched to XFCE.
    Strangely enough I can see KDE run on the XFCE window manager, even
    though I continually try to make XFCE magaed desktop in settings, I have
    also made sure that save desktop on exit is not selected.

    Now what happens when I loginto XFCE is for a brief second I can see
    the XFCE desktop backgrounds that I have set up, then the KDE window
    manager takes over hence the standard KDE green desktop.

    Thanks
    Jeff


    --
    jr223
    ------------------------------------------------------------------------
    jr223's Profile: http://forums.opensuse.org/member.php?userid=3994
    View this thread: http://forums.opensuse.org/showthread.php?t=407443


  6. #6
    jr223 NNTP User

    Default Re: XFCE and keep session


    conram;1942512 Wrote:
    > Which kde?kde 4 or kde 3?
    >
    >
    > Please post what you are seeing in your desktop to see exactly what it
    > is e.g right click your mouse if something pop up read and post it here
    > so we can determine what is really running.
    >
    > One more scennario is it is actually compiz at work. You can run the
    > compiz-fusion icon and when you see it in the system tray do a right
    > mouse click to see the window manager being use, the choice probably are
    > metacity, kwin, icewm, xfwm4 and compiz, there you can select xfwm4 if
    > you want it to run xfce, the next time you reboot or logout login it
    > will be using xfwm4 minus the compiz effects.


    I will post what I'm seeing, when I get home this evening. I have made
    some screen shots, one of them is really weird a box stuck in the left
    hand corner whith now drop down menu to move or close it.
    The window had little dollar signs and random characters running in it,
    almos like you would see in a screen saver.
    This I managed to trace to Compuz fusion, as soon as I turned of
    desktop affects the box was gone.
    This occured in KDE 4.0 I have a screen shot and notes I will post.

    Looks like either a bug or something else
    Thanks


    --
    jr223
    ------------------------------------------------------------------------
    jr223's Profile: http://forums.opensuse.org/member.php?userid=3994
    View this thread: http://forums.opensuse.org/showthread.php?t=407443


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •