Results 1 to 2 of 2

Thread: 32-Bit Libraries on 64-Bit OpenSuSE

  1. #1
    Vince4Amy NNTP User

    Default 32-Bit Libraries on 64-Bit OpenSuSE


    I'd like to install ZSNES on 64-bit OpenSuSE, however when I go to
    install the rpm which I downloaded from the openSuSE build service it
    will not install due to missing dependencies (libao, libGL, libSDL).
    ZSNES was written in 32-bit asm so it is not possible to build an x64
    version.

    When I go to install the 32-bit libraries through YaST they are only
    offered as a downgrade and I can't seem to be able to install them
    separately alongside the 64-bit versions of them, surely clicking
    downgrade would mean first removing the 64-bit version and replacing
    with the 32-bit version.


    --
    Vince4Amy
    ------------------------------------------------------------------------
    Vince4Amy's Profile: http://forums.opensuse.org/member.php?userid=400
    View this thread: http://forums.opensuse.org/showthread.php?t=407387


  2. #2
    Malcolm NNTP User

    Default Re: 32-Bit Libraries on 64-Bit OpenSuSE

    Quote Originally Posted by Vince4Amy
    I'd like to install ZSNES on 64-bit OpenSuSE, however when I go to
    install the rpm which I downloaded from the openSuSE build service it
    will not install due to missing dependencies (libao, libGL, libSDL).
    ZSNES was written in 32-bit asm so it is not possible to build an x64
    version.

    When I go to install the 32-bit libraries through YaST they are only
    offered as a downgrade and I can't seem to be able to install them
    separately alongside the 64-bit versions of them, surely clicking
    downgrade would mean first removing the 64-bit version and replacing
    with the 32-bit version.
    Hi
    You will need to find the 32bit versions for 64bit eg libao-32bit

    Have a search here;
    Get it

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 5:38, 1 user, load average: 0.22, 0.14, 0.07
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •