Results 1 to 5 of 5

Thread: KDE4/Google Earth problem/OpenSuse 11.1

  1. #1

    Exclamation KDE4/Google Earth problem/OpenSuse 11.1

    I think I either have a problem with the Intel driver or maybe with the Mesa3d library or .. something else maybe. My configuration is as follows:
    Intel 965 GM
    OpenSuse 11.1
    KDE4(3d desktop effects activated)
    Driver: 1.4 Mesa 7.2 DRI

    First of all, I can clearly notice a strange behavior of all OpenGL screensavers, as well in some apps using OpenGL(like Space Simulator). Second, I tried to install Google Earth - it freezed my laptop during the start, after trying to visualize the picture of the Earth. Third, I added

    Option "AccelMethod" "exa"
    Option "MigrationHeuristic" "greedy"
    Option "ExaNoComposite" "false"

    within my xorg.conf - it helped, so now Google Earth doesn't lock my whole system but continues to run.

    Unfortunately at least 80% of the textures are either blank or black!!!

    Every piece of software which uses OpenGL looks scrambled. The icons within the Suse TRAY disappeared. I think it's something with the Mesa and DRI, since everything worked fine with OpenSuse 10.3, please help!!!

  2. #2

    Default Re: KDE4/Google Earth problem/OpenSuse 11.1

    Same problem here, x_64, intel GM 45 chipset. GoogleEarth causes hard lockups, need to use power button to restart.

  3. #3

    Default Re: KDE4/Google Earth problem/OpenSuse 11.1

    I had the same problem with intel, google and kde 4.2
    I asked for a solution on, and got this reply:

    intel graphics vs google earth vs kde4 - 1

    Remove those lines from xorg.conf, Then install the following packages from the blow repository and restart:


    repository: Index of /repositories/X11:/XOrg/openSUSE_11.1

    Regards, Rinse

  4. #4

    Default Re: KDE4/Google Earth problem/OpenSuse 11.1


    Thnx a lot but that solutions helps partly, seems like now it's not necessary to add

    # Option "AccelMethod" "exa"
    # Option "MigrationHeuristic" "greedy"
    # Option "ExaNoComposite" "false"

    manually within the xorg.conf to avoid the system freeze. However, I still experience the problems with the black, missing or scrambled (OpenGL) polygons within the picture of the Earth.

  5. #5

    Default Re: KDE4/Google Earth problem/OpenSuse 11.1

    I'm also still experiencing that problem.
    A workaround is to set the desktop effect of kde 4 to xrender in stead of opengl. But that type of rendering is a lot slower and behaves unexpectedly with some desktop effects, like wobbly windows.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts