Results 1 to 7 of 7

Thread: Compiz not working

  1. #1
    harshavarma NNTP User

    Default Compiz not working


    Hello friends...
    im new to Linux and Opensuse 11.1 is the first linux distribution i
    ever installed. This distro is gr8t. I really love this. Since
    installation, im trying to enable the *compiz* in KDE4 but failed. I
    have a Amd x2 3600+ and a Nvidia 9500GT graphics. I followed the guide
    listed in this website but no use. I installed the graphic card drivers
    succesfully. then followed this 'Compiz Fusion - openSUSE'
    (http://en.opensuse.org/Compiz_Fusion)
    While trying the checklist, i always get the msg that composite is
    disabled no matter what i do. I dont have a net connection so i cannot
    use the one click install.

    i tried the instructions here and got a msg that composite is enabled.

    su -
    nvidia-xconfig --composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24

    and when i try running this as mentioned here 'Compiz Fusion -
    openSUSE' (http://en.opensuse.org/Compiz_Fusion)
    i get msg that composite is disabled.

    grep Composite /var/log/Xorg.0.log


    Plz tell me how to enable this feature.....


    --
    harshavarma
    ------------------------------------------------------------------------
    harshavarma's Profile: http://forums.opensuse.org/member.php?userid=21857
    View this thread: http://forums.opensuse.org/showthread.php?t=407176


  2. #2
    caf4926 NNTP User

    Default Re: Compiz not working


    You do NOT need to install it they way have. Compiz is already installed
    and effects are enabled via the Config Desktop - Desktop - enable
    desktop effects
    all effects


    --
    Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)"88.4" | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=407176


  3. #3
    harshavarma NNTP User

    Default Re: Compiz not working


    But i already did that previously and nothing is happening. Are there
    any shortcut keys for enbling that Cube effect? How should i trigger
    that? I enabled all effects and nothings happening actually.


    --
    harshavarma
    ------------------------------------------------------------------------
    harshavarma's Profile: http://forums.opensuse.org/member.php?userid=21857
    View this thread: http://forums.opensuse.org/showthread.php?t=407176


  4. #4
    caf4926 NNTP User

    Default Re: Compiz not working


    Have you upgraded your kde to 4.2?

    Trouble is they keep moving all the settings and I'm not sure where it
    will be in 4.1.3
    But in all efects you need to check the cube effect

    Then look for desktop switching settings
    In 4.2 it's the opening section in Desktop effects
    there are 3 drop boxes

    window switching
    desktop switching
    animation speed


    --
    Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)"88.4" | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=407176


  5. #5
    conram NNTP User

    Default Re: Compiz not working


    harshavarma;1940567 Wrote:
    > But i already did that previously and nothing is happening. Are there
    > any shortcut keys for enbling that Cube effect? How should i trigger
    > that? I enabled all effects and nothings happening actually.


    What compositing type are you using It is under configure desktop
    effects-advance. Mine if I chose xrender effects works except for the
    cube zoom and rotate.Cube zoom and rotate works using opengl for me. I
    am using intel graphics right now but on another machine I have nvidia
    gforce7300gt that works the same as intel. Check it out it might be the
    missing link.


    --
    *People who do not break things first will never learn to create
    anything*
    ------------------------------------------------------------------------
    conram's Profile: http://forums.opensuse.org/member.php?userid=872
    View this thread: http://forums.opensuse.org/showthread.php?t=407176


  6. #6
    harshavarma NNTP User

    Default Re: Compiz not working


    I thought the problem is with KDE and i reinstalled Gnome again. Now i
    installed the drivers succesfully. In the control center, i selected
    DESKTOP Effects and when checking "Enable Desktop Effects" its saying
    that they are not supported under my current configuration. and after
    enabling everything and closing, it is automatically reverting back and
    unchecking the enable effects tab. What should i do?


    --
    harshavarma
    ------------------------------------------------------------------------
    harshavarma's Profile: http://forums.opensuse.org/member.php?userid=21857
    View this thread: http://forums.opensuse.org/showthread.php?t=407176


  7. #7
    harshavarma NNTP User

    Default Re: Compiz not working


    caf4926;1940570 Wrote:
    > Have you upgraded your kde to 4.2?
    >
    > Trouble is they keep moving all the settings and I'm not sure where it
    > will be in 4.1.3
    > But in all efects you need to check the cube effect
    >
    > Then look for desktop switching settings
    > In 4.2 it's the opening section in Desktop effects
    > there are 3 drop boxes
    >
    > window switching
    > desktop switching
    > animation speed

    I thought the problem is with KDE and i reinstalled Gnome again. Now i
    installed the drivers succesfully. In the control center, i selected
    DESKTOP Effects and when checking "Enable Desktop Effects" its saying
    that they are not supported under my current configuration. and after
    enabling everything and closing, it is automatically reverting back and
    unchecking the enable effects tab. What should i do?


    --
    harshavarma
    ------------------------------------------------------------------------
    harshavarma's Profile: http://forums.opensuse.org/member.php?userid=21857
    View this thread: http://forums.opensuse.org/showthread.php?t=407176


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •