Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: VNC on 11.1

  1. #1
    eeijlar NNTP User

    Default VNC on 11.1


    Hi,

    Anyone manage to get VNC to work on 11.1? I can see the Opensuse screen
    that comes up after login but it just hangs there. I edited my vnc
    xstart file and added 'startkde &'. I am using:


    Code:
    --------------------
    vncserver -geometry 800x600 -depth 16 :1
    --------------------


    and


    Code:
    --------------------
    vncviewer myhost:1
    --------------------


    /jlar


    --
    eeijlar
    ------------------------------------------------------------------------
    eeijlar's Profile: http://forums.opensuse.org/member.php?userid=1504
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


  2. #2
    swerdna NNTP User

    Default Re: VNC on 11.1


    VNC has a bug in openSUSE 11.0 and 11.1 for users of KDE4. Try this
    console command to start vncserver:
    Code:
    --------------------
    dbus-start vncserver
    --------------------

    There's a bug report here with more info:
    https://bugzilla.novell.com/show_bug.cgi?id=457809


    --
    'Drop in and visit some time'
    (http://www.swerdna.net.au/linux.html).
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


  3. #3
    eeijlar NNTP User

    Default Re: VNC on 11.1


    Hi,

    Thanks for your reply... I tried that command:

    dbus-start vncserver

    but I am getting:

    bash: dbus: command not found

    any ideas?

    /jlar


    --
    eeijlar
    ------------------------------------------------------------------------
    eeijlar's Profile: http://forums.opensuse.org/member.php?userid=1504
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


  4. #4
    oldcpu NNTP User

    Default Re: VNC on 11.1


    I have vnc working under openSUSE-11.1 KDE-3.5.10, but not under KDE4.
    I spent a fair amount of time on Sunday, connected from Europe to North
    America via vnc, maintaining my mother's openSUSE-11.1 PC in North
    America (from my European openSUSE-11.1 PC). [Both PCs are running
    KDE-3.5.10 - quite possibly the "best" KDE around (at this time) ... ]


    --
    oldcpu
    ------------------------------------------------------------------------
    oldcpu's Profile: http://forums.opensuse.org/member.php?userid=77
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


  5. #5
    swerdna NNTP User

    Default Re: VNC on 11.1


    eeijlar;1941647 Wrote:
    > Hi,
    >
    > Thanks for your reply... I tried that command:
    >
    > dbus-start vncserver
    >
    > but I am getting:
    >
    > bash: dbus: command not found
    >
    > any ideas?
    >
    > /jlar

    Typo -- I meant to say: dbus-launch vncserver


    --
    'Drop in and visit some time'
    (http://www.swerdna.net.au/linux.html).
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


  6. #6
    eeijlar NNTP User

    Default Re: VNC on 11.1


    The computer I am connecting to runs a dual-boot of Windows Xp and
    Opensuse 11.1. I connected to both (from OpenSuse 11.0) using the Remote
    Desktop Connection tool. RDP to connect to XP and VNC to connect to each
    OS. For some reason when I connect to OpenSuse it is really really slow,
    but using RDP to connect to XP is really quick. To setup the vnc I did
    the following:


    Code:
    --------------------
    dbus-launch vncserver
    --------------------


    on the remote host... then in Remote Desktop Connection tool I selected
    the remote host VNC.

    It should be as quick as XP or even quicker I would have thought.


    --
    eeijlar
    ------------------------------------------------------------------------
    eeijlar's Profile: http://forums.opensuse.org/member.php?userid=1504
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


  7. #7
    swerdna NNTP User

    Default Re: VNC on 11.1


    eeijlar;1942560 Wrote:
    > The computer I am connecting to runs a dual-boot of Windows Xp and
    > Opensuse 11.1. I connected to both (from OpenSuse 11.0) using the Remote
    > Desktop Connection tool. RDP to connect to XP and VNC to connect to each
    > OS. For some reason when I connect to OpenSuse it is really really slow,
    > but using RDP to connect to XP is really quick. To setup the vnc I did
    > the following:
    >
    > >

    Code:
    --------------------
    > > dbus-launch vncserver

    --------------------
    > >

    >
    > on the remote host... then in Remote Desktop Connection tool I
    > selected the remote host VNC.
    >
    > It should be as quick as XP or even quicker I would have thought.

    There are options you can use to optimise the connection in VNC. Read
    these:
    man vncserver: 'TightVNC: Manual Page for vncserver(1)'
    (http://www.tightvnc.com/vncserver.1.html)
    man vncviewer: 'TightVNC: Manual Page for vncviewer(1)'
    (http://www.tightvnc.com/vncviewer.1.html)
    and even man xorg-x11-Xvnc: 'TightVNC: Manual Page for Xvnc(1)'
    (http://www.tightvnc.com/Xvnc.1.html)

    It's hard to extract the best combinations of options from them. I'm
    looking at that but won't be finished for quite a while, principally
    because the bugs for VNC in KDE4/Suse are obscuring the problem for me.


    --
    'Drop in and visit some time'
    (http://www.swerdna.net.au/linux.html).
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


  8. #8
    eeijlar NNTP User

    Default Re: VNC on 11.1


    VNC's speed is a shame. I went to a lot of trouble getting 11.1 working
    in work, and a lot of time rooting with a Perl script to access the VPN,
    and now to discover that VNC renders the remote login practically
    useless is dissappointing. I am remote logged into XP at the moment and
    it's as if I was at work. It seems that the protocol windows uses is
    much faster than VNC. It's a pity the same protocol isn't available for
    Linux.


    --
    eeijlar
    ------------------------------------------------------------------------
    eeijlar's Profile: http://forums.opensuse.org/member.php?userid=1504
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


  9. #9
    swerdna NNTP User

    Default Re: VNC on 11.1


    eeijlar;1942792 Wrote:
    > VNC's speed is a shame. I went to a lot of trouble getting 11.1 working
    > in work, and a lot of time rooting with a Perl script to access the VPN,
    > and now to discover that VNC renders the remote login practically
    > useless is dissappointing. I am remote logged into XP at the moment and
    > it's as if I was at work. It seems that the protocol windows uses is
    > much faster than VNC. It's a pity the same protocol isn't available for
    > Linux.

    I'm confused now, too many combinations/permutations. Can you explain
    in more detail the slow connection?
    For the server: the operating system, the Desktop Environment (kde3,
    kde4, gnome), the Desktop Environment being served out, how the server
    is invoked/started.
    For the client: the operating system, the Desktop Environment, the
    client software and how it's started.


    --
    'Drop in and visit some time'
    (http://www.swerdna.net.au/linux.html).
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


  10. #10
    eeijlar NNTP User

    Default Re: VNC on 11.1


    Ok, here it is:

    Note, that the Remote Host is the same machine in both cases running a
    dual boot of XP/Suse


    Code:
    --------------------
    Local Host Remote Host
    Windows Vista -> connecting to -> Windows XP via RD
    Suse 11.0/KDE 4.0 -> connecting to -> Suse 11.1/KDE 4.1 via VNC
    --------------------


    *Remote Host*
    To connect Suse. I logged into the Remote Host via SSH, and started the
    VNC server using:


    Code:
    --------------------
    dbus-launch vncserver
    --------------------


    *
    Local Host*
    Started Remote Desktop (graphical version) for Opensuse... selected VNC
    as the protocol and then put in the ip of the remoted host and the
    DISPLAY.


    Code:
    --------------------
    ip-address:2
    --------------------


    Is this wrong... it was the only way that worked. To connect to XP I
    simply used remote desktop in Vista.


    --
    eeijlar
    ------------------------------------------------------------------------
    eeijlar's Profile: http://forums.opensuse.org/member.php?userid=1504
    View this thread: http://forums.opensuse.org/showthread.php?t=407153


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •