Results 1 to 4 of 4

Thread: make: command not found

  1. #1
    paulm2008 NNTP User

    Default make: command not found


    Hello all. I have just installed OpenSUSE 11.1 on my system.

    If this is the wrong Froum in which to post this then I'm sorry

    Having become rather fed-up with Windows I thought I would look into
    Linux. OpenSUSE appears to be one of the major Linux releases so here
    I'am. Having installed the Operating system [I tried to install via USB
    stick, but for some reason this failed - I do not know why - In the end
    I burnt the iso to CD-R and it worked].

    First thing I have attempted was to install a Widget on the desktop.

    Having downloaded said widget I tried to install the package using the
    install.sh file which accompanied the download. However I receive an
    error message

    "make: command not found"

    Clearly I have to do something else but I do not know what

    Any help would be gratefully received

    Regards

    Paul


    --
    paulm2008
    ------------------------------------------------------------------------
    paulm2008's Profile: http://forums.opensuse.org/member.php?userid=21849
    View this thread: http://forums.opensuse.org/showthread.php?t=407096


  2. #2
    zwenny NNTP User

    Default Re: make: command not found


    First i'd like to say: "Migrating from Windows,
    *good attitude*. Don't give up, if there's something
    more time-consuming than in windows. I know that
    windows often seems to be the easier way, but is
    easier the better way, too..."

    > "make: command not found"


    You haven't the make command installed.
    Install it with YaST:

    1. Menue -> System -> YaST (Administrator Settings)
    2. Enter the root password
    3. Click on "Software Management" in Category "Software"
    4. Choose filter: "Search" and type "make"
    5. Select "make" (make - GNU make),
    so that it's checked with a green tick mark
    6. Click "accept" to finally install it.


    --
    *Oh my God Windows killed zwenny!*
    ------------------------------------------------------------------------
    zwenny's Profile: http://forums.opensuse.org/member.php?userid=14385
    View this thread: http://forums.opensuse.org/showthread.php?t=407096


  3. #3
    paulm2008 NNTP User

    Default Re: make: command not found


    Thank you for the reply. I will give it a try. It does seem odd that
    such functionality [being fundamental to Linux] is not made available
    via the install process. I guess I'm not the first person to encounter
    such problems

    Regards, Paul


    --
    StrikerIIFormula [1901] : Q9450 : 4Gb8500CL5 RAM : SLI8800GTX : 5x500GB
    HDD : VistaUlt64 : OpenSUSE-11.1-KDE : G15Key : G5Mouse : ReadyNAS2250 :
    CanonMX850 : W2252TQ
    ------------------------------------------------------------------------
    paulm2008's Profile: http://forums.opensuse.org/member.php?userid=21849
    View this thread: http://forums.opensuse.org/showthread.php?t=407096


  4. #4
    drem NNTP User

    Default Re: make: command not found


    You need to use make usually only when "compiling", so it's not quite
    fundamental. It is preferred that you install programs using the package
    manager. In case you have to compile them, you have just to install
    these tools (make, gcc, maybe some dev-libraries etc.)

    And another trick (work's best when explaining someone what to do ),
    you can install make by typing this in a terminal:

    Code:
    --------------------

    sudo zypper in make

    --------------------

    and then entering your root password.


    --
    drem
    ------------------------------------------------------------------------
    drem's Profile: http://forums.opensuse.org/member.php?userid=6474
    View this thread: http://forums.opensuse.org/showthread.php?t=407096


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •