Results 1 to 4 of 4

Thread: Language settings under KDE 4.2 / openSUSE 11.1

  1. #1
    homoludens1000 NNTP User

    Default Language settings under KDE 4.2 / openSUSE 11.1


    Oh boy, I don't seem to be able to figure out how the language & local
    setting works under openSUSE 11.1 / KDE 4.2.

    _HERE_IS_HOW_I'D_LIKE_TO_SET_IT_UP:_
    1. Locale: Japan (meaning Yen as currency; Tokyo time zone; comma to
    separate thousands; period as decimal symbol).
    2. Main (=primary?) language: English (US)
    3. Additional languages: Japanese, German, French, English (UK)

    _HERE_IS_WHAT_I'VE_DONE:_
    Opened Yast2 > System > Language.
    Set 'Primary language' to English (US).
    Checked Japanese, German, French, English (UK) under 'Additional
    Languages'.

    Opened Personal Settings > Regions and Language.
    Set 'Country or Region' to Japan.
    Added languages English (UK), Japanese, German, French (in this order).

    _QUESTIONS:_
    1. Why can't I add English (US) as a language in Personal Settings >
    Regions and Language?

    (I checked under Yast: Funny thing, when I choose 'English (US)' as
    Primary Language, I can't add it as an additional language, and it hence
    doesn't appear in the Regions and Language > Add language menu ... )

    2. Why do I get KDE menues in Japanese -despite- the first language of
    the list being 'English (UK)'?

    3. HOW DO I GET THE SETUP I WANT (see above)?!


    --
    homoludens1000
    ------------------------------------------------------------------------
    homoludens1000's Profile: http://forums.opensuse.org/member.php?userid=704
    View this thread: http://forums.opensuse.org/showthread.php?t=406778


  2. #2
    john hudson NNTP User

    Default Re: Language settings under KDE 4.2 / openSUSE 11.1


    You get Japanese because that is the language associated with the
    locale.

    The KDE4 keyboard layout module restricts you to four languages (the
    recommended maximum is three). KDE3 allows you to install more. In fact,
    because I added KDE4 on top of KDE3, I still have five languages
    available. So, it is possible (I don't guarantee it), that if you
    disable the additional languages in KDE4 and install KDE3 to use its
    keyboard layout module, you may be able to get closer to what you want.


    --
    john_hudson
    ------------------------------------------------------------------------
    john_hudson's Profile: http://forums.opensuse.org/member.php?userid=1134
    View this thread: http://forums.opensuse.org/showthread.php?t=406778


  3. #3
    homoludens1000 NNTP User

    Default Re: Language settings under KDE 4.2 / openSUSE 11.1


    John,

    thanks for the reply. Both items sound like bugs to me, or at least
    things that could be improved on. I don't see a reason why locale should
    automatically include language (not to mention multilingual countries
    like Belgium etc.), nor why there should be a limit on the number of
    languages activated. I suppose I'll have to learn now how to file bug
    reports ...

    Hm, I'm also using KDE 4.2 on top of 3.5.10. Will take a look whether I
    can activate more languages, too.


    --
    homoludens1000
    ------------------------------------------------------------------------
    homoludens1000's Profile: http://forums.opensuse.org/member.php?userid=704
    View this thread: http://forums.opensuse.org/showthread.php?t=406778


  4. #4
    homoludens1000 NNTP User

    Default Re: Language settings under KDE 4.2 / openSUSE 11.1


    Ok, so there is definitely a bug, and probably more than one.

    _BUGS_

    (1) In KDE3, the language associated with the locale/country chosen
    should be automatically added on top of the language list. This doesn't
    happen in KDE4.

    (2) Something is wrong with with the link between Yast2 and
    PersonalSettings.
    I've deleted all languages except English (US) and Japanese using Yast2
    > System > Languages. Yet, the 'Add languages' menu in Personal Settings
    > Country & Language gives me 4 options (de, jp, fr, en-uk), but no

    en-us. This shouldn't be.

    (3) The PersonalSettings also don't work without problems. When I put
    Japanese, German, or French on top of the languages list, the menus
    switch to that particular language upon logging back in, no matter what
    the locale is (I've set it to 'Undefined (English)' now).
    However, when I move English-UK to the top, the language set previously
    remains in use.

    _QUESTIONS_

    (1) Can anyone confirm this strange behavior?

    (2) Does anyone know what files store the settings for Yast2 > System >
    Language and for PersonalSettings > Region & Language?

    (3) Is there a way to use the command-line to set the language
    environment (in openSUSE 11.1, KDE 4.2)?

    Cheers,

    homoludens


    --
    homoludens1000
    ------------------------------------------------------------------------
    homoludens1000's Profile: http://forums.opensuse.org/member.php?userid=704
    View this thread: http://forums.opensuse.org/showthread.php?t=406778


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •