Results 1 to 7 of 7

Thread: 11.1/KDE 4.2 Install - KDM gone

  1. #1
    macguru NNTP User

    Default 11.1/KDE 4.2 Install - KDM gone


    I had OpenSuSE 11.1 64-bit and KDE 3.5 (active) and KDE 4.1.3 (not
    used). After KDE 4.2 have been released, I have installed it (from
    factory repo). However, my KDM login screen have gone, and I cannot
    switch session to KDE 4.2. Oddly enough, after KDM fails, I can still
    start KDE 3.5 with "startx".

    Anyone have a clue what might go wrong?

    Thanks in advance for any suggestion(s).


    --
    macguru
    ------------------------------------------------------------------------
    macguru's Profile: http://forums.opensuse.org/member.php?userid=11717
    View this thread: http://forums.opensuse.org/showthread.php?t=406596


  2. #2
    Mark NNTP User

    Default Re: 11.1/KDE 4.2 Install - KDM gone

    macguru wrote:

    >
    > I had OpenSuSE 11.1 64-bit and KDE 3.5 (active) and KDE 4.1.3 (not
    > used). After KDE 4.2 have been released, I have installed it (from
    > factory repo). However, my KDM login screen have gone, and I cannot
    > switch session to KDE 4.2. Oddly enough, after KDM fails, I can still
    > start KDE 3.5 with "startx".
    >
    > Anyone have a clue what might go wrong?
    >
    > Thanks in advance for any suggestion(s).
    >
    >


    Not seen this here but you can have a look in Yast>System>/etc/sysconfig
    editor and see what is set for the window manager, should be:

    startkde4

    Also default desktop manager should be:

    kdm4

    HTH

    --
    Mark

    Nil illegitimi carborundum


  3. #3
    macguru NNTP User

    Default Re: 11.1/KDE 4.2 Install - KDM gone


    Thanks a lot for reply! I have sysconfig values DISPLAYMANAGER -> kdm4
    and DEFAULT_WM -> kde. But the problem is not that I cannot start x.org
    or KDE, but broken KDM. KDM is unable to present list of login users and
    list of WMs at startup.


    --
    macguru
    ------------------------------------------------------------------------
    macguru's Profile: http://forums.opensuse.org/member.php?userid=11717
    View this thread: http://forums.opensuse.org/showthread.php?t=406596


  4. #4
    macguru NNTP User

    Default Re: 11.1/KDE 4.2 Install - KDM gone


    I have checked kdm.log messages and found these error alerts:

    /usr/lib64/kde4/libexec/kdm_greet: symbol lookup error:
    /usr/lib64/libkdeui.so.5: undefined symbol:
    _ZN7QTabBar9hideEventEP10QHideEvent

    /usr/share/kde4/apps/kdm/read_sysconfig.sh: line 75: pam-config:
    command not found
    --------------------------
    rpm -qf /usr/lib64/libkdeui.so.5
    libkde4-4.2.0-83.1

    rpm -qf /usr/share/kde4/apps/kdm/read_sysconfig.sh
    kde4-kdm-4.2.0-183.3

    Both packages have been reinstalled, nothing changed. pam-config RPM
    package IS installed.


    --
    macguru
    ------------------------------------------------------------------------
    macguru's Profile: http://forums.opensuse.org/member.php?userid=11717
    View this thread: http://forums.opensuse.org/showthread.php?t=406596


  5. #5
    Baskitcaise NNTP User

    Default Re: 11.1/KDE 4.2 Install - KDM gone

    macguru wrote:

    >
    > I have checked kdm.log messages and found these error alerts:
    >
    > /usr/lib64/kde4/libexec/kdm_greet: symbol lookup error:
    > /usr/lib64/libkdeui.so.5: undefined symbol:
    > _ZN7QTabBar9hideEventEP10QHideEvent
    >
    > /usr/share/kde4/apps/kdm/read_sysconfig.sh: line 75: pam-config:
    > command not found
    > --------------------------
    > rpm -qf /usr/lib64/libkdeui.so.5
    > libkde4-4.2.0-83.1
    >
    > rpm -qf /usr/share/kde4/apps/kdm/read_sysconfig.sh
    > kde4-kdm-4.2.0-183.3
    >
    > Both packages have been reinstalled, nothing changed. pam-config RPM
    > package IS installed.
    >
    >


    There was a post on the groups a while ago about a similar prob, the
    answer was to re-install the kde-session and the kde libraries `only`
    but that was for KDE4.1.3 IIRC

    YMMV

    HTH
    --
    Mark

    Nil illegitimi carborundum


  6. #6
    anshuljain NNTP User

    Default Re: 11.1/KDE 4.2 Install - KDM gone


    I dont know if I'm facing the same problem...but I installed KDE 4.2
    through Stephan Binner's Live CD on kde.org. I get a KDM which looks the
    same as for KDE3. I've checked my KDM packages and they're all KDE4 and
    not KDE3.

    I tried looking for the packages, the previous poster, had
    mentioned...but couldn't find any. Any help?

    -Anshul


    --
    anshuljain
    ------------------------------------------------------------------------
    anshuljain's Profile: http://forums.opensuse.org/member.php?userid=661
    View this thread: http://forums.opensuse.org/showthread.php?t=406596


  7. #7
    Tom2k NNTP User

    Default Re: 11.1/KDE 4.2 Install - KDM gone


    I've face the same problem due to upgrading from KDE 4.1.3 to KDE 4.2.x,
    but the command startx worked flawlessly. I've managed to solve the
    issue by issuing two commands:

    1. Renaming .kde4 to .kde4-old.
    2. As root Changing directory to /tmp and Deleting KDE and Xorg and
    ICEWM related stuff.

    I've told to my installation to clear the /tmp directory upon every
    reboot.

    Hope this helps.


    --
    Tom2k
    ------------------------------------------------------------------------
    Tom2k's Profile: http://forums.opensuse.org/member.php?userid=2140
    View this thread: http://forums.opensuse.org/showthread.php?t=406596


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •