Results 1 to 2 of 2

Thread: Compiz and GNOME in openSUSE 11.1

  1. #1
    adpads NNTP User

    Default Compiz and GNOME in openSUSE 11.1

    I am working on setting up a new install of openSUSE 11.1 on a Lenovo
    s10e with Intel GMA950 graphics. I have installed compiz and emerald,
    and rolled them back to the versions without the NOMAD patch, from the
    alternate repo.
    TI have not installed any ATI, Nvidia, or XGL packages, but the
    compositing seems to be working fine.

    It has been a bit of trouble getting compiz to work properly.
    For some reason Compiz and emerald seem to work fine in KDE 4, but in
    GNOME (which I intend to use as my default desktop environment), I can
    launch compiz only from a terminal with superuser privilieges, but not
    in the ordinary way.

    If, after booting into GNOME, I issue

    compiz-manager --replace

    from a terminal with super-user privileges, it runs fine. It also works
    fine if I launch simple-ccsm from a super-user terminal and activate
    Compiz that way. But if I run simple-ccsm from the applications menu and
    activate compiz, emerald does not load, windows have no decorations, and
    the screen completely refireshes every couple of seconds. The terminal
    and all the windows disappear and flicker on and off, then the screen
    goes black, and the X session crashes after about 30 seconds. Booting
    back into GNOME, I find the same problem, the screen and the panel keep
    flashing, and the session crashes again.

    Is there some way that I can configure gnome from an xsessions .desktop
    file to load compiz instead of metacity at startup? This is the method i
    have used with other distros in the past, but it seems not to work here.

    Help! What is going on here?

    adpads's Profile:
    View this thread:

  2. #2
    adpads NNTP User

    Default Re: Compiz and GNOME in openSUSE 11.1

    No takers? I am surprised that as a new openSuSE user I have had to face
    this with no help. Seems like a common enough thing I'm trying to

    An update on the above: I figured out that if the compiz settings were
    ok when I ran compiz-manager as root, then all I had to do was copy the
    compiz and emerald settings files from root's home directory to my home
    directory. I also figured out that I didn't have fusion-icon installed.
    Those two things made it work.

    However, I am now booting into compiz with the fusion-icon method, This
    is quiet ugly and slow: after my gnome desktop appears, a few screenlets
    appear, blink on and off, and are eventually relegated to the compiz
    widgets layer when that loads. I have a strong impulse that says this is
    not the best way of going about this, because it takes an extra 20-30
    seconds and looks terrible.
    What's equally bad, in KDE (both 3 and 4) I believe compiz is loading
    as the default manager, and is then loading again with fusion-icon,
    which is set to boot in the sessions.

    I have tried editing an xsessions file to start up compiz that way; I
    can get compiz to load, but then I find that in gnome, my keyboard
    shortcuts don't work. I have configured these in the metacity section of
    gconf-editor and also in the compiz ccsm general settings, and I find
    that they appear just fine in both places but do not function.
    I am so close I can taste it. Help me out, please, someone!
    1) Perhaps there is a way in the "sessions" settings to set fusion-icon
    to load only under gnome?
    2) What is the magic command I need to put in an xsessions script to
    load the compiz-manager correctly?

    Thank you in advance for your help, to anyone!

    adpads's Profile:
    View this thread:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts