Results 1 to 6 of 6

Thread: X server Problem

  1. #1
    Jilly NNTP User

    Default X server Problem


    Hello,

    I dont know wether i chose the right cathegory to poste this, but i
    hope so.

    I have a problem on my Suse 11.0 Machine. I updated yesterday 2
    security updates. They needed a reboot. Now my X server wont start.

    While i start the system i dont get any graphical visualisation, but
    the bootloader. After pressing Alt + F10 i get some messages; some
    things seem normal to me, but then:


    Code:
    --------------------
    powernow-k8: Found 1 AMD Athlon 64Processor 3500+
    powernow-k8: Bios error - no PSB or ACPI _PSS objects
    powernow: This module only works with AMD k7 CPUs
    Jan 25 12:43:12 linux-drim kernel: nf_contrack version 0.5.0(16384buckets, 65536 max)
    Jan 25 12:43:18 linux-drim kernel powernow-k8:Bios error - no PSB or APCI _PSS objects
    Jan 25 12:43:20 localhost kdm [2887]: X server for display :0 terminated unexpectedly
    Jan 25 12:43:20 localhost kdm [2887]:Unable to fire uplocal display :0; dislabeling
    --------------------


    When i try to sart up X server manualy, i get only the message


    Code:
    --------------------
    Jan 25 12:43:20 localhost kdm [2887]: X server for display :0 terminated unexpectedly
    Jan 25 12:43:20 localhost kdm [2887]:Unable to fire uplocal display :0; dislabeling
    --------------------


    As im not very famiiar with the linux console i dont know what i can
    perhaps do.

    Thank you for any help


    --
    Jilly
    ------------------------------------------------------------------------
    Jilly's Profile: http://forums.opensuse.org/member.php?userid=20864
    View this thread: http://forums.opensuse.org/showthread.php?t=405996


  2. #2
    Jilly NNTP User

    Default Re: X server Problem


    'push*


    It would be already very helpful to have a way to get back the system i
    had before the crash.
    Can anyone explain how to do only with the console?


    --
    Jilly
    ------------------------------------------------------------------------
    Jilly's Profile: http://forums.opensuse.org/member.php?userid=20864
    View this thread: http://forums.opensuse.org/showthread.php?t=405996


  3. #3
    baskitcaise NNTP User

    Default Re: X server Problem

    Jilly wrote on Sunday 25 Jan 2009 20:46:

    >
    > 'push*
    >
    >
    > It would be already very helpful to have a way to get back the
    > system i had before the crash.
    > Can anyone explain how to do only with the console?
    >
    >


    What graphics?

    Was the update for the kernel?

    If so and you are using ATI or NVIDIA propriety drivers then you will
    need to re-install them again so they they match the running kernel.

    HTH


    --
    Mark....

    Nil illegitimi carborundum


  4. #4
    Jilly NNTP User

    Default Re: X server Problem


    thanks for your answer

    No was simply a security update. Thats why i dont know what might went
    wrong.

    Im using Nvidia and the driver is installed and runs.

    Is there any posibility to set back the system to an earlier
    configuration?


    --
    Jilly
    ------------------------------------------------------------------------
    Jilly's Profile: http://forums.opensuse.org/member.php?userid=20864
    View this thread: http://forums.opensuse.org/showthread.php?t=405996


  5. #5
    mflexman NNTP User

    Default Re: X server Problem


    Try this.

    11.0 just issued a kernel update and you probably have the proprietary
    drivers for ati or nvidia.

    On the boot screen put 3 on the command line.

    login as root

    goto

    cd /etc/X11
    mv ./xorg.conf ./xorg.conf.bak1
    sax2 -a
    startx

    see if you get a desktop for root, if so a reboot and all should be
    well.

    after that you will need to re-install any proprietary drivers as
    before.

    rgds
    M


    --
    mflexman
    ------------------------------------------------------------------------
    mflexman's Profile: http://forums.opensuse.org/member.php?userid=18952
    View this thread: http://forums.opensuse.org/showthread.php?t=405996


  6. #6
    mflexman NNTP User

    Default Re: X server Problem


    just a thought but if

    sax2 -a

    doesn't help

    try again using

    sax2 -r -m 0=nv

    or possibly

    sax2 -r -m 0=vesa

    should at least get something running.

    rgds
    M


    --
    mflexman
    ------------------------------------------------------------------------
    mflexman's Profile: http://forums.opensuse.org/member.php?userid=18952
    View this thread: http://forums.opensuse.org/showthread.php?t=405996


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •