Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Mingetty not running - no virtual terminals

  1. #1
    certadmin NNTP User

    Default Mingetty not running - no virtual terminals


    Hi, running openSUSE 11.1 on a Dell Optiplex 755.

    I have a problem where mingetty is not running, and therefore I have
    not virtual terminals (text mode consoles). ps shows the following:


    Code:
    --------------------
    #ps -a|grep tty
    2633 tty7 00:00:00 X
    --------------------

    Contents of /etc/inittab include the correct commands:

    Code:
    --------------------
    #grep mingetty /etc/inittab
    1:2345:respawn:/sbin/mingetty --noclear tty1
    2:2345:respawn:/sbin/mingetty tty2
    3:2345:respawn:/sbin/mingetty tty3
    4:2345:respawn:/sbin/mingetty tty4
    5:2345:respawn:/sbin/mingetty tty5
    6:2345:respawn:/sbin/mingetty tty6
    --------------------

    The logs don't seem much help:

    Code:
    --------------------
    #grep mingetty /var/log/*
    --------------------

    Returns nothing

    Code:
    --------------------
    #dmesg|grep tty
    console [tty0] enabled
    serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    00:07: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    0000:00:03.3: ttyS4 at I/O 0xec98 (irq = 17) is a 16550A

    --------------------

    Any ideas are welcome!


    --
    certadmin
    ------------------------------------------------------------------------
    certadmin's Profile: http://forums.opensuse.org/member.php?userid=20778
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


  2. #2
    ken yap NNTP User

    Default Re: Mingetty not running - no virtual terminals


    What happens if you try running mingetty manually, just to check?

    # /sbin/mingetty tty2

    Any errors? Did a login show up on VT2?


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


  3. #3
    certadmin NNTP User

    Default Re: Mingetty not running - no virtual terminals


    Thanks for such a quick response!

    The only option I have is to run it from a kterm:

    Code:
    --------------------
    #mingetty tty2
    Warning: Program '/bin/bash' crashed.
    --------------------


    And the following in /var/log/warn:

    Code:
    --------------------
    Jan 24 11:15:14 CC014 mingetty[6364]: mingetty: /dev/tty2: cannot get controlling tty: Operation not permitted
    --------------------


    Which I think is more to do with the fact that Bash crashed rather than
    mingetty?

    Similar results with tty1, 3, 4 etc.


    --
    certadmin
    ------------------------------------------------------------------------
    certadmin's Profile: http://forums.opensuse.org/member.php?userid=20778
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


  4. #4
    ken yap NNTP User

    Default Re: Mingetty not running - no virtual terminals


    What are the owner and group of the /dev/tty[1-6] devices?

    Mine are root,tty for reference.


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


  5. #5
    certadmin NNTP User

    Default Re: Mingetty not running - no virtual terminals


    Yep, mine are also root:tty (except tty7 which is owned by my user
    login).

    Permissions are 660 for interest


    --
    certadmin
    ------------------------------------------------------------------------
    certadmin's Profile: http://forums.opensuse.org/member.php?userid=20778
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


  6. #6
    ken yap NNTP User

    Default Re: Mingetty not running - no virtual terminals


    Sorry, I don't see anything obviously wrong. Maybe the next step is to
    strace mingetty.

    strace /sbin/mingetty /dev/tty2


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


  7. #7
    certadmin NNTP User

    Default Re: Mingetty not running - no virtual terminals


    wow - I have not used strace before, give a lot of info. Should I post
    the whole output here?

    The last few lines before the crash are:


    Code:
    --------------------
    chown("/dev/tty2", 0, 5) = 0
    chmod("/dev/tty2", 0660) = 0
    rt_sigaction(SIGHUP, {0x1, [], SA_RESTORER, 0x7f4805e5d6e0}, {SIG_DFL, [], 0}, 8) = 0
    rt_sigaction(SIGQUIT, {0x402020, [], SA_RESTORER, 0x7f4805e5d6e0}, NULL, 8) = 0
    open("/dev/tty2", O_RDWR) = 3
    ioctl(3, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
    vhangup(

    Warning: Program '/bin/bash' crashed.
    --------------------


    Will try to reboot into safe mode and see if there are differences.


    --
    certadmin
    ------------------------------------------------------------------------
    certadmin's Profile: http://forums.opensuse.org/member.php?userid=20778
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


  8. #8
    ken yap NNTP User

    Default Re: Mingetty not running - no virtual terminals


    The thing is, it shouldn't even be calling /bin/bash at that stage. It
    first has to call /bin/login to get the user name and password before
    creating a shell for the user.


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


  9. #9
    certadmin NNTP User

    Default Re: Mingetty not running - no virtual terminals


    Sorry, that message is not part of the strace output, its generated by
    konsole.

    Failsafe mode didn't help, but if I type:

    Code:
    --------------------
    #init 3
    --------------------

    in a konsole window then X and kdm are killed (obviously) but the tty's
    start up!
    Returning to init 5 restarts kdm and the tty's still run.

    I have checked /etc/inittab (see first post) and both runlevels 3 and 5
    are configured.

    There is nothing obvious in the runlevel editor or /etc/sysconfig
    editor - but I wonder is this a security feature? i.e. no text logins in
    graphic mode by default?

    Odd eh?


    --
    certadmin
    ------------------------------------------------------------------------
    certadmin's Profile: http://forums.opensuse.org/member.php?userid=20778
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


  10. #10
    ken yap NNTP User

    Default Re: Mingetty not running - no virtual terminals


    No, according to inittab the vttys are active in both levels 3 and 5.
    Does this reliably happen at boot or was it just that time it went
    wrong? If you cannot repeat the problem then just write it off as one of
    those things.


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=405899


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •