Results 1 to 6 of 6

Thread: zypper/suse-updater help please

  1. #1
    cybertaz NNTP User

    Default zypper/suse-updater help please


    I had this same problem for a little while. I got a new HD and thought a
    fresh install would fix it. But it didn't.

    I have two recommended updates that will not update. They are:
    fileshareset and kdenetworkmanager3-InstantMessenger.

    Here is the out put of zypper -n -vv up:

    Code:
    --------------------
    Verbosity: 2
    Entering non-interactive mode.
    Initializing Target
    Checking whether to refresh metadata for KDE4 Desktop
    Checking whether to refresh metadata for openSUSE-11.0-Non-Oss
    Checking whether to refresh metadata for KDE4 Extra Apps
    Checking whether to refresh metadata for KDE4 Community
    Checking whether to refresh metadata for Packman
    Checking whether to refresh metadata for Main Update Repository
    Checking whether to refresh metadata for KDE4 Compiz
    Checking whether to refresh metadata for openSUSE-11.0-Oss
    Reading installed packages...
    Force resolution: No
    Resolving dependencies...
    Force resolution: No
    Resolving dependencies...

    The following NEW patches are going to be installed:
    fileshareset-124.noarch (Main Update Repository, maint-coord@suse.de)
    kdenetwork3-InstantMessenger-235.noarch (Main Update Repository, maint-coord@suse.de)


    No additional space will be used or freed after the operation.
    
    Continue? [YES/no]: yes
    committing
    committingCommitResult 2 (errors 0, remaining 0, srcremaining 0)
    --------------------


    Output from zypper -vv lu:

    Code:
    --------------------
    Verbosity: 2
    Initializing Target
    Checking whether to refresh metadata for KDE4 Desktop
    Checking whether to refresh metadata for openSUSE-11.0-Non-Oss
    Checking whether to refresh metadata for KDE4 Extra Apps
    Checking whether to refresh metadata for KDE4 Community
    Checking whether to refresh metadata for Packman
    Checking whether to refresh metadata for Main Update Repository
    Checking whether to refresh metadata for KDE4 Compiz
    Checking whether to refresh metadata for openSUSE-11.0-Oss
    Reading installed packages...
    Force resolution: No
    Resolving dependencies...
    Patches

    [?1034hRepository | Name | Version | Category | Status
    -----------------------+------------------------------+---------+-------------+-------
    Main Update Repository | fileshareset | 124 | recommended | Needed
    Main Update Repository | kdenetwork3-InstantMessenger | 235 | recommended | Needed
    --------------------


    Is there anything else that might be needed to try and get rid of this?


    --
    '' (http://userbars.org)AMD64-X2 4200+, NVIDIA 8500GTx2 (twinview mode),
    2 GB Ram
    ------------------------------------------------------------------------
    cybertaz's Profile: http://forums.opensuse.org/member.php?userid=123
    View this thread: http://forums.opensuse.org/showthread.php?t=405792


  2. #2
    caf4926 NNTP User

    Default Re: zypper/suse-updater help please


    This is a bug.
    Mark as DO NOT INSTALL

    or just don't use the updater app. Use Yast Software Management


    --
    Box: Linux 2.6.27.7-9 i686 | OS 11.1 | (KDE4.1.96) "78.1"rc1 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE4.1.96)"78.1"rc1 | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=405792


  3. #3
    cybertaz NNTP User

    Default Re: zypper/suse-updater help please


    Do you have link to the bug report?

    Thanks.


    --
    '' (http://userbars.org)AMD64-X2 4200+, NVIDIA 8500GTx2 (twinview mode),
    2 GB Ram
    ------------------------------------------------------------------------
    cybertaz's Profile: http://forums.opensuse.org/member.php?userid=123
    View this thread: http://forums.opensuse.org/showthread.php?t=405792


  4. #4
    caf4926 NNTP User

    Default Re: zypper/suse-updater help please


    This is it I think

    https://bugzilla.novell.com/show_bug.cgi?id=447986


    --
    Box: Linux 2.6.27.7-9 i686 | OS 11.1 | (KDE4.1.96) "78.1"rc1 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE4.1.96)"78.1"rc1 | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=405792


  5. #5
    deano ferrari NNTP User

    Default Re: zypper/suse-updater help please


    Thanks for bug report link. I see the dev team have recently released a
    patch to fix this 'solver' issue for opensuse 11.0

    Fix involves adding this repo:

    zypper ar 'Index of /update/11.0-test'
    (http://download.opensuse.org/update/11.0-test/) patch

    Then

    zypper ref
    zypper up -t patch

    This gave me:

    > Reading installed packages...
    >
    > The following packages are going to be upgraded:
    > satsolver-tools yast2-pkg-bindings libzypp yast2-qt-pkg
    > yast2-ncurses-pkg
    >
    >
    > The following NEW patch is going to be installed:
    > gnome-packagekit
    >
    >
    > Overall download size: 2.7 M. After the operation, additional 4.0 K
    > will be used.
    > Continue? [YES/no]: YES
    >



    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=405792


  6. #6
    cybertaz NNTP User

    Default Re: zypper/suse-updater help please


    Thanks, installed it and it seems to be working now.


    --
    '' (http://userbars.org)AMD64-X2 4200+, NVIDIA 8500GTx2 (twinview mode),
    2 GB Ram
    ------------------------------------------------------------------------
    cybertaz's Profile: http://forums.opensuse.org/member.php?userid=123
    View this thread: http://forums.opensuse.org/showthread.php?t=405792


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •