Results 1 to 4 of 4

Thread: DVD drive hangs while installing software

  1. #1
    lopax NNTP User

    Default DVD drive hangs while installing software


    I hope this is the right forums for this question.

    I am trying to install extras software from the opensuse 11.1 DVD but
    it hangs. Here is the info Yast2 log shows.

    1> linux-bhhn(4515) [zypp++] MediaCD.cc(attachTo):293 next 0 last -1
    last tried -1
    2009-01-23 00:41:32 <1> linux-bhhn(4515) [zypp++]
    MediaCD.cc(detectDevices):231 Found 1 cdrom drive udis
    2009-01-23 00:41:32 <1> linux-bhhn(4515) [zypp++]
    MediaCD.cc(detectDevices):261 Found
    /org/freedesktop/Hal/devices/storage_model_CDDVDW_TS_L633L:
    cdrom</dev/sr0[11,0]>
    2009-01-23 00:41:32 <1> linux-bhhn(4515) [zypp++]
    MediaCD.cc(attachTo):358 count 0
    2009-01-23 00:41:32 <2> linux-bhhn(4515) [zypp]
    MediaCD.cc(closeTray):205 Close tray /dev/sr0 failed (Input/output
    error)
    2009-01-23 00:41:32 <1> linux-bhhn(4515) [zypp++]
    MediaHandler.cc(createAttachPoint):393 Trying to create attach point in
    /var/adm/mount
    2009-01-23 00:41:32 <1> linux-bhhn(4515) [zypp]
    PathInfo.cc(_Log_Result):292 mkdir /var/adm/mount/AP_0x00000003 00755
    2009-01-23 00:41:32 <1> linux-bhhn(4515) [zypp]
    MediaHandler.cc(createAttachPoint):370 Created default attach point
    /var/adm/mount/AP_0x00000003
    2009-01-23 00:41:32 <1> linux-bhhn(4515) [zypp++]
    ExternalProgram.cc(start_program):210 Executing '/bin/mount' '-t'
    'iso9660' '-o' 'ro' '/dev/sr0' '/var/adm/mount/AP_0x00000003'
    2009-01-23 00:41:32 <1> linux-bhhn(4515) [zypp++]
    ExternalProgram.cc(start_program):354 pid 4668 launched


    Also when I click the cdrom icon on mycomputer, I get the warning
    window saying "you can stop this operation by clicking cancle", and
    then another window pops up saying "Unable to mount(Dbus error
    org.freedesktop.dbus, did not receive any reply, possible causes: remote
    application did not send any reply)

    Please any help would be appreciated.


    --
    lopax
    ------------------------------------------------------------------------
    lopax's Profile: http://forums.opensuse.org/member.php?userid=19583
    View this thread: http://forums.opensuse.org/showthread.php?t=405790


  2. #2
    caf4926 NNTP User

    Default Re: DVD drive hangs while installing software


    Have you done this:

    YAST >> Security and Users >> User Management >> "select your user" >>
    Edit >> Details >> Groups >> check "cdrom" and "disk" and then click on
    "ACCEPT".


    --
    Box: Linux 2.6.27.7-9 i686 | OS 11.1 | (KDE4.1.96) "78.1"rc1 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE4.1.96)"78.1"rc1 | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=405790


  3. #3
    lopax NNTP User

    Default Re: DVD drive hangs while installing software


    caf4926;1932285 Wrote:
    > Have you done this:
    >
    > YAST >> Security and Users >> User Management >> "select your user" >>
    > Edit >> Details >> Groups >> check "cdrom" and "disk" and then click on
    > "ACCEPT".


    Hi,
    I was already in disk and cdrom groups. Then I added myself to every
    possible to groups and still same errors.

    I think it has to do something with hal and Dbus.

    Any other suggestion, please.


    --
    lopax
    ------------------------------------------------------------------------
    lopax's Profile: http://forums.opensuse.org/member.php?userid=19583
    View this thread: http://forums.opensuse.org/showthread.php?t=405790


  4. #4
    lopax NNTP User

    Default Re: DVD drive hangs while installing software


    lopax;1933032 Wrote:
    > Hi,
    > I was already in disk and cdrom groups. Then I added myself to every
    > possible to groups and still same errors.
    >
    > I think it has to do something with hal and Dbus.
    >
    > Any other suggestion, please.


    Hello community,
    Any sugggestion on this problem... please...


    --
    lopax
    ------------------------------------------------------------------------
    lopax's Profile: http://forums.opensuse.org/member.php?userid=19583
    View this thread: http://forums.opensuse.org/showthread.php?t=405790


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •