Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: NVIDIA driver problem

  1. #11
    Fredczhy NNTP User

    Default Re: NVIDIA driver problem


    When I installed the drivers with the NVIDIA script, I switched to
    runlevel 3 (with the "init 3" command). I have also tried running the
    script with " -K", but that gave me a error in the end.


    --
    Fredczhy
    ------------------------------------------------------------------------
    Fredczhy's Profile: http://forums.opensuse.org/member.php?userid=19643
    View this thread: http://forums.opensuse.org/showthread.php?t=405532


  2. #12
    ram88 NNTP User

    Default Re: NVIDIA driver problem


    Fredczhy;1931271 Wrote:
    > When I installed the drivers with the NVIDIA script, I switched to
    > runlevel 3 (with the "init 3" command). I have also tried running the
    > script with " -K", but that gave me a error in the end.

    So, that's the problem. What is that error message? Are you have
    kernel-sources / header, gcc installed?


    --
    http://yami.googlecode.com/
    http://akoskm.blogspot.com/
    ------------------------------------------------------------------------
    ram88's Profile: http://forums.opensuse.org/member.php?userid=1058
    View this thread: http://forums.opensuse.org/showthread.php?t=405532


  3. #13
    Fredczhy NNTP User

    Default Re: NVIDIA driver problem


    I have the kernel-source and kernel-headers for my current kernel
    version along with the newest gcc installed. The error that the NVIDIA
    script displays is:
    Code:
    --------------------
    ERROR: The file '/lib/modules/2.6.25.20-0.1-default/kernel/drivers/video/nvidia.ko` already exists as part of this driver installation.

    --------------------

    On the next screen it says:
    Code:
    --------------------
    ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

    --------------------


    --
    Fredczhy
    ------------------------------------------------------------------------
    Fredczhy's Profile: http://forums.opensuse.org/member.php?userid=19643
    View this thread: http://forums.opensuse.org/showthread.php?t=405532


  4. #14
    ram88 NNTP User

    Default Re: NVIDIA driver problem


    Fredczhy;1931313 Wrote:
    > I have the kernel-source and kernel-headers for my current kernel
    > version along with the newest gcc installed. The error that the NVIDIA
    > script displays is: >

    Code:
    --------------------
    > > ERROR: The file '/lib/modules/2.6.25.20-0.1-default/kernel/drivers/video/nvidia.ko` already exists as part of this driver installation.

    >

    --------------------
    > >

    > On the next screen it says: >

    Code:
    --------------------
    > > ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

    >

    --------------------
    > >

    Try to rename the nvidia.ko and move the entire nvidia file/directory
    with:

    Code:
    --------------------

    mv nvidia.ko nvidia.ko_old
    mv nvidia/ nvidia_old/

    --------------------

    in directory */lib/modules/2.6.25.20-0.1-default/kernel/drivers/video/*
    and try to install it again. Maybe som junk files are left after the
    last unsuccessful installation.
    Good luck.


    --
    http://yami.googlecode.com/
    http://akoskm.blogspot.com/
    ------------------------------------------------------------------------
    ram88's Profile: http://forums.opensuse.org/member.php?userid=1058
    View this thread: http://forums.opensuse.org/showthread.php?t=405532


  5. #15
    Fredczhy NNTP User

    Default Re: NVIDIA driver problem


    I renamed the nvidia.ko and nvidia folder, and ran the script again, and
    got it working fine after a reboot.
    Thanks!


    --
    Fredczhy
    ------------------------------------------------------------------------
    Fredczhy's Profile: http://forums.opensuse.org/member.php?userid=19643
    View this thread: http://forums.opensuse.org/showthread.php?t=405532


  6. #16
    ram88 NNTP User

    Default Re: NVIDIA driver problem


    Fredczhy;1931403 Wrote:
    > I renamed the nvidia.ko and nvidia folder, and ran the script again, and
    > got it working fine after a reboot.
    > Thanks!

    Glad to hear!
    Thank you for posting back.


    --
    http://yami.googlecode.com/
    http://akoskm.blogspot.com/
    ------------------------------------------------------------------------
    ram88's Profile: http://forums.opensuse.org/member.php?userid=1058
    View this thread: http://forums.opensuse.org/showthread.php?t=405532


Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •