Results 1 to 10 of 10

Thread: virtualbox

  1. #1
    randomguy NNTP User

    Default virtualbox


    hi, i installed virtualbox and it works as root but not my user. says
    permissions denied.

    i added my user to the group vboxusers but it still is a no go.

    works fine as root

    i followed the guide here

    'Tutorial : VirtualBox on openSUSE 11.1 Part 1 | Spirit of Change'
    (http://tinyurl.com/9pd25q)

    any ideas?


    --
    randomguy
    ------------------------------------------------------------------------
    randomguy's Profile: http://forums.opensuse.org/member.php?userid=20415
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


  2. #2
    caf4926 NNTP User

    Default Re: virtualbox


    Check here
    'VirtualBox Installation - openSUSE'
    (http://en.opensuse.org/VirtualBox_Installation)

    If using OSE you might want to add this repo and update
    'Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.1'
    (http://tinyurl.com/a72es3)

    You should not be runnin as root!

    Try rebooting.


    --
    Box: Linux 2.6.27.7-9 i686 | OS 11.1 | (KDE4.1.96) "78.1"rc1 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE4.1.96)"78.1"rc1 | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


  3. #3
    freedguy NNTP User

    Default Re: virtualbox


    Did you reboot your system after adding user to vboxusers group?


    --
    freedguy
    ------------------------------------------------------------------------
    freedguy's Profile: http://forums.opensuse.org/member.php?userid=11067
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


  4. #4
    ken yap NNTP User

    Default Re: virtualbox


    Logging out and back in again is sufficient.


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


  5. #5
    hank se NNTP User

    Default Re: virtualbox


    Remove /tmp/.vbox-*-ipc/ and retry running it as your ordinary
    user.


    --
    hank_se
    ------------------------------------------------------------------------
    hank_se's Profile: http://forums.opensuse.org/member.php?userid=202
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


  6. #6
    vavai NNTP User

    Default Re: virtualbox


    randomguy;1930443 Wrote:
    > hi, i installed virtualbox and it works as root but not my user. says
    > permissions denied.
    >
    > i added my user to the group vboxusers but it still is a no go.
    >
    > works fine as root
    >
    > i followed the guide here
    >
    > 'Tutorial : VirtualBox on openSUSE 11.1 Part 1 | Spirit of Change'
    > (http://tinyurl.com/9pd25q)
    >
    > any ideas?


    Take a look to another article : 'Solved : VirtualBox Permission
    Problem with Normal User | Spirit of Change' (http://tinyurl.com/9r9d5h)


    --
    ---
    Vavai - http://tinyurl.com/ax69da
    http://www.vavai.net
    http://www.vavai.com/blog
    http://www.opensuse.or.id
    ------------------------------------------------------------------------
    vavai's Profile: http://forums.opensuse.org/member.php?userid=334
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


  7. #7
    randomguy NNTP User

    Default Re: virtualbox


    awesome, it worked out great. thanks for your help.


    --
    randomguy
    ------------------------------------------------------------------------
    randomguy's Profile: http://forums.opensuse.org/member.php?userid=20415
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


  8. #8
    randomguy NNTP User

    Default Re: virtualbox


    oh one more thing:

    i have lots of virtualbox virtual machines on my hard drive from a
    previous installation.

    any way i can import those into my current virtual box installation?


    --
    randomguy
    ------------------------------------------------------------------------
    randomguy's Profile: http://forums.opensuse.org/member.php?userid=20415
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


  9. #9
    hank se NNTP User

    Default Re: virtualbox


    In your home directory you have a hidden directory .VirtualBox,
    all your machines are contained in there. Take a look at that
    directory and I'm sure you'll understand how to manage that.
    I'm old and lazy and have only one virtual machine so I always
    keep a couple of copys of that directory on an external hard
    drive, different instances. That way I can restore them on a
    new installation, and also roll back to a previos instance should
    something nasty happen to my XP-machine. Back up the XP-machine
    you already have and feel free to experiment.


    --
    hank_se
    ------------------------------------------------------------------------
    hank_se's Profile: http://forums.opensuse.org/member.php?userid=202
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


  10. #10
    caf4926 NNTP User

    Default Re: virtualbox


    randomguy;1930909 Wrote:
    > oh one more thing:
    >
    > i have lots of virtualbox virtual machines on my hard drive from a
    > previous installation.
    >
    > any way i can import those into my current virtual box installation?


    Select create New machine and then point it to the VDI file of the
    machine from your old files. Ideally you want to have already put the
    old VDI files in your current VDI location. Which as has been mentioned
    is by default it your hidden folders under your username.


    --
    Box: Linux 2.6.27.7-9 i686 | OS 11.1 | (KDE4.1.96) "78.1"rc1 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE4.1.96)"78.1"rc1 | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=405488


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •