Results 1 to 4 of 4

Thread: What is wrong with YAST?

  1. #1
    vilanye NNTP User

    Default What is wrong with YAST?


    The update mechanism is acting very strangely. Well, it would be strange
    if it wasn't YAST.

    When I installed 11.1 with KDE 3, I didn't install Amarok, Amarok-xine,
    etc with the broken nonsense supplied on the DVD. I installed from
    packman. Everything works well, but YAST put itself into a circle.

    Every update it asks to "update" Amarok, xine and the dependencies,
    even though it isn't an update. It jumps between a version that uses
    libmad0, amarok-packman, etc. If I install that, the next time it wants
    to delete all of that and install the version that existed before the
    last "update".

    For fun I can sit here for an hour, uninstalling and installing the
    exact same versions. If I tell YAST to never update, it still throws up
    it lame dependency resolver.

    Is there a fix for this comical problem?


    --
    vilanye
    ------------------------------------------------------------------------
    vilanye's Profile: http://forums.opensuse.org/member.php?userid=1410
    View this thread: http://forums.opensuse.org/showthread.php?t=405463


  2. #2
    Uwe Buckesfeld NNTP User

    Default Re: What is wrong with YAST?

    * vilanye,

    I don't know what's wrong, but here's how you should be able to fix it:
    Yast, Software, Software repositories. Locate the repo which has the version of Amarok you want to *keep* (I assume this will be Packman), edit it and push the priority from 99 to >100.

    Uwe

  3. #3
    vilanye NNTP User

    Default Re: What is wrong with YAST?


    Thank you.

    I read up a little on priorities, and maybe I am just thinking upside
    down. It is 99 now, if I change it to say, 101, the priority will be
    lower. To me that sounds like any package matching amarok outside of
    packman will be offered thus stopping the circle, but giving me a broken
    Amarok version.


    --
    vilanye
    ------------------------------------------------------------------------
    vilanye's Profile: http://forums.opensuse.org/member.php?userid=1410
    View this thread: http://forums.opensuse.org/showthread.php?t=405463


  4. #4
    caf4926 NNTP User

    Default Re: What is wrong with YAST?


    Maybe there is some confusion but to set a higher priority the number is
    lower.

    eg; if you set all to 99 default and packman to 20 - packman would have
    priority.

    I personally have all mine to 99 as I manage many repo's from Factory
    too and never use the updater, but manage everything from zypper or
    software management.


    --
    Box: Linux 2.6.27.7-9 i686 | OS 11.1 | (KDE4.1.96) "78.1"rc1 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE4.1.96)"78.1"rc1 | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=405463


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •