Results 1 to 8 of 8

Thread: Can't mount 720k floppy in 11.1

  1. #1
    Mike unique NNTP User

    Default Can't mount 720k floppy in 11.1


    OpenSUSE 11.1 64 bit w/ KDE 3.5

    When I try and mount a 720k IBM FAT formatted floppy using a right
    click on the floppy desktop icon , then left click mount, after a delay
    I get this error window:

    ERROR-KIO_MEDIA_MOUNTHELPER
    MOUNT: YOU MUST SPECIFY THE FILESYSTEM TYPE

    Fedora Core 8 with KDE mounts and read/writes this floppy, Windown 2000
    Pro SP 4 read/writes this floppy. OpenSUSE 11.0 32 bit KDE has the same
    error.

    I can mount 1.44 mb floppies in both of the above OpenSUSE releases.

    Before you tell me how old 720k floppies are, please note that I have
    perfectly working logic analyzers that are stuck with these old floppies
    as their only portable storage media.


    --
    Mike_unique
    ------------------------------------------------------------------------
    Mike_unique's Profile: http://forums.opensuse.org/member.php?userid=17820
    View this thread: http://forums.opensuse.org/showthread.php?t=405371


  2. #2
    arcull NNTP User

    Default Re: Can't mount 720k floppy in 11.1


    Hi, you could try to specify filesystem type via vfstype parameter,
    check 'mount(8): mount file system - Linux man page'
    (http://linux.die.net/man/8/mount)


    --
    arcull
    ------------------------------------------------------------------------
    arcull's Profile: http://forums.opensuse.org/member.php?userid=11668
    View this thread: http://forums.opensuse.org/showthread.php?t=405371


  3. #3
    Mike unique NNTP User

    Default Re: Can't mount 720k floppy in 11.1


    I already looked at mount(8) and fat12, fat16 and fat32 are all fat, and
    fat is part of msdos, umsdos and vfat. Since the mount operation is
    embedded with the supplied floppy desktop icon, I would rather see it
    work like it already works in Fedora 8. That is why I didn't try
    manually mounting it before.

    Just to make sure mount works under SUSE I did manually mount the 720
    kb floppy and it worked without complaint:
    mount -v -t vfat /dev/fd0 /media

    However, this SUSE mount:
    mount -v -t auto /dev/fd0 /media
    failed with this error:
    Code:
    --------------------
    mount: you must specify the filesystem type
    --------------------

    So I tried this on the Fedora 8 box:
    mount -v -t auto /dev/fd0 /media
    and because of the -v it had these messages:
    Code:
    --------------------
    mount: you didn't specify a filesystem type for /dev/fd0
    I will try type vfat
    --------------------
    It works on the Fedora box. Don't tell me SUSE has broken something in
    mount(8)?

    I suppose the work around is to start a root shell and manually mount
    and unmount these 720 kb floppies every time from the shell. What a
    royal pain in the rear!

    BTW, the floppy desktop icon doesn't show the manually mounted floppy
    as mounted, but it opens it with a message that is it already mounted.


    --
    Mike_unique
    ------------------------------------------------------------------------
    Mike_unique's Profile: http://forums.opensuse.org/member.php?userid=17820
    View this thread: http://forums.opensuse.org/showthread.php?t=405371


  4. #4
    Mike unique NNTP User

    Default Re: Can't mount 720k floppy in 11.1


    I changed the title and bumped this.


    --
    Mike_unique
    ------------------------------------------------------------------------
    Mike_unique's Profile: http://forums.opensuse.org/member.php?userid=17820
    View this thread: http://forums.opensuse.org/showthread.php?t=405371


  5. #5
    ErikEngerd NNTP User

    Default Re: Can't mount 720k floppy in 11.1


    I have a similar problem. On one machine (Pentium 4) I have both SuSE
    Linux 10.1 and Open SuSE 11.1 installed.

    The floppy mounts fine on 10.1 with

    mount /dev/fd0 /mnt/floppy

    On 11.1 I get
    >
    > mount: you must specify the filesystem type
    >


    and if I specify the file type using
    >
    > mount -v -t vfat /dev/fd0 /mnt/floppy/
    >

    I get the following message:

    >
    > mount: /dev/fd0: can't read superblock
    >


    It looks like something is broken in 11.1. Still floppy support would
    be good to have because it can be useful (such as for writing firmware
    updates for the motherboard on it).

    Cheers
    Erik


    --
    ErikEngerd
    ------------------------------------------------------------------------
    ErikEngerd's Profile: http://forums.opensuse.org/member.php?userid=20652
    View this thread: http://forums.opensuse.org/showthread.php?t=405371


  6. #6
    ken yap NNTP User

    Default Re: Can't mount 720k floppy in 11.1


    I think that a few people discovered that autodetection of fstype
    doesn't work with 720k floppies. Just file a bug at bugzilla.novell.com
    and see the devs say.


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=405371


  7. #7
    john hudson NNTP User

    Default Re: Can't mount 720k floppy in 11.1


    For anyone who has not installed openSuSE, I found many versions ago
    that plugging in the floppy drive while installing avoided this problem.
    I've just tried it and my floppy was recognised and read immediately.

    It appears as user messagebus, group root and all the files on the disk
    can be opened.

    I hope this information may help those who understand things better
    than I do to suggest a solution.


    --
    john_hudson
    ------------------------------------------------------------------------
    john_hudson's Profile: http://forums.opensuse.org/member.php?userid=1134
    View this thread: http://forums.opensuse.org/showthread.php?t=405371


  8. #8
    ErikEngerd NNTP User

    Default Re: Can't mount 720k floppy in 11.1


    ErikEngerd;1941399 Wrote:
    > I have a similar problem. On one machine (Pentium 4) I have both SuSE
    > Linux 10.1 and Open SuSE 11.1 installed.
    >
    > The floppy mounts fine on 10.1 with
    >
    > mount /dev/fd0 /mnt/floppy
    >
    > On 11.1 I get
    >
    >
    > and if I specify the file type using
    >
    > I get the following message:
    >
    >
    >
    > It looks like something is broken in 11.1. Still floppy support would
    > be good to have because it can be useful (such as for writing firmware
    > updates for the motherboard on it).
    >
    > Cheers
    > Erik


    I made some progress. I was seeing this problem when running the xen
    kernel. Nevertheless, switching to the pae kernel solved the problem.

    Therefore, I am seeing another issue which is that the floppy drive
    apparently does not work in a xen kernel.


    --
    ErikEngerd
    ------------------------------------------------------------------------
    ErikEngerd's Profile: http://forums.opensuse.org/member.php?userid=20652
    View this thread: http://forums.opensuse.org/showthread.php?t=405371


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •