Results 1 to 3 of 3

Thread: try to use a local website

  1. #1
    collinm NNTP User

    Default try to use a local website


    hi

    i try to run a website with opensuse 11.1, apache

    under /srv/www/htdocs i have a web site (who use cakephp)

    i have a .htaccess file that its content


    Code:
    --------------------

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /app/
    RewriteRule ^$ webroot/ [L]
    RewriteRule ^(.*) webroot/$1 [L]
    </IfModule>

    --------------------


    i have in /etc/apache2/default-server.conf


    Code:
    --------------------

    <Directory "/srv/www/htdocs">
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    ]
    <Directory />
    Options None
    AllowOverride None
    Order deny,allow
    Deny from all
    </Directory>

    --------------------


    in /etc/apache2/httpd.conf


    Code:
    --------------------

    # use .htaccess files for overriding,
    AccessFileName .htaccess
    # and never show them
    <Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    </Files>

    # List of resources to look for when the client requests a directory
    DirectoryIndex index.html index.html.var indexp.php

    --------------------

    i add rewrite to APACHE_MODULES in /etc/sysconfig/apache2

    when i start the web site i get

    Apache 403 Forbidden Error

    any idea?


    --
    collinm
    ------------------------------------------------------------------------
    collinm's Profile: http://forums.opensuse.org/member.php?userid=3366
    View this thread: http://forums.opensuse.org/showthread.php?t=405198


  2. #2
    geoffro NNTP User

    Default Re: try to use a local website


    It's a permissions problem.
    There is a solution guide 'here'
    (http://www.cyberciti.biz/faq/apache-...-and-solution/)
    change the paths as required

    /Geoff


    --
    Core 2 Duo 3.16GHz, 4GB DDR2, 2.5TB, GeForce 7600 GS, OS 11.1
    x86_64, KDE4.2 RC1 (77.1) 'Smolt specs' (http://tinyurl.com/9hgxhl)
    ------------------------------------------------------------------------
    geoffro's Profile: http://forums.opensuse.org/member.php?userid=75
    View this thread: http://forums.opensuse.org/showthread.php?t=405198


  3. #3
    freedguy NNTP User

    Default Re: try to use a local website


    Lets do it via GUI (thanks to YaST)

    Go to YaSt --> Network Services --> HTTP Server --> Main Host -->
    Directory --> Edit

    Options --> Edit --> Change "None" to "Indexes"

    Allowoverride --> Edit --> Change "None" to "All"

    Order --> Edit --> Change the order from "Deny,Allow" to
    "Allow,Deny"

    Allow --> Edit --> "from all"

    Restart Apache.


    --
    freedguy
    ------------------------------------------------------------------------
    freedguy's Profile: http://forums.opensuse.org/member.php?userid=11067
    View this thread: http://forums.opensuse.org/showthread.php?t=405198


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •