Results 1 to 10 of 10

Thread: kdesu not accepting my root password

  1. #1
    hieronymous NNTP User

    Default kdesu not accepting my root password


    I'm using openSUSE 11.1, with KDE 4.1 and kdesu doesn't accept my root
    password. Originally I had installed it with the root password being the
    same as my user, but I have since changed it (as I can login just fine
    from the command line) and it still doesn't work. For instance, if I
    select the Yast2 icon from the KDE menu, it prompts me to enter a
    password but nothing seems to work.

    Any ideas? I tried some of the hacks to get it not even ask for my
    password (ie, using kwriteconfig) but those don't help either. It still
    asks for the root password and doesn't accept it even if I type it in
    correctly.


    --
    'Daemon Dancing in the Dark ' (http://freebsd.amazingdev.com/blog)
    ------------------------------------------------------------------------
    hieronymous's Profile: http://forums.opensuse.org/member.php?userid=543
    View this thread: http://forums.opensuse.org/showthread.php?t=404897


  2. #2

    Default Re: kdesu not accepting my root password

    hieronymous wrote:
    > I'm using openSUSE 11.1, with KDE 4.1 and kdesu doesn't accept my root
    > password. Originally I had installed it with the root password being the
    > same as my user, but I have since changed it (as I can login just fine
    > from the command line) and it still doesn't work. For instance, if I
    > select the Yast2 icon from the KDE menu, it prompts me to enter a
    > password but nothing seems to work.
    >
    > Any ideas? I tried some of the hacks to get it not even ask for my
    > password (ie, using kwriteconfig) but those don't help either. It still
    > asks for the root password and doesn't accept it even if I type it in
    > correctly.
    >
    >

    If you added yourself to sudoers, try entering your own password...

    --
    Kevin Miller
    Juneau, Alaska
    http://www.alaska.net/~atftb

  3. #3
    buckmaster60 NNTP User

    Default Re: kdesu not accepting my root password


    This worked for me:
    'Default kdesu to use sudo and not su | Ben Kevan's Blog'
    (http://www.benkevan.com/blog/default...do-and-not-su/)


    --
    buckmaster60
    ------------------------------------------------------------------------
    buckmaster60's Profile: http://forums.opensuse.org/member.php?userid=2194
    View this thread: http://forums.opensuse.org/showthread.php?t=404897


  4. #4
    hieronymous NNTP User

    Default Re: kdesu not accepting my root password


    Yeah, like I said, I tried that. I don't mind typing in the root
    password, but KDE just doesn't seem to like anything I type in, even if
    it is correct


    --
    'Daemon Dancing in the Dark ' (http://freebsd.amazingdev.com/blog)
    ------------------------------------------------------------------------
    hieronymous's Profile: http://forums.opensuse.org/member.php?userid=543
    View this thread: http://forums.opensuse.org/showthread.php?t=404897


  5. #5
    hieronymous NNTP User

    Default Re: kdesu not accepting my root password


    really, no one else has this problem? If I type in 'kdesu xterm' it
    prompts me for my root password, and always fails. But I can su, or sudo
    and su -l as root with no problem. This is a real problem when it comes
    to installing software! I can run yast2, but only if I run it from the
    Super-User xterm!


    --
    'Daemon Dancing in the Dark ' (http://freebsd.amazingdev.com/blog)
    ------------------------------------------------------------------------
    hieronymous's Profile: http://forums.opensuse.org/member.php?userid=543
    View this thread: http://forums.opensuse.org/showthread.php?t=404897


  6. #6
    NightStorm NNTP User

    Default Re: kdesu not accepting my root password


    I am having it. Any place where I've installed KDE 4.x: the kdesu will
    not accept a correct root password. I end up having to open a terminal,
    do an su -, and then run the app. that I want.

    This is occuring on a fresh install of openSuSE 11.1 to a Dell laptop,
    also on an old Sony VAIO laptop on which I installed 11.1, and now on
    this IBM T60 running openSUSE 11.0 for which I just tried the on-click
    install of KDE 4.2.

    I'm now 3 for 3 systems, so from that perspective I'd think that most
    people would be seeing this issue.


    --
    NightStorm
    ------------------------------------------------------------------------
    NightStorm's Profile: http://forums.opensuse.org/member.php?userid=9270
    View this thread: http://forums.opensuse.org/showthread.php?t=404897


  7. #7
    brucecadieux NNTP User

    Default Re: kdesu not accepting my root password


    Have three systems running here and it works on all three, so I don't
    think everyone is seeing this problem.

    Wish I had an answer for you but I don't.

    All I can say is it is working the way it should for me, so you know
    that it will or should work.


    --
    brucecadieux
    ------------------------------------------------------------------------
    brucecadieux's Profile: http://forums.opensuse.org/member.php?userid=1373
    View this thread: http://forums.opensuse.org/showthread.php?t=404897


  8. #8
    hieronymous NNTP User

    Default Re: kdesu not accepting my root password


    The only workaround I saw was to change it so that my user was
    automatically approved and didn't have to type a password. I really have
    no idea what is the cause or why it works for some and not others.


    --
    'Daemon Dancing in the Dark ' (http://freebsd.amazingdev.com/blog)
    ------------------------------------------------------------------------
    hieronymous's Profile: http://forums.opensuse.org/member.php?userid=543
    View this thread: http://forums.opensuse.org/showthread.php?t=404897


  9. #9
    pwnawannab NNTP User

    Default Re: kdesu not accepting my root password


    Got a case here as well. While auto-update running on non-privileged
    session, kdesu failure is seen; 10.3 with 4.2.
    I think un-checking option to remember credentials helped in my case.


    --
    pwnawannab
    ------------------------------------------------------------------------
    pwnawannab's Profile: http://forums.opensuse.org/member.php?userid=15957
    View this thread: http://forums.opensuse.org/showthread.php?t=404897


  10. #10
    NightStorm NNTP User

    Default Re: kdesu not accepting my root password


    I have found the cause of this (at least for me). It was this line in
    my ~/.bash_profile:
    export BASH_ENV=$HOME/.bashrc

    Removed that and I was good-to-go.

    If that does not do it for others I suggest trying this experiment:
    - login
    - cd ~
    - mkdir old
    - mv .bashrc .bash_profile old/

    logout/login

    Bring up a konsole and type:
    kdesu /sbin/yast2

    See if it works for you now. If it does not then I don't have any
    suggestions for you other then to be sure that you restore your .bashrc
    and .bash_profile from where they were saved in old/

    If it does work then I suggest putting back your .bashrc and
    .bash_profile files:
    cd ~
    cp -p old/.??* ~

    Then start commenting out sections of each (do a binary search through
    the file disabling whole portions) until you find the offending
    section.

    - Bruce


    --
    NightStorm
    ------------------------------------------------------------------------
    NightStorm's Profile: http://forums.opensuse.org/member.php?userid=9270
    View this thread: http://forums.opensuse.org/showthread.php?t=404897


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •