Results 1 to 6 of 6

Thread: OpenGL doesn't work

  1. #1
    MirceaKitsune NNTP User

    Default OpenGL doesn't work


    My attention was brought to this by the fact Desktop Effects work
    through XRender but not OpenGL (which gives 'this error'
    (http://tinyurl.com/6tcun4)). I then tried running some openGL command
    (forgot what) and that gave me an error as well, which confirmed to me
    OpenGL is broken on my OpenSuse 11.1 64bit.

    Someone told me to erase the fglrx_dri.so in /usr/lib/dri and replace
    with the one from /usr/lib64/dri to the /usr/lib/dri. I have done that,
    re-ran "sax2 -r -m 0=fglrx" even and restarted but no good. The error I
    get when running glxgears to test is:


    Code:
    --------------------
    mircea@linux-wdzw:~> glxgears
    X Error of failed request: BadRequest (invalid request code or no such operation)
    Major opcode of failed request: 143 (GLX)
    Minor opcode of failed request: 19 (X_GLXQueryServerString)
    Serial number of failed request: 14
    Current serial number in output stream: 14
    mircea@linux-wdzw:~>
    --------------------


    My video card is an ATI Radeon X3870 X2 with is official Linux drivers
    installed correctly. What must I do to get OpenGL working and Desktop
    Effects working through it as well?


    --
    OpenSuse 11.1 64bit, KDE 4.1.3
    ------------------------------------------------------------------------
    MirceaKitsune's Profile: http://forums.opensuse.org/member.php?userid=19753
    View this thread: http://forums.opensuse.org/showthread.php?t=404820


  2. #2
    MirceaKitsune NNTP User

    Default Re: OpenGL doesn't work


    I remembered what that second command was. It was a shortcut which
    initialized the command "kcmshell opengl". Clicking that pops up a
    dialog saying "Could not initialize OpenGL". Then when I answer to that
    window I get a new window called Configure - KDE Control Module with
    some list and when I answer it a KDE Crash window.

    Writing that command in the console also gives me this line of errors:


    Code:
    --------------------
    mircea@linux-wdzw:~> kcmshell opengl
    X Error: BadRequest (invalid request code or no such operation) 1
    Major opcode: 143
    Minor opcode: 19
    Resource id: 0x17
    X Error: BadRequest (invalid request code or no such operation) 1
    Major opcode: 143
    Minor opcode: 19
    Resource id: 0x17
    X Error: BadRequest (invalid request code or no such operation) 1
    Major opcode: 143
    Minor opcode: 14
    Resource id: 0x17
    X Error: BadRequest (invalid request code or no such operation) 1
    Major opcode: 143
    Minor opcode: 19
    Resource id: 0x17
    X Error: BadRequest (invalid request code or no such operation) 1
    Major opcode: 143
    Minor opcode: 19
    Resource id: 0x17
    X Error: BadRequest (invalid request code or no such operation) 1
    Major opcode: 143
    Minor opcode: 14
    Resource id: 0x17
    X Error: BadRequest (invalid request code or no such operation) 1
    Major opcode: 143
    Minor opcode: 19
    Resource id: 0x17
    X Error: BadRequest (invalid request code or no such operation) 1
    Major opcode: 143
    Minor opcode: 19
    Resource id: 0x17
    X Error: BadRequest (invalid request code or no such operation) 1
    Major opcode: 143
    Minor opcode: 14
    Resource id: 0x17
    KCrash: Application 'kcmshell' crashing...
    mircea@linux-wdzw:~>
    --------------------


    --
    OpenSuse 11.1 64bit, KDE 4.1.3
    ------------------------------------------------------------------------
    MirceaKitsune's Profile: http://forums.opensuse.org/member.php?userid=19753
    View this thread: http://forums.opensuse.org/showthread.php?t=404820


  3. #3
    sidnelson13 NNTP User

    Default Re: OpenGL doesn't work


    Same think here. did the same thing.
    I'm using kde 4.1.96 (4.2 RC) and latest ATI's driver with dual
    monitors.

    If anyone has been able to setup ATI's proprietary driver with opensuse
    11.1 and 3d acceleration enabled on dual screen, I'd really appreciate
    some pointers.


    --
    sidnelson13
    ------------------------------------------------------------------------
    sidnelson13's Profile: http://forums.opensuse.org/member.php?userid=4462
    View this thread: http://forums.opensuse.org/showthread.php?t=404820


  4. #4
    Axeia NNTP User

    Default Re: OpenGL doesn't work


    Same on a Radeon 3200, video acceleration does seem to work though as
    previously while using the 'xv' output driver while playing a movie
    resultated in no image, I am getting an image after installing the
    driver and running the "sax2 -r -m 0=fglrx" command as root in init 3.
    Think someone needs to send ATI an email , I wont since I only need a
    working display + hardware acceleration for video's.


    --
    'Special effects' (http://tiny.cc/Y0T) <- KDE 4.2 Showing off
    More KDE -> ' PINK KDE' (http://tiny.cc/v30h)
    'HQ Pink KDE' (http://tiny.cc/R4P)
    ------------------------------------------------------------------------
    Axeia's Profile: http://forums.opensuse.org/member.php?userid=4794
    View this thread: http://forums.opensuse.org/showthread.php?t=404820


  5. #5
    moortier NNTP User

    Default Re: OpenGL doesn't work


    I guess I found the error, I just looked into the Xorg.0.log and found
    the following two lines:


    Code:
    --------------------
    (EE) AIGLX error: dlopen of /usr/lib/dri/fglrx_dri.so failed (/usr/lib/dri/fglrx_dri.so: wrong ELF class: ELFCLASS32)
    (EE) AIGLX: reverting to software rendering
    --------------------


    So I guess someone packed the 32 bit .so into the package that gets
    installed on 64 bit systems.


    --
    moortier
    ------------------------------------------------------------------------
    moortier's Profile: http://forums.opensuse.org/member.php?userid=20639
    View this thread: http://forums.opensuse.org/showthread.php?t=404820


  6. #6
    natss NNTP User

    Default Re: OpenGL doesn't work


    Hello,

    same problem with ATI HD 4850 (glxinfo errors).

    i just rename /usr/lib/dri/fglrx_dri.so to fglrx_dri.so.bak
    and link fglrx_dri.so with the 64bit fglrx_dri.so


    Code:
    --------------------
    # cd /usr/lib/dri
    # mv fglrx_dri.so fglrx_dri.so.bak
    # ln -s /usr/lib64/dri/fglrx_dri.so fglrx_dri.so
    --------------------


    Kill the server x and now glxinfo is ok.

    We must wait now for ATI update

    Stan


    --
    natss
    ------------------------------------------------------------------------
    natss's Profile: http://forums.opensuse.org/member.php?userid=21202
    View this thread: http://forums.opensuse.org/showthread.php?t=404820


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •