Results 1 to 9 of 9

Thread: Bad 3D performance with Radeon 7500 in opensuse 11.1

  1. #1

    Default Bad 3D performance with Radeon 7500 in opensuse 11.1

    I used to be able to play Wolfenstein Enemy Territory and a lot of other games relatively well on my Radeon 7500 using open source drivers. However, once I switched to opensuse 11.1, everything is laggier. Even the mouse lags in the Wolfenstein menu screen. When I run these games in the console I get a lot of "[driAllocateTexture:636] unable to allocate texture" messages. Is something wrong with my xorg configuration?

    Code:
    # /.../                                 
    # SaX generated X11 config file         
    # Created on: 2009-01-06T19:32:43-0800. 
    #                                       
    # Version: 8.1                          
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #                                                                             
    # Automatically generated by [ISaX] (8.1)                                     
    # PLEASE DO NOT EDIT THIS FILE!                                               
    #                                                                             
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"        
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"          
      FontPath     "/usr/share/fonts/URW"            
      FontPath     "/usr/share/fonts/Speedo"         
      FontPath     "/usr/share/fonts/PEX"            
      FontPath     "/usr/share/fonts/cyrillic"       
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"          
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled" 
      FontPath     "/usr/share/fonts/baekmuk:unscaled"      
      FontPath     "/usr/share/fonts/japanese:unscaled"     
      FontPath     "/usr/share/fonts/kwintv"                
      FontPath     "/usr/share/fonts/truetype"              
      FontPath     "/usr/share/fonts/uni:unscaled"          
      FontPath     "/usr/share/fonts/CID"                   
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"     
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"    
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"   
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"  
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled" 
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"          
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"     
      FontPath     "/usr/share/fonts/xtest"                 
      FontPath     "/opt/kde3/share/fonts"                  
      InputDevices "/dev/gpmdata"                           
      InputDevices "/dev/input/mice"                        
    EndSection                                              
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"        
    EndSection                              
    
    Section "Module"
      Load         "freetype"
      Load         "extmod"  
      Load         "dbe"     
      Load         "glx"     
      Load         "dri"     
    EndSection               
    
    Section "InputDevice"
      Driver       "kbd" 
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "us"     
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"     
    EndSection                              
    
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "7"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Microsoft IntelliMouse Optical"
      Option       "Protocol" "explorerps/2"              
      Option       "Vendor" "Sysp"                        
      Option       "ZAxisMapping" "4 5"                   
    EndSection                                            
    
    Section "InputDevice"
      Driver       "synaptics"
      Identifier   "Mouse[3]" 
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Emulate3Buttons" "on"    
      Option       "HorizScrollDelta" "0"    
      Option       "InputFashion" "Mouse"    
      Option       "Name" "Synaptics;Touchpad"
      Option       "Protocol" "explorerps/2"  
      Option       "SHMConfig" "on"           
      Option       "Vendor" "Sysp"            
      Option       "ZAxisMapping" "4 5"       
    EndSection                                
    
    
    Section "Monitor"
      DisplaySize  304 228
      HorizSync    30-50  
      Identifier   "Monitor[0]"
      ModelName    "LCD MONITOR"
      Option       "DPMS"       
      Option       "PreferredMode" "1024x768"
      VendorName   "LGP"                     
      VertRefresh  43-60                     
      UseModes     "Modes[0]"                
    EndSection                               
    
    
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection               
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15     
        Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection                                                    
      SubSection "Display"                                             
        Depth      16                                                  
        Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection                                                    
      SubSection "Display"                                             
        Depth      24                                                  
        Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection                                                    
      SubSection "Display"                                             
        Depth      8                                                   
        Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection                                                    
      Device       "Device[0]"                                         
      Identifier   "Screen[0]"                                         
      Monitor      "Monitor[0]"                                        
    EndSection                                                         
    
    
    Section "Device"
      BoardName    "Radeon LW"
      Driver       "radeon"   
      Identifier   "Device[0]"
      Option       "SaXDualHead"
      Option       "XAANoOffscreenPixmaps" "true"
      Option       "monitor-LVDS" "Monitor[0]"   
      Option       "SaXDualMonitorVendor" "--> LCD"
      Option       "SaXDualOrientation" "RightOf"  
      Option       "SaXDualResolution" "1440x900"  
      Option       "SaXDualMode" "Xinerama"        
      Option       "SaXDualHSync" "50-70"          
      Option       "SaXDualMonitorModel" "1440X900@60HZ"
      Option       "SaXDualVSync" "50-60"               
      Option       "SaXExternal" "Identifier&EXT+DisplaySize&304 228+VendorName&--> LCD+RightOf&Monitor[0]+PreferredMode&1440x900+HorizSync&50-70+ModelName&1440X900@60HZ+VertRefresh&50-60"          
      Screen       0                                                                                 
      VendorName   "ATI"                                                                             
    EndSection                                                                                       
    
    
    Section "Monitor"
      DisplaySize  304 228
      HorizSync    50-70  
      Identifier   "EXT"  
      ModelName    "1440X900@60HZ"
      Option       "RightOf" "Monitor[0]"
      Option       "PreferredMode" "1440x900"
      VendorName   "--> LCD"                 
      VertRefresh  50-60                     
    EndSection                               
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      InputDevice  "Mouse[3]" "SendCoreEvents"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
    EndSection

    Any help is appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,547
    Blog Entries
    1

    Default Re: Bad 3D performance with Radeon 7500 in opensuse 11.1

    I don't use the radeon driver, but others have reported similar video performance issues with recent Xorg versions. This thread may help with this. It suggests editing your xorg.conf 'Device' section by adding these options:


    Option "VideoOverlay" "off"
    Option "OpenGLOverlay" "on"
    Option "TexturedVideo" "off"

    Make sure you backup your current working xorg.conf first with something like:

    cp /etc/X11/xorg.conf /etc/X11/xorg.conf.working

    Good luck.

  3. #3

    Default Re: Bad 3D performance with Radeon 7500 in opensuse 11.1

    That thread deals with flickering images during video playback. I am just complaining about slow rendering of 3D games and the many
    Code:
    [driAllocateTexture:636] unable to allocate texture
    messages that I get in the console. I will try the above options though and see where that gets me.

  4. #4

    Default Re: Bad 3D performance with Radeon 7500 in opensuse 11.1

    I don't see where 3D is enabled in your Xorg file (am I missing something?) I had heard it was enabled by default in 11.1. True or false?

  5. #5

    Default Re: Bad 3D performance with Radeon 7500 in opensuse 11.1

    Okay, I found the fix. According to the Radeon DRI site, DRI Wiki - ATIRadeon,
    the radeon drivers as of September 2007 work better with EXA acceleration than XAA. Sure enough adding
    Code:
    Option "AccelMethod" "EXA"
    in the Device section of xorg.conf restored 3d performance to what it was before.

    Hope this helps anyone encountering this problem.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,547
    Blog Entries
    1

    Default Re: Bad 3D performance with Radeon 7500 in opensuse 11.1

    Thanks for update. I was going to mention that as well.

    man radeon

  7. #7

    Default Re: Bad 3D performance with Radeon 7500 in opensuse 11.1

    Actually I spoke too soon. While switching to EXA did speed up the menus in Wolfenstein, actually playing the game was still abysmally slow. Plus EXA seems to introduce lag in the KDE 4 interface and crashes X when Kwin Desktop effects are enabled. EXA does help a bit in terms of 3D, but I don't think its the core issue here. Any other suggestions?

  8. #8

    Default Re: Bad 3D performance with Radeon 7500 in opensuse 11.1

    New update. I turned off EXA as it was slowing down the GUI way too much. However, while I was browsing through my Xorg.0.log, I found an entry regarding Max desktop size. It said that using the Virtual option in xorg.conf, you can decrease this max desktop size and help 3D performance. The Max desktop size was set at 1600 x 1200, which was WAY to big for my LCD laptop panel (1024 x 768) anyway, so I added "Virtual 1024 768" in the 24-bit depth Display Subsection in the Screen section of xorg.conf. This essentially increased Wolfenstein performance more than just turning on EXA alone. However, still not up to opensuse 11.0 speeds yet.

  9. #9

    Default Re: Bad 3D performance with Radeon 7500 in opensuse 11.1

    Any ideas guys? Maybe I should try reverting to an older or newer version of X11? Anyone know how I can easily do that without recompiling?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •