Results 1 to 9 of 9

Thread: vmware virtualization blues

  1. #1
    kittyhooch NNTP User

    Default vmware virtualization blues

    As a Linux developer I'm loathe to use Windows, but as a musician I've
    finally decided to give in. I have various devices that have special non
    file type USB drivers for Windows as well as music production software
    now. I tried VirtualBox which was easy to set up but the USB
    functionality is not 100%. So I thought I'd try vmware server. I read
    opensuse howtos and 'Install VMware server 2 in Suse / openSUSE 11 & USB
    support' ( I've
    done everything carefully. I downloaded the latest RPM from vmware and
    followed the install which completes only failing to build vsock which
    it says is not critical. Starting with /etc/init.d/vmware start gives me

    Starting VMware services:
    Virtual machine monitor failed
    Virtual machine communication interface done
    Virtual ethernet failed
    Bridged networking on /dev/vmnet0 done


    That is disturbing by maybe those failures are due to not being set up.
    Using Firefox as advised and myself as the user it continually rejects
    me. Isn't there a way to circumvent this from localhost? BTW it fails to
    show for localhost but only Possibly there is some issue with
    needing the virtual internet working to configure. Shutting down gives
    me this.

    Stopping VMware autostart virtual machines:
    Virtual machines failed
    Stopping VMware management services:
    VMware Virtual Infrastructure Web Access
    VMware Server Host Agent failed
    Stopping VMware services:
    VMware Authentication Daemon done
    Virtual machine communication interface done
    Virtual machine monitor done
    Bridged networking on /dev/vmnet0 done
    Host network detection done
    Virtual ethernet failed


    Seemingly some of these might be expected as it's not configured but
    vmnet-bridge and vmware-hostd have to be manually killed if I want to
    try configuring again. I've combed all the posts I could search and
    confirmed I've done everything relevant for opensuse 11.1.

    I'm running an AMD Phenom Quad 2500 64 bit with 8GB RAM. I even made
    out with the devil and bought Vista 64 bit to try as well as my copy of
    XP. I'm now going to install Vista to dual boot on another drive and
    rely on opensuse to boot manage it. I've read it may be possible to use
    either a VirtualBox image or a phisical install with vmware server. It
    seemed pointless to install XP 32 bit on this machine. I am running
    databases for my business and doing Linux software development so I'd
    like to not have to dual boot to run my studio. TIA

    kittyhooch's Profile:
    View this thread:

  2. #2
    caf4926 NNTP User

    Default Re: vmware virtualization blues

    Don't feel to bad about yourself. Though I think you will be sadly
    disappointed by Vista. Though you have the advantage of RAM overkill,
    well for most of us it is, but Vista will love it.

    Windows has it's place and credit when due, XP has been and still is a
    great bit of work. Pretty much All I see in the business workplace is
    XP, often a downgrade from Vista.

    Not for me of course. But if you need it.

    There are, incidentally spins I think in Ubuntu that focus on your line
    of work. But I dare say its focus is on apps like for like with windows,
    rather than usb drivers.
    'Home | Ubuntu Studio' (

    Box: Linux i686 | OS 11.1 | (KDE3.5.10) "33.2" | M2N4-SLI |
    AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE4.1.87)"3.1" | Intel 965 GM | Lenovo
    R61e | 3GB RAM
    caf4926's Profile:
    View this thread:

  3. #3
    geoffro NNTP User

    Default Re: vmware virtualization blues

    Tried vmware for music but gave up as i was unable to get my firewire
    sound card an hardware dongles. Had to use xp tried vista but hated it.
    Only have 4 gb ram but it works fine with Cubase 4 which i use
    You could try getting the 64 bit version of XP have it on my developmen
    machine on work. Pretty similar specs to yours intel quad core 8 gb. Use
    vmware for different environments to test the software


    Core 2 Duo 3.16GHz 4GB DDR2 2.5 TB GeForce 7600 GS OS 11.1 x86_64
    KDE4.2 beta2 'Smolt specs' (
    geoffro's Profile:
    View this thread:

  4. #4
    inktvis75 NNTP User

    Default Re: vmware virtualization blues

    The problem is the first part of the howto: the kernel part is not
    working (not for me).. I made a little manual, it's in dutch, but i'm
    sure you can read the commands

    The second part of this howto is very interesting, i'll have a look
    further into it

    inktvis75's Profile:
    View this thread:

  5. #5
    swerdna NNTP User

    Default Re: vmware virtualization blues

    kittyhooch;1925538 Wrote:
    > ............. Starting with /etc/init.d/vmware start gives me this.
    > >

    > > Starting VMware services:

    > Virtual machine monitor failed
    > Virtual machine communication interface done
    > Virtual ethernet failed
    > Bridged networking on /dev/vmnet0 done

    > >

    > ..........

    That message usually occurs after a failed run of or
    if a kernel-update has come in. You need to run it again.

    Ensure that during the re-run that you choose yourself as the admin
    manager for the VMachines.

    Check you changed the line in /etc/sysconfig/boot to RUN_PARALLEL="yes"

    In Yast --> System --> System Services (Runlevel) --> Expert: set
    service vmware to 2, 3 and 5. Set all the other vmware-related services
    to off and no runlevels.

    If you prefer to start it occasionally rather than at boot. Set the
    runlevels for vmware to no runlevels and the service to off. Then you
    can start it with /etc/init.d/vmware start in a root console.

    The main thing here is I think that a kernel-type update has occurred
    or the install failed. So you need I think to run

    Check rpms installed for: kernel-source, make, gcc, gcc-c++ (most
    likely are)

    'Drop in and visit some time'
    swerdna's Profile:
    View this thread:

  6. #6
    kittyhooch NNTP User

    Default Re: vmware virtualization blues

    I have run more times than I have tried variations on
    VirtualBox. I have been getting indications of success with no failures
    on at the end. However I have been getting an error when it tries to
    build vsock. I mentioned this already. It says it's optional. The funny
    thing is it says it may have to do with the kernel not matching due to
    an update. I found another post on the web suggesting to get kernel
    sources, clone the running configuration and build the sources so this
    would match. I wish I could remember the link as it was days of hell
    ago. Anyway that appeared to have worked, but possibly it didn't.

    This brings up two pivotal points to explore. First what path does this
    need for kernel headers. It seems it gets them from an object directory,
    not the original source path and it builds. Can someone give me a
    verifiable reference directory? The other point is the question of how
    to insure my kernel and headers match. My running kernel seems fine and
    I have built a lot of kernels with Gentoo and other distributions. I've
    also hosed it a few times. Any reference for the least invasive and most
    probable successful course here? Rebuild and install? I guess I could
    look at the docs.

    Thanks, and for the reference as to whether I will like Vista, Get a
    life! I have been a project lead on some of the more popular open source
    projects (Quanta & Kommander) for the last 8 years precisely because I
    believe in free as in GPL and I detest the Microsoft culture. I have
    grown to hate Windows the more I use it, but the best sequencer on Linux
    is Rosegarden which crashes on opensuse and I've never got fully working
    on anything including Gentoo. Even so it's no Cakewalk Sonar and I don't
    think I'm likely to see a GPL'd competitor to Melodyne. It's not easy
    for me dual booting to Vista... Well it is since I fixed grub, but I
    didn't want to do this and I didn't want to spendover a thousand dollars
    on software for a platform I hate. That said I have to give Microsoft
    it's due. In spite of needing to reboot, a little bit of inconsistent
    behavior with drivers and only one desktop I would say over all there
    are things I really like about Vista and it's by far the best I've seen
    from them. It also exposes why even if opensuse isn't as aesthetically
    decorated it still does a lot of stuff better out of the box. It's all
    academic though. If I want to run this software it's either cough up for
    a mac or use my current system. $100 to the evil empire or $2000 to
    their little brother.

    kittyhooch's Profile:
    View this thread:

  7. #7
    swerdna NNTP User

    Default Re: vmware virtualization blues

    There's a patch for the vsock thing here:
    'Getting VMware to run on openSUSE 11.1 - Page 2 - openSUSE Forums'

    There's a mix of VM workstation and Server 2 discussions starting
    'Getting VMware to run on openSUSE 11.1 - openSUSE Forums'
    and running about 4 pages, including I think, compilations.

    'Drop in and visit some time'
    swerdna's Profile:
    View this thread:

  8. #8
    silenuz NNTP User

    Default Re: vmware virtualization blues

    try this:

    Open a terminal and as a superuser type

    mv /usr/lib/vmware/modules/binary /usr/lib/vmware/modules/binary.old

    Now start vmware, it will rebuild all the modules. Note you have to
    have kernel development installed, and it works best if you actually
    build the kernel, don't have to install it just build it.

    make menuconfig (exit saving config, don't have to change anything)
    make modules

    Now when you remove the modules/binary directory it should have all the
    proper objects and symbols to properly compile the modules vmware needs.

    silenuz's Profile:
    View this thread:

  9. #9
    tsteiner2 NNTP User

    Default Re: vmware virtualization blues

    I'm just curious, but is there any reason why you are using VMware
    Server rather than VMware Workstation? With Workstation I am able to run
    Windows XP (for SolidWorks and MS Office) just fine, and with the new
    version you no longer need to mess with the vmware-config nonsense, it
    just ran like it should. Originally I was having trouble with the
    vmware-config stuff as well, so I switched back to VirtualBox, but it
    still can't handle the graphics in SolidWorks, so I switched back to
    VMware Workstation 6.5.1 and it ran just fine right away, no more
    vmware-config. It seems to me that if you are just running music
    programs that wouldn't require a server, but I don't have any experience
    with that.

    tsteiner2's Profile:
    View this thread:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts