Results 1 to 2 of 2

Thread: Creating and migrating a menu

  1. #1
    Ecky NNTP User

    Default Creating and migrating a menu


    I've created a custom menu of commonly used apps for adding to the main
    panel similar to the windoze quick launch

    I want to maybe make a script for adding the same menu to other user
    accounts, or just do it manually by copying over the necessary files

    Looked up some info on how menus are created by installations and
    identified the files that making my menu created

    I've got the following files:

    /home/user/.config/menus/applications-kmenuedit.menu

    /home/user/.local/share/desktop-directories/My Menu.directory
    (There are also .directory files for submenus of my Menu in
    desktop-directories)

    /home/user/.kde/share/apps/RecentDocuments/My Menu.desktop

    /home/user/.kde/share/apps/RecentDocuments/My Menu.directory.desktop

    I wasn't able to find those last two files anywhere other than in
    RecentDocuments

    From what I've read on the files needed for a menu, My Menu.desktop at
    least I would've thought should be somewhere other than RecentDocuments,
    but I'm ********** if I could find it anywhere

    I copied all the files relating to the menu I made from the user's
    folders I created it in to another user's folder in the corresponding
    locations and set the permissions accordingly

    Obviously there's something more I need to do because the menu isn't
    there when I log into the account

    Anyone have any ideas what I need to do here to get the menu loading?


    --
    Ecky
    ------------------------------------------------------------------------
    Ecky's Profile: http://forums.opensuse.org/member.php?userid=3518
    View this thread: http://forums.opensuse.org/showthread.php?t=404632


  2. #2
    Ecky NNTP User

    Default Re: Creating and migrating a menu


    I seem to be developing a habit of asking questions people don't know
    the answer to ... either that or I'm asking them wrong

    The last one I asked that no-one really answered I eventually solved by
    uninstalling and reinstalling the app around fourteen times, that
    approach isn't gonna apply to this one though

    Probably end up being a case of either keep doing it the long way round
    or do a load more reading and playing until I eventually figure it out
    myself ... it's all good fun


    --
    Ecky
    ------------------------------------------------------------------------
    Ecky's Profile: http://forums.opensuse.org/member.php?userid=3518
    View this thread: http://forums.opensuse.org/showthread.php?t=404632


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •