Results 1 to 7 of 7

Thread: GTK-Qt engine can not be found

  1. #1
    TimDavies NNTP User

    Default GTK-Qt engine can not be found


    Some of the most important apps in openSUSE look pretty ugly (Firefox,
    Writer, GIMP), I found out that I need to use the GTK Styles and Fonts
    in the KDE Control Centre. But no matter what theme I select those apps
    don't change at all.

    In the Change Search Paths dialogue in GTK Styles and Fonts it says:

    > The control center module could not find GTK-Qt engine in its list of
    > search paths. If you have installed it elsewhere, you will need to add
    > the correct path to the list below.


    I have the following paths in the list:

    -/usr
    /usr/local
    /opt/gnome
    /usr/share/gtk-engines
    /usr/share/themes-

    Is the GTK-Qt engine located somewhere else?
    Or do I need to install anything else?

    I have openSUSE 11.1 with KDE4.

    Thank you very much for any help.


    --
    TimDavies
    ------------------------------------------------------------------------
    TimDavies's Profile: http://forums.opensuse.org/member.php?userid=1532
    View this thread: http://forums.opensuse.org/showthread.php?t=404597


  2. #2
    RedDwarf NNTP User

    Default Re: GTK-Qt engine can not be found


    Note http://bugzilla.novell.com/462488

    You probably are seeing something like
    https://bugzilla.novell.com/attachment.cgi?id=262419 ?


    --
    RedDwarf
    ------------------------------------------------------------------------
    RedDwarf's Profile: http://forums.opensuse.org/member.php?userid=374
    View this thread: http://forums.opensuse.org/showthread.php?t=404597


  3. #3
    TimDavies NNTP User

    Default Re: GTK-Qt engine can not be found


    Actually no, it looks like the first one:
    https://bugzilla.novell.com/attachment.cgi?id=262418

    I don't think my problem is related to that bug, but thanks for your
    help.


    --
    TimDavies
    ------------------------------------------------------------------------
    TimDavies's Profile: http://forums.opensuse.org/member.php?userid=1532
    View this thread: http://forums.opensuse.org/showthread.php?t=404597


  4. #4
    RedDwarf NNTP User

    Default Re: GTK-Qt engine can not be found


    Well, I don't really know too much about GTK-Qt Engine. But here is the
    situation...
    You have a package available at KDE:Community OBS repo, but it's the
    Qt3 version. A kde4-gtk-qt-engine package exists at KDE:KDE4:Community,
    but doesn't builds for 11.1 (it's available for 11.0)... you can open a
    bug report or fix it yourself if you know how to use the openSUSE Build
    Service.

    Both kcm_gtk and kde4-kcm_gtk packages are built from gtk-qt-engine,
    but it's specifically patched to not build gtk-qt-engine itself... only
    kcm_gtk. And all references to GTK-Qt Engine are removed... the fact
    that you can see the "The control center module could not find GTK-Qt
    engine in its list of search paths..." message is a bug... isn't removed
    because someone forgot to.
    I don't know why openSUSE decided to remove GTK-Qt Engine from the
    official repo, you will need to ask in the opensuse-kde mailing list to
    know.

    If GTK-Qt Engine purpose is to make GTK apps look like Qt ones... well,
    I already have that (see attachment #262418). And isn't ugly to me.
    I expect that if you install the kde4-gtk-qt-engine package you will
    get the same, or something very similar.


    If I change the theme in "GTK Styles and Fonts"... it really changes. A
    hidden ".gtkrc-2.0-kde4" file is created in my home folder to do so. I
    don't know why that fails to you (you tried all themes? some of them
    are very similar... "Redmond" is clearly different).


    --
    RedDwarf
    ------------------------------------------------------------------------
    RedDwarf's Profile: http://forums.opensuse.org/member.php?userid=374
    View this thread: http://forums.opensuse.org/showthread.php?t=404597


  5. #5
    TimDavies NNTP User

    Default Re: GTK-Qt engine can not be found


    Thank you very much for the explanation and help RedDwarf. It appears
    that the themes were changing, but the changes were quite subtle.
    However, it appears the thing I'm having a problem with is the menu
    fonts in Firefox (and OOo and GIMP). The File/Edit/View menus and the
    bookmarks. The text just doesn't seem to be as sharp and clear as they
    are under Windows.


    --
    TimDavies
    ------------------------------------------------------------------------
    TimDavies's Profile: http://forums.opensuse.org/member.php?userid=1532
    View this thread: http://forums.opensuse.org/showthread.php?t=404597


  6. #6
    farcusnz NNTP User

    Default Re: GTK-Qt engine can not be found


    Here si what I have found (at least in KDE 3.5.xx)

    KCM-GTK does nto seem to work. Any changes applied do nto make one bit
    of difference in GTK apps (I am using QTcurve).

    Uninstalling KCM-GTK and replacing it with GTK-QT you can make changes
    that will work in GTK apps. However, the problem here is in applications
    like Firefox you get dirty buttons - they dont' quite work properly -
    has been like this for some time)

    But - if you then uninstall GTK-QT and reinstall KCM-GTK - the KCM_GTK
    package now works.

    This is the same for me in Opensuse 11.0 and Opensuse 11.1 on several
    machines - tested and confirmed exact same behaviour.


    --
    farcusnz
    ------------------------------------------------------------------------
    farcusnz's Profile: http://forums.opensuse.org/member.php?userid=230
    View this thread: http://forums.opensuse.org/showthread.php?t=404597


  7. #7
    TimDavies NNTP User

    Default Re: GTK-Qt engine can not be found


    Thanks very much for you help, I've managed to get the GTK look
    reasonable now, so everything is quite a bit smoother.

    Thanks again


    --
    TimDavies
    ------------------------------------------------------------------------
    TimDavies's Profile: http://forums.opensuse.org/member.php?userid=1532
    View this thread: http://forums.opensuse.org/showthread.php?t=404597


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •