Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: KDE4.1 + Compiz doesn't work in 11.1

  1. #1
    djechelon NNTP User

    Default KDE4.1 + Compiz doesn't work in 11.1


    Hello,
    I installed 11.1 the day it got released upgrading my existing 11.0
    installation.
    I'm a fan of Compiz and it worked fine in 11.0 with KDE4.1 as desktop
    manager.

    After upgrade, it doesn't work at all.

    I had some troubles with nVidia drivers, but now they are fine (I use a
    9700M GT, which requires manual installation), and Xgl is enabled since
    I can use glxgears fine.

    When I go into KDE's Window Manager settings I can't enable Compiz: it
    says it failed to start.

    All of my packages are up to date with lastest version, and I have set
    up proper repositories for Xgl and Compiz.

    Can somebody help me step by step solving my problem? Thank you very
    much.


    --
    djechelon
    ------------------------------------------------------------------------
    djechelon's Profile: http://forums.opensuse.org/member.php?userid=9918
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


  2. #2
    mckeeshop NNTP User

    Default Re: KDE4.1 + Compiz doesn't work in 11.1


    djechelon,
    You may wish to try adding the repositories that are maintained by
    Cyborg and install his version of Compiz without the Nomad patch.

    mckeeshop


    --
    SUSE 11.0
    Ubuntu 8.10
    ------------------------------------------------------------------------
    mckeeshop's Profile: http://forums.opensuse.org/member.php?userid=549
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


  3. #3
    djechelon NNTP User

    Default Re: KDE4.1 + Compiz doesn't work in 11.1


    Could you please give me the URL of that repository? I added the X11GL
    repository at 'Index of /repositories/X11:/XGL/openSUSE_11.1'
    (http://download.opensuse.org/reposit...openSUSE_11.1/). Is
    that correct?


    --
    djechelon
    ------------------------------------------------------------------------
    djechelon's Profile: http://forums.opensuse.org/member.php?userid=9918
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


  4. #4
    beli0135 NNTP User

    Default Re: KDE4.1 + Compiz doesn't work in 11.1


    Sorry, I don't understand. Why do you need compiz? Almost all effects
    already exists in new KWin... cube, wobbly windows, etc etc.


    --
    beli0135
    ------------------------------------------------------------------------
    beli0135's Profile: http://forums.opensuse.org/member.php?userid=1101
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


  5. #5
    rjwilmsi NNTP User

    Default Re: KDE4.1 + Compiz doesn't work in 11.1


    beli0135;1924112 Wrote:
    > Sorry, I don't understand. Why do you need compiz? Almost all effects
    > already exists in new KWin... cube, wobbly windows, etc etc.

    For me the lack of customisation over keyboard shortcuts and mouse
    clicks on desktop edge in KWin was why I set up compiz.


    --
    MSI K9N SLI Platinum rev 1.11 | Athlon64 X2 4600 65W | 3GB 667MHz RAM |
    512MB POV 8800GT PCI-E | LG GSA-H30N |Netgear WG311T | opensuse 10.3
    x86_64 (250 GB) & Win XP Pro SP3 (160GB) | Samsung 206BW 1680x1050 DVI |
    Logitech MX3000 | Freecom USB DVB-T 25452
    ------------------------------------------------------------------------
    rjwilmsi's Profile: http://forums.opensuse.org/member.php?userid=4236
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


  6. #6
    beli0135 NNTP User

    Default Re: KDE4.1 + Compiz doesn't work in 11.1


    I thought the same at first, but I managed to put shortcuts as I like
    and also screen edges the same as in compiz.
    Buzz is that I had to do it manually from "configure desktop" ->
    "keyboard shortcuts", but OK, no big deal. Everything works the same.

    I have a remark in KDE4 that settings are bit confusing, but at least
    all are there.


    --
    beli0135
    ------------------------------------------------------------------------
    beli0135's Profile: http://forums.opensuse.org/member.php?userid=1101
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


  7. #7
    mckeeshop NNTP User

    Default Re: KDE4.1 + Compiz doesn't work in 11.1


    Add this repo to your YaST software repositories, install the Compiz
    related items that are updated from it.
    'Index of /repositories/home:/cyberorg/openSUSE_11.1'
    (http://tinyurl.com/7uufl9)


    --
    SUSE 11.0
    Ubuntu 8.10
    ------------------------------------------------------------------------
    mckeeshop's Profile: http://forums.opensuse.org/member.php?userid=549
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


  8. #8
    djechelon NNTP User

    Default Re: KDE4.1 + Compiz doesn't work in 11.1


    Didn't work
    Anyway since I enabled Xrender on Kwin the whole KDE goes worse. It
    won't let me re-enable OpenGL rendering, but I'm 100% sure Xgl works
    fine.

    What can I try then?


    --
    djechelon
    ------------------------------------------------------------------------
    djechelon's Profile: http://forums.opensuse.org/member.php?userid=9918
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


  9. #9
    beli0135 NNTP User

    Default Re: KDE4.1 + Compiz doesn't work in 11.1


    Sorry, I don't mean to be boring, but did you try without compiz, XGL
    and emerald and whatever else. Just plain KWin at 4.1 works OK. I had to
    remove all startup things for compiz and emerald to get my beloved cube
    work as I wish.


    --
    beli0135
    ------------------------------------------------------------------------
    beli0135's Profile: http://forums.opensuse.org/member.php?userid=1101
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


  10. #10
    silenuz NNTP User

    Default Re: KDE4.1 + Compiz doesn't work in 11.1


    You might want to check your /etc/X11/xorg.conf and see if it has
    compositing turned on.

    The last section should be something like:

    Section "Extensions"
    Option "Composite" "Enable"
    End Section


    --
    silenuz
    ------------------------------------------------------------------------
    silenuz's Profile: http://forums.opensuse.org/member.php?userid=19071
    View this thread: http://forums.opensuse.org/showthread.php?t=404249


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •