Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: OpenSuse 11.1 and SMB (Ger)

  1. #1
    Xandersoft NNTP User

    Default OpenSuse 11.1 and SMB (Ger)


    English:
    Hello...

    I just find a problem by using the Samba (SMB://) and Konqueror.

    If i open the "url" "smb://Server/public" is open a Diolog that give me
    the info that an Folder not exist*.
    Normalely i have to check the Server but only on the Unix Maschines i
    have that problem. Under MS-XP all works fine.

    Example*: "smb://Server/public/music" -> not exist but without "s"
    "smb://Server/public/musics" -> is the right

    in the anther folders and files the thame problem ... always the last
    letter are cut in the overview.

    smbclient -L Servername list all fine...

    SMB Version on Server/Router: 2.2.12
    SMB Version on Client: 3.2.4-5.2-1985-SUSE-CODE11

    the SMB Verion on Server is an ipkg-opt packages

    can my any one tell whats wrong?

    Deutsch:
    hallo
    Ich hab festellen mssen das ich seit OpenSuse 11.1 nicht mehr auf
    Samba Ordner auf meinem Server/Router zugreifen kann.
    Wenn ich mit dem Konqueror die eingabe smb://Servername/public eingben
    wird mir als erstes eine Fehlermeldung ausgebgen das ein Ordner nicht
    existert.
    Dann wird mir allerdings der inhalt im Konqueror angezeigt. Was dort
    dann sehr auffllig ist, die Ordner werden als Symbol eine Datei gezeigt
    mit einem Schloss.
    Bei der Bezeichnung der Ordner fehlt immer der letzte Buchstabe. Kann
    mir nicht erklren woran es liegt.
    ber Windows XP gibt es da allerdings keine probleme. Lese und Schreibe
    zugriffe funktionieren dort ausgezeichnet auch werden alle Ordner und
    Dateien mit richtigem namen ausgegegen.
    Das Problem tritt nur bei Opensuse

    Kann mir da jemand helfen?


    --
    Xandersoft
    ------------------------------------------------------------------------
    Xandersoft's Profile: http://forums.opensuse.org/member.php?userid=19194
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


  2. #2
    michaelhust NNTP User

    Default Re: OpenSuse 11.1 and SMB (Ger)


    Hi,

    ich kann Dir leider auch nicht helfen, sondern nur besttigen, da bei
    mir das gleich auftritt . Bei mir werden jedoch immer irgendwelche
    Dateien anstelle von Ordnern angemeckert.
    (I my case the same problems).

    Gre

    Michael


    --
    michaelhust
    ------------------------------------------------------------------------
    michaelhust's Profile: http://forums.opensuse.org/member.php?userid=17663
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


  3. #3
    supertimorplusfort NNTP User

    Default Re: OpenSuse 11.1 and SMB (Ger)


    Moin. Versuchts mal da mit 'Opening Samba ports in the Firewall in
    openSUSE 11.1 - openSUSE Forums' (http://tinyurl.com/937jqw). Hat mir
    sehr geholfen...


    --
    supertimorplusfort
    ------------------------------------------------------------------------
    supertimorplusfort's Profile: http://forums.opensuse.org/member.php?userid=1970
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


  4. #4
    michaelhust NNTP User

    Default Re: OpenSuse 11.1 and SMB (Ger)


    Hi,

    thanks for your answer!
    I also openend the firewall for SAMBA. This didn't make any difference
    to before. I would be also surprised if the firewall has something to do
    with our german language problem .
    Did you make anything else, which helped to circumvent the problems
    with the german umlauts?
    Other languages like french, turkish or scandinavian languages should
    have the same problem. Is somebody using this languages and solved the
    problem?

    Greetings

    Michael


    --
    michaelhust
    ------------------------------------------------------------------------
    michaelhust's Profile: http://forums.opensuse.org/member.php?userid=17663
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


  5. #5
    supertimorplusfort NNTP User

    Default Re: OpenSuse 11.1 and SMB (Ger)


    Hi. Switch off your firewall for a moment and see if the problem still
    exists. Then, please post your results again. What exactly are your
    problems with umlauts? I didn't encounter any yet.


    --
    supertimorplusfort
    ------------------------------------------------------------------------
    supertimorplusfort's Profile: http://forums.opensuse.org/member.php?userid=1970
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


  6. #6
    michaelhust NNTP User

    Default Re: OpenSuse 11.1 and SMB (Ger)


    Hi,

    I switched of the firewall, but it doesn't change anything.
    My problem with the umlauts is, that dolphin/samba says:
    Die Datei exisitiert nicht (file not existing):
    smb://x.y.z/file with german umlaut

    I can open, copy... only files without german umlauts.

    Greetings and thanks for your help

    Michael

    P.S.: I will switch on again my firewall now ;-)


    --
    michaelhust
    ------------------------------------------------------------------------
    michaelhust's Profile: http://forums.opensuse.org/member.php?userid=17663
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


  7. #7
    supertimorplusfort NNTP User

    Default Re: OpenSuse 11.1 and SMB (Ger)


    michaelhust;1925653 Wrote:
    >
    > I can open, copy... only files without german umlauts.
    >

    Hmm, everything fine here with the programs you mentioned.
    Xandersoft said he couldn't access samba shares with openSUSE11.1 at
    all. Obviously you can and your problem is the umlaut thing only which
    is unlikely to be caused by the firewall. I believe that the link posted
    before didn't help you in this case. Which version of samba are you
    running and what exactly is not working except of the umlauts? Does it
    happen with samba only or also when you work with files on your local
    disk or a USB stick? You can also copy an umlaut file with ssh or scp
    (or fish:// in Konqueror) and see if that works. Good luck!


    --
    supertimorplusfort
    ------------------------------------------------------------------------
    supertimorplusfort's Profile: http://forums.opensuse.org/member.php?userid=1970
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


  8. #8
    michaelhust NNTP User

    Default Re: OpenSuse 11.1 and SMB (Ger)


    Hi supertimorplusfort,

    thanks for your answer. The problems with the umlauts occures only with
    samba shares.
    E.g.:the file "NYT Flschung.pdf" leads to following error when opening
    the folder with this files: "Die Datei existiert nicht:
    smb://user@xxx.xxx.xx.xxx/austauschserver/NYT%20F%C3%A4lschung.pdf"
    The file name is shown correctly "NYT Flschung.pdf" but with 0 B. If I
    try to open this files, I'am getting the answer: "Die Datei oder der
    Ordner smb://root@134.169.72.166/austauschserver/NYT Flschung.pdf
    existiert nicht."
    Using opensuse 11.0 and KDE3 this problem doesn't occur.

    Greetings

    Michael


    --
    michaelhust
    ------------------------------------------------------------------------
    michaelhust's Profile: http://forums.opensuse.org/member.php?userid=17663
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


  9. #9
    michaelhust NNTP User

    Default Re: OpenSuse 11.1 and SMB (Ger)


    Addition:

    The problem with the german umlauts does not depend on dolphin,
    konqueror gives the same error message.

    Greetings

    Michael


    --
    michaelhust
    ------------------------------------------------------------------------
    michaelhust's Profile: http://forums.opensuse.org/member.php?userid=17663
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


  10. #10
    supertimorplusfort NNTP User

    Default Re: OpenSuse 11.1 and SMB (Ger)


    Hi.
    You can try copying an umlaut file to your computer with "smbget
    smb://x.y.z/file". The file should be downloaded to your home folder. If
    it works your problem may be related to KDE, if it doesn't it may be
    samba.
    As I mentioned, I don't have that problem here (openSUSE 11.1 64-bit,
    samba 3.2.4-5.2-1985-SUSE-CODE11, KDE 3.5.10 and some KDE4 apps like
    Dolphin 1.1.80), so I had a look on KDE bugs and only found something
    very very old: 'Bug 50270 files and dirs with german umlauts are not
    displayed with smb://' (http://bugs.kde.org/show_bug.cgi?id=50270). That
    link won't help you I guess but I post it anyway, you never know...
    p.s.: You can find a great introduction to samba on openSUSE here:
    'Linux HOWTOs and Tutorials: Suse Linux 10.0, 10.1 openSUSE 10.2, 10.3,
    11.0, 11.1' (http://www.swerdna.net.au/linux.html).
    Good luck!


    --
    supertimorplusfort
    ------------------------------------------------------------------------
    supertimorplusfort's Profile: http://forums.opensuse.org/member.php?userid=1970
    View this thread: http://forums.opensuse.org/showthread.php?t=403984


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •