Results 1 to 3 of 3

Thread: Message says, "Compositing too slow, KWIN turned off"

  1. #1
    Psquared NNTP User

    Default Message says, "Compositing too slow, KWIN turned off"


    I've got Suse 11.0 with KDE 4.1.3 running and just did a rather thorough
    upgrade yesterday. I'm on a laptop with 3 gigs of ram, 64 mb or
    dedicated video ram (Intel 915) and a dual core processor.

    Today (twice now) I've gotten a pop up message saying that

    > compositing was running too slow and DE have been turned off. To restart
    > press Shift-Alt-F12.


    I did a search for this error message and could not find anything at
    all. I'll try googling it, but wanted to post this in case someone else
    had run into it.

    I am only using KWIN. I DO NOT have Compiz even installed. (although I
    once did and I uninstalled it because it crashed my computer)


    --
    Psquared
    ------------------------------------------------------------------------
    Psquared's Profile: http://forums.opensuse.org/member.php?userid=3895
    View this thread: http://forums.opensuse.org/showthread.php?t=403943


  2. #2
    Axeia NNTP User

    Default Re: Message says, "Compositing too slow, KWIN turned off"


    Kwin comes with it's own effects as well, hell it even has the famous
    cube.

    Since you only have 64MB of videocard RAM I'm guessing the problem lies
    there.
    To disable the effects completely, go to the KDE4 menu and search for
    "Configure Desktop" (by default already on favorites though.. first
    thing you'll see).
    Then go to *Desktop*, deselect the *Enable desktop effects* checkbox
    and apply the changes.
    You might instead of completely disabling setting everything to "no
    effect" and leave window management on.. since it's quite nifty and I
    doubt it's actually related to anything the videocard is used for.


    --
    *Server:* openSUSE 11.1, Athlon 64 LE-1640, HDD 3 * 1TB, 1*640GB, 2GB
    RAM, Ati Radeon 3200
    *Desktop:* openSUSE 11.1, Intel Q6600, HDD 2 * 320GB, 4GB RAM, NVIDIA
    8800GT
    *Laptop:* openSUSE 11.1, Intel p8400, HDD 280GB, 4GB RAM, NVIDIA 9600GT
    ------------------------------------------------------------------------
    Axeia's Profile: http://forums.opensuse.org/member.php?userid=4794
    View this thread: http://forums.opensuse.org/showthread.php?t=403943


  3. #3
    freedguy NNTP User

    Default Re: Message says, "Compositing too slow, KWIN turned off"


    I get the same message after I finish playing massive games.

    Its not a bug. Its a Kwin's intelligent feature to lessen the memory
    load.


    --
    freedguy
    ------------------------------------------------------------------------
    freedguy's Profile: http://forums.opensuse.org/member.php?userid=11067
    View this thread: http://forums.opensuse.org/showthread.php?t=403943


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •