Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: KDE Doesn't Detect Widescreen Monitor

  1. #1
    mdoubledragon NNTP User

    Default KDE Doesn't Detect Widescreen Monitor


    Hi All,

    I was trying to set widescreen resolution on my laptop using
    nvidia-settings and I found out that as KDE is not detecting my monitor
    as widescreen, nvidia driver is also not getting that information. I
    think that is why when I try to set the resolution to WXGA in Sax2, it
    falls back to XGA on re-login.

    I searched online and all I could find is how to fix this in Gnome
    (Ubuntu forums) but couldn't find anything about KDE. Please help.


    --
    mdoubledragon
    ------------------------------------------------------------------------
    mdoubledragon's Profile: http://forums.opensuse.org/member.php?userid=3314
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


  2. #2
    caf4926 NNTP User

    Default Re: KDE Doesn't Detect Widescreen Monitor


    post

    /etc/X11/xorg.conf

    also in a su terminal do:

    hwinfo

    near the top should be info on your video card/chip


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.87) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    http://tinyurl.com/985fp2
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


  3. #3
    mdoubledragon NNTP User

    Default Re: KDE Doesn't Detect Widescreen Monitor


    Hi,

    Here is the xorg.conf:


    Code:
    --------------------

    # /.../
    # SaX generated X11 config file
    # Created on: 2009-01-03T10:10:04+0300.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #


    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "dri"
    Load "dbe"
    Load "freetype"
    Load "extmod"
    Load "glx"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 341 192
    HorizSync 30-94
    Identifier "Monitor[0]"
    ModelName "YC475 154WU1 LCD MONITOR"
    Option "DPMS"
    Option "PreferredMode" "1280x800"
    VendorName "LPL"
    VertRefresh 50-60
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "GeForce Go 7300"
    Driver "nvidia"
    Identifier "Device[0]"
    VendorName "NVIDIA"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    InputDevice "Mouse[5]" "SendCoreEvents"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection


    --------------------


    Here is the hwinfo:


    Code:
    --------------------

    121: udi = '/org/freedesktop/Hal/devices/pci_10de_1d7'
    pci.device_class = 3 (0x3)
    info.subsystem = 'pci'
    pci.device_subclass = 0 (0x0)
    info.product = 'G72M [Quadro NVS 110M/GeForce Go 7300]'
    pci.device_protocol = 0 (0x0)
    info.udi = '/org/freedesktop/Hal/devices/pci_10de_1d7'
    pci.vendor = 'nVidia Corporation'
    linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0'
    info.vendor = 'nVidia Corporation'
    info.parent = '/org/freedesktop/Hal/devices/pci_8086_27a1'
    pci.product = 'G72M [Quadro NVS 110M/GeForce Go 7300]'
    pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0'
    pci.subsys_vendor = 'Dell'
    pci.product_id = 471 (0x1d7)
    linux.hotplug_type = 2 (0x2)
    pci.vendor_id = 4318 (0x10de)
    linux.subsystem = 'pci'
    info.linux.driver = 'nvidia'
    pci.subsys_product_id = 460 (0x1cc)
    pci.subsys_vendor_id = 4136 (0x1028)

    --------------------


    Also I noticed one more thing. If I change the screen aspect ratio in
    Sax2 from 16/10 to 16/9, it doesn't take effect and on next sax2 login,
    its again 16/10.


    --
    mdoubledragon
    ------------------------------------------------------------------------
    mdoubledragon's Profile: http://forums.opensuse.org/member.php?userid=3314
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


  4. #4
    caf4926 NNTP User

    Default Re: KDE Doesn't Detect Widescreen Monitor


    Have a look here
    'HCL/Nvidia Video Cards - openSUSE'
    (http://en.opensuse.org/HCL/Nvidia_Video_Cards)

    Also check the boot argument in /boot/grub/menu.lst
    vga=???

    you might try failsafe boot
    which may land you at a CLI login then do
    startx

    see what happens


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.87) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    http://tinyurl.com/985fp2
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


  5. #5
    mdoubledragon NNTP User

    Default Re: KDE Doesn't Detect Widescreen Monitor


    caf4926;1920572 Wrote:
    > Have a look here
    > 'HCL/Nvidia Video Cards - openSUSE'
    > (http://en.opensuse.org/HCL/Nvidia_Video_Cards)
    >
    > Also check the boot argument in /boot/grub/menu.lst
    > vga=???
    >
    > you might try failsafe boot
    > which may land you at a CLI login then do
    > startx
    >
    > see what happens


    In menu.lst, the vga parameter is 0x317. Also I tried rebooting in
    failsafe and in init level 3 and changed sax2 configuration from there.
    If I change from one non-widescreen to another non-widescreen
    resolution, the change stays. Otherwise it falls back to XGA. Same is
    the case when I change aspect ratio from 16/10 to 16/9; the change is
    ignored as if the hardware is telling it otherwise.


    --
    mdoubledragon
    ------------------------------------------------------------------------
    mdoubledragon's Profile: http://forums.opensuse.org/member.php?userid=3314
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


  6. #6
    caf4926 NNTP User

    Default Re: KDE Doesn't Detect Widescreen Monitor


    0x317 is not widescreen, I think it is 1024x768

    There is a way to know the right setting, but I forget. maybe google
    it, but I have to logout now sorry.


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.87) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    http://tinyurl.com/985fp2
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


  7. #7
    mdoubledragon NNTP User

    Default Re: KDE Doesn't Detect Widescreen Monitor


    caf4926;1920577 Wrote:
    > 0x317 is not widescreen, I think it is 1024x768
    >
    > There is a way to know the right setting, but I forget. maybe google
    > it, but I have to logout now sorry.


    I googled for the vga modes and it looks like the grub vga mode only
    determines which resolution is used during boot-up screen. Is this
    right? If it is then this parameter should not be a problem.


    --
    mdoubledragon
    ------------------------------------------------------------------------
    mdoubledragon's Profile: http://forums.opensuse.org/member.php?userid=3314
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


  8. #8
    geoffro NNTP User

    Default Re: KDE Doesn't Detect Widescreen Monitor


    The vga modes are just for booting so you can leave it as 0x317.
    To get your resolution working try this: Open a console type *su* then
    root pass then
    *nvidia-xconfig* then *nvidia-settings* set you resolution and save to
    xconfig.

    In kde you can also set the resolution open kicker > configure desktop
    > computer administration > display.


    However should be enough to use the nvidia settings above

    /Geoff


    --
    Core 2 Duo 3.16GHz 4GB DDR2 2.5 TB GeForce 7600 GS OS 11.1 x86_64
    KDE4.2 beta2 'Smolt specs' (http://tinyurl.com/9hgxhl)
    ------------------------------------------------------------------------
    geoffro's Profile: http://forums.opensuse.org/member.php?userid=75
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


  9. #9
    mdoubledragon NNTP User

    Default Re: KDE Doesn't Detect Widescreen Monitor


    geoffro;1920603 Wrote:
    > The vga modes are just for booting so you can leave it as 0x317.
    > To get your resolution working try this: Open a console type *su* then
    > root pass then
    > *nvidia-xconfig* then *nvidia-settings* set you resolution and save to
    > xconfig.
    >
    > In kde you can also set the resolution open kicker > configure desktop
    > > computer administration > display.

    >
    > However should be enough to use the nvidia settings above
    >
    > /Geoff


    Actually I tried that and found out that widescreen resolutions are not
    appearing in nvidia-settings tool. This first tip me off that KDE or X
    itself is not recognizing the LCD as widescreen.


    --
    mdoubledragon
    ------------------------------------------------------------------------
    mdoubledragon's Profile: http://forums.opensuse.org/member.php?userid=3314
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


  10. #10
    mdoubledragon NNTP User

    Default Re: KDE Doesn't Detect Widescreen Monitor


    bump bump


    --
    mdoubledragon
    ------------------------------------------------------------------------
    mdoubledragon's Profile: http://forums.opensuse.org/member.php?userid=3314
    View this thread: http://forums.opensuse.org/showthread.php?t=403821


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •