Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Disabling beagle on openSuSE 11.1

  1. #1
    stephanhh NNTP User

    Default Disabling beagle on openSuSE 11.1


    Hi,

    I followed the recommendation in another thread and removed
    beagle-crawl-system from /etc/cron.daily.
    After I started my computer this morning I was surprised to see that
    "ps aux|grep 'beagle'" still found two processes related to beagle.

    How do I stop this dog for good? I don't want to uninstall it as I
    might want to use it later.

    Thanks, Stephan


    --
    stephanhh
    ------------------------------------------------------------------------
    stephanhh's Profile: http://forums.opensuse.org/member.php?userid=12638
    View this thread: http://forums.opensuse.org/showthread.php?t=403745


  2. #2
    RicardoVarasSantana NNTP User

    Default Re: Disabling beagle on openSuSE 11.1


    I thought that just clicking on it would do. Anyway I uninstalled it.


    --
    RicardoVarasSantana
    ------------------------------------------------------------------------
    RicardoVarasSantana's Profile: http://forums.opensuse.org/member.php?userid=8061
    View this thread: http://forums.opensuse.org/showthread.php?t=403745


  3. #3
    bwalex NNTP User

    Default Re: Disabling beagle on openSuSE 11.1


    I also uninstalled it, it also gets rid of that search box in the "start
    menu".


    --
    bwalex
    ------------------------------------------------------------------------
    bwalex's Profile: http://forums.opensuse.org/member.php?userid=18473
    View this thread: http://forums.opensuse.org/showthread.php?t=403745


  4. #4
    RicardoVarasSantana NNTP User

    Default Re: Disabling beagle on openSuSE 11.1


    bwalex;1920186 Wrote:
    > I also uninstalled it, it also gets rid of that search box in the "start
    > menu".

    You are right. I also uninstalled mono-core and if no I want to have
    the search box back again, it requires:

    libc.so.6()(64bit)
    libc.so.6(GLIBC_2.2.5)(64bit)
    libc.so.6(GLIBC_2.4)(64bit)
    libc.so.6(GLIBC_2.3.4)(64bit)
    libm.so.6()(64bit)
    libpthread.so.0()(64bit)
    libc.so.6(GLIBC_2.3)(64bit)
    libz.so.1()(64bit)
    libdl.so.2()(64bit)
    libpthread.so.0(GLIBC_2.2.5)(64bit)
    libX11.so.6()(64bit)
    libglib-2.0.so.0()(64bit)
    libfreetype.so.6()(64bit)
    libXau.so.6()(64bit)
    libgobject-2.0.so.0()(64bit)
    libXext.so.6()(64bit)
    libSM.so.6()(64bit)
    libICE.so.6()(64bit)
    libgmodule-2.0.so.0()(64bit)
    librt.so.1()(64bit)
    libpng12.so.0()(64bit)
    libgio-2.0.so.0()(64bit)
    libxcb.so.1()(64bit)
    libxml2.so.2()(64bit)
    libxcb-xlib.so.0()(64bit)
    libgthread-2.0.so.0()(64bit)
    libuuid.so.1()(64bit)
    /bin/bash
    libbz2.so.1()(64bit)
    libjpeg.so.62()(64bit)
    libsqlite3.so.0()(64bit)
    libXss.so.1()(64bit)
    gtk-sharp2
    libgsf-1.so.114()(64bit)
    glib-sharp2
    shared-mime-info
    libwmflite-0.2.so.7()(64bit)
    desktop-data
    libwmf-0.2.so.7()(64bit)
    libmono.so.0()(64bit)
    libmono.so.0(VER_1)(64bit)
    wv
    /usr/bin/pdftotext
    libwv-1.2.so.1()(64bit)
    *mono-data-sqlite
    mono-web
    mono(mscorlib) = 2.0.0.0
    mono(glib-sharp) = 2.12.0.0
    mono(System) = 2.0.0.0
    mono(Mono.Posix) = 2.0.0.0
    mono(System.Xml) = 2.0.0.0
    mono(NDesk.DBus) = 1.0.0.0
    beagle-lang = 0.3.8
    mono(System.Data) = 2.0.0.0
    mono(NDesk.DBus.GLib) = 1.0.0.0
    mono(ICSharpCode.SharpZipLib) = 2.84.0.0
    mono(System.Web) = 2.0.0.0
    mono(taglib-sharp) = 2.0.3.0
    mono(Mono.Data.Sqlite) = 2.0.0.0
    mono(gmime-sharp) = 2.2.0.0
    mono(avahi-sharp) = 1.0.0.0
    mono(gsf-sharp) = 0.0.0.7
    mono-core >= 1.1.13.5
    *gmime-sharp >= 2.2.1
    gsf-sharp >= 0.6
    /bin/sh
    /usr/sbin/useradd
    /bin/rm
    /usr/sbin/groupadd
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadIsLzma) <= 4.4.2-1
    rpmlib(VersionedDependencies) <= 3.0.3-1


    --
    RicardoVarasSantana
    ------------------------------------------------------------------------
    RicardoVarasSantana's Profile: http://forums.opensuse.org/member.php?userid=8061
    View this thread: http://forums.opensuse.org/showthread.php?t=403745


  5. #5
    tralalire NNTP User

    Default Re: Disabling beagle on openSuSE 11.1


    If you want to fine tune the behavior of beagle, here are the "right"
    files to modify:

    # grep "CRAWL_ENABLED" /etc/beagle/crawl-rules/*
    /etc/beagle/crawl-rules/crawl-applications:CRAWL_ENABLED="yes"
    /etc/beagle/crawl-rules/crawl-documentation:CRAWL_ENABLED="yes"
    /etc/beagle/crawl-rules/crawl-executables:CRAWL_ENABLED="no"
    /etc/beagle/crawl-rules/crawl-manpages:CRAWL_ENABLED="yes"
    /etc/beagle/crawl-rules/crawl-monodoc:CRAWL_ENABLED="no"

    # sed -i s/CRAWL_ENABLED=\"yes\"/CRAWL_ENABLED=\"no\"/g
    /etc/beagle/crawl-rules/*

    # grep "CRAWL_ENABLED" /etc/beagle/crawl-rules/*
    /etc/beagle/crawl-rules/crawl-applications:CRAWL_ENABLED="no"
    /etc/beagle/crawl-rules/crawl-documentation:CRAWL_ENABLED="no"
    /etc/beagle/crawl-rules/crawl-executables:CRAWL_ENABLED="no"
    /etc/beagle/crawl-rules/crawl-manpages:CRAWL_ENABLED="no"
    /etc/beagle/crawl-rules/crawl-monodoc:CRAWL_ENABLED="no"

    And if you want to get rid of the beagle icon at startup you can remove
    the file "/etc/xdg/autostart/beagled-autostart.desktop"


    --
    Stress is bad...
    ------------------------------------------------------------------------
    tralalire's Profile: http://forums.opensuse.org/member.php?userid=1015
    View this thread: http://forums.opensuse.org/showthread.php?t=403745


  6. #6
    stephanhh NNTP User

    Default Re: Disabling beagle on openSuSE 11.1


    Hi,

    thanks for all the help so far.
    I'd like to understand this issue, not just solve it.
    What I don't understand is: who starts the beagle demon?
    I removed it from /etc/cron.daily.
    But 'ps aux' shows 'beagled' running.
    The owner is 'stephan'.

    Any hints?

    Thanks, Stephan


    --
    stephanhh
    ------------------------------------------------------------------------
    stephanhh's Profile: http://forums.opensuse.org/member.php?userid=12638
    View this thread: http://forums.opensuse.org/showthread.php?t=403745


  7. #7
    Odin NNTP User

    Default Re: Disabling beagle on openSuSE 11.1

    Do you have a beagle icon on the task bar? If so left click it. In
    the window that pops up find "Open Configuration Dialog" (or
    something like that, I'm using OS 10.3 and KDE 3x) and click on that.

    In the new window that pops up click on the "Deamon Status" find the
    button labeled "Stop" and click it. It should STAY stopped even after
    a reboot. If you ever need/want beagle again you can find the "Stop"
    button now says "Start" and you will know what to do.

    Simple, no remove everything or don't install it or clean out the
    cron required.

  8. #8
    james dedon NNTP User

    Default Re: Disabling beagle on openSuSE 11.1


    The way I see it is that there's really no good reason to disable beagle
    other than the fact that it takes up a few hundred megs of ram. But who
    cares? I have a gig of ram in an old laptop and it runs just fine. I
    don't see the point of spending my days killing processes just so I can
    keep my memory load at 300 megs. Let 'em roll. Plus, the nice value is
    at 7 so if you need that memory for anything else it's going to give it
    up. Plus, it's a really nice search program to have around to find
    stuff.


    --
    james_dedon
    ------------------------------------------------------------------------
    james_dedon's Profile: http://forums.opensuse.org/member.php?userid=19494
    View this thread: http://forums.opensuse.org/showthread.php?t=403745


  9. #9
    ken yap NNTP User

    Default Re: Disabling beagle on openSuSE 11.1


    I just did a


    Code:
    --------------------
    zypper rm beagle
    --------------------


    That fixed the pooch for good. I don't need it running. I know where
    things are in my system, I don't need a local search. Having an indexer
    running wastes electricity and adds wear and tear to my system.


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=403745


  10. #10
    metalwraith NNTP User

    Default Re: Disabling beagle on openSuSE 11.1


    Now this is cool.. I updated Banshee media player... it uninstalled
    pretty much all of beagle at the same time.


    --
    metalwraith
    ------------------------------------------------------------------------
    metalwraith's Profile: http://forums.opensuse.org/member.php?userid=18941
    View this thread: http://forums.opensuse.org/showthread.php?t=403745


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •