Results 1 to 4 of 4

Thread: KDE 4.2 KDM will not start

  1. #1
    CJstone NNTP User

    Default KDE 4.2 KDM will not start


    I had installed KDE 4.2b2 on an OpenSUSE 11.0 system, and it worked
    fine. I recently installed OpenSUSE 11.1, and upgraded to KDE 4.2b2. KDM
    now fails with the error "/usr/bin/xrdb: Connection reset by peer." I
    can run startx, and get to a desktop, so it's not the Xorg
    configuration.


    --
    CJstone
    ------------------------------------------------------------------------
    CJstone's Profile: http://forums.opensuse.org/member.php?userid=18833
    View this thread: http://forums.opensuse.org/showthread.php?t=403603


  2. #2
    zak89 NNTP User

    Default Re: KDE 4.2 KDM will not start


    I am getting the same behavior with KDE 4.2b2. I am not seeing the error
    you mention, but KDM is consistently not starting an X server. startx
    does it every time.

    I suspect it's a bug in KDM4. I am going to try KDM3 to verify this.


    --
    openSUSE 11.0; Kernel 2.6.25-pae; Intel Core 2 Quad Q6600 - 2.4Ghz; 6GB
    DDR2 RAM; M-Audio Delta 44 Audio Interface; 640GB SATA Disk.
    ------------------------------------------------------------------------
    zak89's Profile: http://forums.opensuse.org/member.php?userid=10788
    View this thread: http://forums.opensuse.org/showthread.php?t=403603


  3. #3
    CJstone NNTP User

    Default Re: KDE 4.2 KDM will not start


    The error is in the KDM log. It isn't written to the terminal.


    --
    CJstone
    ------------------------------------------------------------------------
    CJstone's Profile: http://forums.opensuse.org/member.php?userid=18833
    View this thread: http://forums.opensuse.org/showthread.php?t=403603


  4. #4
    blackyK4 NNTP User

    Default Re: KDE 4.2 KDM will not start


    Hi there,

    I think I have the same problem with SuSE 11.1 and KDE 4.1.3. X is not
    starting every time, but the command startx works.
    I won't get an error on the console. Where is the error log for KDE?

    The message "/usr/bin/xrdb: Connection reset by peer." seems that there
    is a problem with the permission. Maybe when the computer will start X,
    it has no permission to do that. But some milliseconds later, the
    permission was set correct so it is possible to start the X-Server with
    startx.

    But how can be solved that X is starting automatically every time?

    (Please apologize my bad english, I'm german.)

    Greets
    Siena


    --
    blackyK4
    ------------------------------------------------------------------------
    blackyK4's Profile: http://forums.opensuse.org/member.php?userid=21854
    View this thread: http://forums.opensuse.org/showthread.php?t=403603


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •