Results 1 to 2 of 2

Thread: Unable to Disable Print Screen Key in GNOME Desktop

  1. #1
    chada67 NNTP User

    Default Unable to Disable Print Screen Key in GNOME Desktop

    I am a new-ish Linux developer, coming from a MS Windows background, so
    please bear with me here...

    I have researched this particular problem for a couple of days now, and
    have explored some of the suggested solutions without success, other
    than learning much more about Linux. I am hoping someone can offer some
    good advice.

    I am working on a kiosk right now and as part of the application, I
    need to disable the Print Screen keyboard button.

    I have used 'xmodmap' to map keycode 111 to NoSymbol, but that is not
    stopping the Snapshot dialog from appearing.

    I am using OpenSuSE 10.3 with a GNOME desktop on an IBM PC with a
    Logitech USB keyboard.

    I have tried swapping the keyboard with a PS/2 keyboard to see if that
    was the problem, but it was not.

    The strange thing is that when I use VNC 4.1.3 Free Edition to remote
    into this system from another IBM PC (Windows XP Pro OS), I am able to
    use the xmodmap -e "keycode 111 = NoSymbol" command to successfully
    prevent the Snapshot dialog from appearing.

    Is there some kind of keyboard mapping override or shortcut mapping
    going on here when I am logged into the Linux box locally, but is not
    happening remotely?

    Please advise.

    chada67's Profile:
    View this thread:

  2. #2
    Zaitor NNTP User

    Default Re: Unable to Disable Print Screen Key in GNOME Desktop

    Not sure, but take a look in gnome control center -> keyboardshortcuts.
    Disable the 2 printscreen keys there.

    Zaitor's Profile:
    View this thread:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts