Results 1 to 3 of 3

Thread: is Xvfb colorblind?

  1. #1
    amhines NNTP User

    Default is Xvfb colorblind?


    I'm trying to run a graphical application in the background of a
    headless server for scientific work. But when I run *Xvfb* with basic
    values, it croaks if I attempt to access a shared or private colormap.
    What's up with that?!? Works perfectly if I ship it to a remote
    terminal, but that's not an option for what I need.
    Is there an argument that specifies the color depth or something?
    Running SLES 9/10, but don't think that should really matter.


    --
    amhines
    ------------------------------------------------------------------------
    amhines's Profile: http://forums.opensuse.org/member.php?userid=18695
    View this thread: http://forums.opensuse.org/showthread.php?t=403473


  2. #2
    amhines NNTP User

    Default Re: is Xvfb colorblind?


    OK, I posted without enough info. I requested 8 bit color (WxHx8), but
    if I shoot some simple windows at my virtual display and grab the
    results with an xwd, every pixel is either black or white. If I try to
    display a color image, it either gives an X_StoreColors failure, or just
    plots solid black.


    --
    amhines
    ------------------------------------------------------------------------
    amhines's Profile: http://forums.opensuse.org/member.php?userid=18695
    View this thread: http://forums.opensuse.org/showthread.php?t=403473


  3. #3
    amhines NNTP User

    Default Re: is Xvfb colorblind?


    The plot thickens.
    When I run the same procesdure on a machine with a graphics head, it
    works perfectly.
    Here's my procedure:

    > Xvfb :3 -ac -screen 1 1024x768x8 +bs -fbdir /tmp &
    > setenv DISPLAY :3
    > xv pretty_pix.jpg &
    > xwd -display :3 -root -out window_1.xwd


    So on one machine it gives me the expected desktop image. On the
    headless machine, I get an image of a solid black window on an empty
    desktop. Or, if I try another application,using a private colormap, it
    gives an error:

    X Error of failed request: BadAccess (attempt to access private
    resource denied)
    Major opcode of failed request: 89 (X_StoreColors)
    Serial number of failed request: 2061
    Current serial number in output stream: 3227

    Any takers?


    --
    amhines
    ------------------------------------------------------------------------
    amhines's Profile: http://forums.opensuse.org/member.php?userid=18695
    View this thread: http://forums.opensuse.org/showthread.php?t=403473


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •