Results 1 to 9 of 9

Thread: Yast problem after online update

  1. #1
    beli0135 NNTP User

    Default Yast problem after online update


    Hello

    (running openSUSE 11.0, KDE 4.2)

    After online update, Yast started to crash. Yast panel opens, but when
    I select anything inside it (like software management, boot loader etc.)
    it crashes and gives error:

    YaST got signal 11 at YCP file
    /usr/share/YaST2/clients/inst_packages.ycp:36
    /sbin/yast2: line 421: 4378 Segmentation fault $ybindir/y2base
    $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS



    How do I resolve this?
    Thanks


    --
    beli0135
    ------------------------------------------------------------------------
    beli0135's Profile: http://forums.opensuse.org/member.php?userid=1101
    View this thread: http://forums.opensuse.org/showthread.php?t=406282


  2. #2
    caf4926 NNTP User

    Default Re: Yast problem after online update


    - remove /var/cache/zypp/zypp.db and /var/cache/zypp/zypp.db-journal

    sudo rpmdb --rebuilddb

    - then run 'zypper refresh'

    try yast again.

    If necessary run it from CLI to re-install all yast packages


    --
    Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)"82.1" | Intel 965 GM |
    Lenovo R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=406282


  3. #3
    ram88 NNTP User

    Default Re: Yast problem after online update


    beli0135;1935225 Wrote:
    > Hello
    >
    > (running openSUSE 11.0, KDE 4.2)
    >
    > After online update, Yast started to crash. Yast panel opens, but when
    > I select anything inside it (like software management, boot loader etc.)
    > it crashes and gives error:
    >
    > YaST got signal 11 at YCP file
    > /usr/share/YaST2/clients/inst_packages.ycp:36
    > /sbin/yast2: line 421: 4378 Segmentation fault $ybindir/y2base
    > $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    >
    >
    >
    > How do I resolve this?
    > Thanks

    Are you tried to update unconditionally your YaST packages also with
    yast but from the CLI?


    --
    http://yami.googlecode.com/
    http://akoskm.blogspot.com/
    ------------------------------------------------------------------------
    ram88's Profile: http://forums.opensuse.org/member.php?userid=1058
    View this thread: http://forums.opensuse.org/showthread.php?t=406282


  4. #4
    pilotgi NNTP User

    Default Re: Yast problem after online update


    I'm getting the same error message as beli0135. I submitted a bug report
    to Novell's bugzilla but haven't heard anything yet.

    I tried deleting the zypp files mentioned above and reinstalling the
    YaST packages but that didn't fix the problem.


    --
    pilotgi
    ------------------------------------------------------------------------
    pilotgi's Profile: http://forums.opensuse.org/member.php?userid=1313
    View this thread: http://forums.opensuse.org/showthread.php?t=406282


  5. #5
    pilotgi NNTP User

    Default Re: Yast problem after online update


    Actually several days ago I deleted some zypp files following some
    instructions I found on the mailing lists. The files listed above
    sounded like the ones I deleted, but after checking, I discovered that I
    don't have these files.

    I have /var/cache/zypp, but there's no zypp files within this
    directory.


    --
    pilotgi
    ------------------------------------------------------------------------
    pilotgi's Profile: http://forums.opensuse.org/member.php?userid=1313
    View this thread: http://forums.opensuse.org/showthread.php?t=406282


  6. #6
    ram88 NNTP User

    Default Re: Yast problem after online update


    pilotgi;1935289 Wrote:
    > Actually several days ago I deleted some zypp files following some
    > instructions I found on the mailing lists. The files listed above
    > sounded like the ones I deleted, but after checking, I discovered that I
    > don't have these files.
    >
    > I have /var/cache/zypp, but there's no zypp files within this
    > directory.

    This directory is the local cache for zypper. It doesn't cause anything
    if you delete files from them. Next time if your run

    Code:
    --------------------

    zypper refresh

    --------------------

    zypper fills this cache with repo data.


    --
    http://yami.googlecode.com/
    http://akoskm.blogspot.com/
    ------------------------------------------------------------------------
    ram88's Profile: http://forums.opensuse.org/member.php?userid=1058
    View this thread: http://forums.opensuse.org/showthread.php?t=406282


  7. #7
    beli0135 NNTP User

    Default Re: Yast problem after online update


    I still haven't had time to fix as you suggested, but last night, I
    uninstalled Yast completely, then reinstalled it. I get the same error
    in GUI, but when run from console it works.
    Seems that some library that handles gui is broken.


    --
    beli0135
    ------------------------------------------------------------------------
    beli0135's Profile: http://forums.opensuse.org/member.php?userid=1101
    View this thread: http://forums.opensuse.org/showthread.php?t=406282


  8. #8
    ststeppat NNTP User

    Default Re: Yast problem after online update


    Hello,

    i have the some problem. I used at first openSUSE11.1 and now i install
    SUSE 11.0 and it is the some problem.

    has anyone a workaround or any help ?

    thanxs a lot

    Stefan


    --
    ststeppat
    ------------------------------------------------------------------------
    ststeppat's Profile: http://forums.opensuse.org/member.php?userid=21292
    View this thread: http://forums.opensuse.org/showthread.php?t=406282


  9. #9
    beli0135 NNTP User

    Default Re: Yast problem after online update


    When I find it, I will post here.

    Seems that some package of yast was updated and it is broken.
    For now, use yast from console when you need to fix something


    --
    beli0135
    ------------------------------------------------------------------------
    beli0135's Profile: http://forums.opensuse.org/member.php?userid=1101
    View this thread: http://forums.opensuse.org/showthread.php?t=406282


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •