Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Yast Software manager freezes

  1. #1
    metalman2000 NNTP User

    Default Yast Software manager freezes


    I just installed OpenSuse 11.1, and upgraded from 10.3 . The package
    manager was a little wonky. Everytime I tried to update, it froze in
    the middle. Using command-line zypper as root froze also, during
    downloading of certain packages (libvzio, for example).

    So, I decided to clean out the cache.
    zypper clean -a

    That was a bad idea. Now, whenever I open the software manager, it
    freezes, saying "loading package manager".

    Same with zypper.
    linux:/home/scott # zypper -v update
    Verbosity: 1
    Initializing Target

    Any idea?

    Thanks


    --
    metalman2000
    ------------------------------------------------------------------------
    metalman2000's Profile: http://forums.opensuse.org/member.php?userid=18561
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


  2. #2
    caf4926 NNTP User

    Default Re: Yast Software manager freezes


    boot to runlevel 3
    login as user then go su

    rpmdb --rebuilddb

    zypper ref

    zypper dup


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.85) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE 4.1.85 "release 3.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


  3. #3
    ramaswamyps NNTP User

    Default Re: Yast Software manager freezes


    a newly installed suse-11.1 updated with yast finds no more updates.

    but running a zypper dup wants to install 115 packages of updates!!!


    --
    ramaswamyps
    ------------------------------------------------------------------------
    ramaswamyps's Profile: http://forums.opensuse.org/member.php?userid=16339
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


  4. #4
    caf4926 NNTP User

    Default Re: Yast Software manager freezes


    Give us

    zypper lr


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.85) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE 4.1.85 "release 3.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


  5. #5
    metalman2000 NNTP User

    Default Re: Yast Software manager freezes


    caf4926;1917622 Wrote:
    > boot to runlevel 3
    > login as user then go su
    >
    > rpmdb --rebuilddb
    >
    > zypper ref
    >
    > zypper dup


    "zypper ref" worked. But "zypper dup" hangs. Same with "zypper up"
    and "lu" and pretty much every other command.

    zypper lr works.

    These are the enabled repositories:
    openSUSE 11.1-0
    openSUSE-11.1-Update
    openSUSE-11.1-Oss
    openSUSE-11.1-Non-Oss

    Thanks


    --
    metalman2000
    ------------------------------------------------------------------------
    metalman2000's Profile: http://forums.opensuse.org/member.php?userid=18561
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


  6. #6
    caf4926 NNTP User

    Default Re: Yast Software manager freezes


    What do you get from

    zypper up -t yast2


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.85) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    http://tinyurl.com/985fp2
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


  7. #7
    metalman2000 NNTP User

    Default Re: Yast Software manager freezes


    caf4926;1918259 Wrote:
    > What do you get from
    >
    > zypper up -t yast2


    linux:/home/scott # zypper up -t yast2
    Unknown package type 'yast2'.


    --
    metalman2000
    ------------------------------------------------------------------------
    metalman2000's Profile: http://forums.opensuse.org/member.php?userid=18561
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


  8. #8
    caf4926 NNTP User

    Default Re: Yast Software manager freezes


    Ok try

    zypper in -f yast2

    you could try add in the * at the end to do all yast2 (the f = force)

    zypper in -f yast2*


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.86) "5.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    http://tinyurl.com/985fp2
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


  9. #9
    metalman2000 NNTP User

    Default Re: Yast Software manager freezes


    caf4926;1919074 Wrote:
    > Ok try
    >
    > zypper in -f yast2
    >
    > you could try add in the * at the end to do all yast2 (the f = force)
    >
    > zypper in -f yast2*


    linux:/home/scott # zypper -v in -f yast2
    Verbosity: 1
    Non-option program arguments: 'yast2'
    Initializing Target
    <freeze>

    Same with yast2*

    Is there a directory or something I can delete? I remember last time I
    had problems with zypper (in like suse 10.2 or something) I had to
    delete /var/lib/zypper/ or something? Somehow clear the cache? Can't
    quite remember how I fixed that.


    --
    metalman2000
    ------------------------------------------------------------------------
    metalman2000's Profile: http://forums.opensuse.org/member.php?userid=18561
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


  10. #10
    caf4926 NNTP User

    Default Re: Yast Software manager freezes


    In a terminal do

    rpm -qi yast2

    what do you get?

    You could try, booting to runlevel3
    login and go su
    then run

    yast

    It should run a basic form of yast for you so you can re-install all
    yast and do updates

    (runlevel3, can be reached from default boot, clear all boot arguments
    and just type: 3 )
    (then hit enter)


    --
    Box: Linux 2.6.27.7-9 i686 | OS 11.1 | (KDE4.1.87) "3.1" | M2N4-SLI |
    AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE4.1.87)"3.1" | Intel 965 GM | Lenovo
    R61e | 3GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=403330


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •