Results 1 to 3 of 3

Thread: Unresponsive GUI, slow Firefox, with Nvidia card - EXPLAINED

  1. #1
    cabrilo NNTP User

    Default Unresponsive GUI, slow Firefox, with Nvidia card - EXPLAINED


    Hello everybody,

    I browsed through the forums and I see several people encountered same
    problems as me with 11.0 and 11.1.

    The problems are:

    - Unresponsive GUI in general
    - Choppy and slow resize of windows
    - Slow scrolling
    - Slow terminals
    - Slow Firefox in general
    - Firefox choking on javascript effects (fade in, fade out, and such)
    or fixed backgrounds
    - To define: *SLOW 2D PERFORMANCE*


    Good test is to go to:
    'Getting Started with Firefox'
    (http://en-us.www.mozilla.com/en-US/firefox/central/) and click on tabs
    (Work, Learn, Play, Connect). If content fade in/fade outs are smooth,
    then you are good to go, and if they are choppy and bring your CPU to
    knees - and you have a Nvidia card - this is the post for you.


    I finally got around to what the problem is:

    N-v-i-d-i-a- -p-r-o-p-r-i-e-t-a-r-y- -d-r-i-v-e-r-s- -w-o-r-k-
    -t-e-r-r-i-b-l-y- -b-a-d-l-y- -i-n- -2-D- -w-i-t-h- -n-e-w-
    -g-r-a-p-h-i-c- -c-a-r-d-s- -(-s-e-r-i-e-s- -8-x-x-x- -a-n-d-
    -9-x-x-x-)-,- -a-n-d- -s-o- -d-o- -n-v- -a-n-d- -n-o-u-v-e-a-u-.-

    Using gtkperf ('GtkPerf' (http://gtkperf.sourceforge.net/)) - a simple
    benchmarking tool to measure 2d performance I got about the following
    results for 100 iterations:

    nv drivers: 18 seconds
    nvidia drivers: 16 seconds
    vesa drivers: 10 seconds

    That should give you an idea about the quality of both nv and nvidia
    drivers. 3d works about right with nvidia.

    Anyway, after some googling, I stumbled upon this link:
    'nVidia 8000/9000 Series Performance Issues - nV News Forums'
    (http://www.nvnews.net/vbulletin/showthread.php?t=115916)

    I suggest everybody with those problems to read through it.

    Doing the following really quicked up my nvidia drivers:


    Code:
    --------------------
    nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
    --------------------

    (make a script out of it and execute it on your DE startup)

    and adding:


    Code:
    --------------------

    Option "PixmapCacheSize" "300000"
    Option "OnDemandVBlankInterrupts" "True"

    --------------------


    to my xorg.conf "Device" section.

    This is another interesting reading:
    ' 2D benchmarks on Linux Nvidia, Intel, ATI: xrender on Jkx@home
    Blog Archive' (http://www.larsen-b.com/Article/290.html) (benchmark of
    2d performance between ATI and NVIDIA on Linux).

    I hope I helped some of you and hopefully I saved you a lot of time and
    frustration...

    Cheers,
    Dejan


    --
    cabrilo
    ------------------------------------------------------------------------
    cabrilo's Profile: http://forums.opensuse.org/member.php?userid=18552
    View this thread: http://forums.opensuse.org/showthread.php?t=403322


  2. #2
    shakyb NNTP User

    Default Re: Unresponsive GUI, slow Firefox, with Nvidia card - EXPLAINED


    Thanks! this worked for me (NVIDIA 8600M GS + Gnome 2.24 + OpenSUSE
    11.1).

    For testing: 'Firefox 3 Linux Performance Bugz'
    (http://lubosz.de/Firefox3PerformanceBug/)


    --
    shakyb
    ------------------------------------------------------------------------
    shakyb's Profile: http://forums.opensuse.org/member.php?userid=19191
    View this thread: http://forums.opensuse.org/showthread.php?t=403322


  3. #3
    emsellem NNTP User

    Default Re: Unresponsive GUI, slow Firefox, with Nvidia card - EXPLAINED


    Sorry but I installed the latest NVIDIA driver 180.22_2 x86_64 and
    resizing windows is AMAZINGLY SLOW. In fact it is not usable at all,
    since it takes about 6-7 seconds for the window to be resized, WHEN it
    works at all (most of the time it does not in fact and just get stuck to
    a small size when I try to enlarge the konsole).

    I am using the tricks you indicated (nvidia-settings, xconf) and this
    didn't do anything. I also changed to Share memory in the Desktop
    setting issue but no luck.

    I am really tired with the NVIDIA issue. next time I'll buy something
    else for sure.

    But if anybody has an idea of how to make this work I am ready to be
    convinced otherwise

    Using Opensuse 11.1, KDE 4.1.2 (Release 4.9) on a Sony Vaio Laptop with
    NVIDIA 8400M GS


    --
    emsellem
    ------------------------------------------------------------------------
    emsellem's Profile: http://forums.opensuse.org/member.php?userid=17535
    View this thread: http://forums.opensuse.org/showthread.php?t=403322


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •