Results 1 to 2 of 2

Thread: libc.so.6(GLIBC_2.4) is needed

  1. #1
    vivek1717 NNTP User

    Default libc.so.6(GLIBC_2.4) is needed


    Hi All,

    While trying to install libattr on opensuse10-32,I am getting the
    following error:
    opensuse10-32:/BUILDS/HEAD/SOURCE # rpm -ivh
    libattr-devel-2.4.28-38.i586.rpm libattr-2.4.28-81.i586.rpm
    error: Failed dependencies:
    libc.so.6(GLIBC_2.4) is needed by libattr-2.4.28-81

    The OS version is :
    opensuse10-32:/BUILDS/HEAD/SOURCE # cat /etc/SuSE-release
    SUSE LINUX 10.0 (i586) OSS
    VERSION = 10.0

    I have already Glibc rpm installed:
    glibc-2.3.5-40

    Any help is appreciated.

    Thanks and Regards,
    Vivek


    --
    vivek1717
    ------------------------------------------------------------------------
    vivek1717's Profile: http://forums.opensuse.org/member.php?userid=18532
    View this thread: http://forums.opensuse.org/showthread.php?t=403304


  2. #2
    kdemello NNTP User

    Default Re: libc.so.6(GLIBC_2.4) is needed


    Your glibc looks to be too old to run that version of libattr.

    Is that on SLE? 10 was a confusing release, they didn't come to their
    senses about naming things until 10.2.

    The reason I ask is if I remember correctly, 10.2 and below are now end
    of life.

    The easiest thing would probably be to obtain an earlier version of
    libattr.


    --
    kdemello
    ------------------------------------------------------------------------
    kdemello's Profile: http://forums.opensuse.org/member.php?userid=1583
    View this thread: http://forums.opensuse.org/showthread.php?t=403304


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •