Results 1 to 4 of 4

Thread: build package for 11.1, not possible to install icons

  1. #1
    bruno pages NNTP User

    Default build package for 11.1, not possible to install icons


    Hi,

    I try to package a tool for openSUSE 11.1, I have an error relative to
    icons while almost is done :


    Code:
    --------------------

    ... checking filelist
    bouml-4.9-9.1.i586.rpm: directories not owned by a package:
    - /usr/share/icons/hicolor
    - /usr/share/icons/hicolor/16x16
    - /usr/share/icons/hicolor/16x16/apps
    - /usr/share/icons/hicolor/32x32
    - /usr/share/icons/hicolor/32x32/apps
    - /usr/share/icons/hicolor/48x48
    - /usr/share/icons/hicolor/48x48/apps
    - /usr/share/icons/hicolor/64x64
    - /usr/share/icons/hicolor/64x64/apps
    --------------------


    the end of my spec file is :

    Code:
    --------------------

    %files
    %defattr(-,root,root)
    %if 0%{?suse_version}
    %else
    %dir %{_datadir}/applications
    %dir %{_datadir}/icons/hicolor/16x16/apps
    %dir %{_datadir}/icons/hicolor/32x32/apps
    %dir %{_datadir}/icons/hicolor/48x48/apps
    %dir %{_datadir}/icons/hicolor/64x64/apps
    %endif
    %{_bindir}/bouml
    %{_bindir}/projectControl
    %{_bindir}/projectSynchro
    %{_datadir}/icons/hicolor/16x16/apps/bouml.png
    %{_datadir}/icons/hicolor/32x32/apps/bouml.png
    %{_datadir}/icons/hicolor/48x48/apps/bouml.png
    %{_datadir}/icons/hicolor/64x64/apps/bouml.png
    %{_datadir}/icons/hicolor/16x16/apps/projectControl.png
    %{_datadir}/icons/hicolor/16x16/apps/projectSynchro.png
    %{_datadir}/icons/hicolor/32x32/apps/projectControl.png
    %{_datadir}/icons/hicolor/32x32/apps/projectSynchro.png
    %{_datadir}/icons/hicolor/48x48/apps/projectControl.png
    %{_datadir}/icons/hicolor/48x48/apps/projectSynchro.png
    %{_datadir}/icons/hicolor/64x64/apps/projectControl.png
    %{_datadir}/icons/hicolor/64x64/apps/projectSynchro.png
    %{_datadir}/applications/bouml.desktop
    %{_datadir}/applications/projectControl.desktop
    %{_datadir}/applications/projectSynchro.desktop
    %{_libdir}/bouml
    --------------------


    I invalided the lines like "%dir %{_datadir}/applications" in case of
    suse to (try to) avoid similar message about these directories

    is something changed about icons with 11.1 ?

    I can make the package without any problems with the same spec file for
    openSUSE 10.3 and openSUSE 11.0 (and other packages like RHEL etc)

    my project is under
    https://build.opensuse.org/package/show?package=Bouml


    Thanks for your help

    Bruno


    --
    bruno_pages
    ------------------------------------------------------------------------
    bruno_pages's Profile: http://forums.opensuse.org/member.php?userid=12891
    View this thread: http://forums.opensuse.org/showthread.php?t=403280


  2. #2
    Monex NNTP User

    Default Re: build package for 11.1, not possible to install icons


    Hi,

    just remove following if else clause:

    Code:
    --------------------

    %if 0%{?suse_version}
    ...

    --------------------


    That should do it I had a similar issue.

    Hope this helps


    --
    Monex
    ------------------------------------------------------------------------
    Monex's Profile: http://forums.opensuse.org/member.php?userid=160
    View this thread: http://forums.opensuse.org/showthread.php?t=403280


  3. #3
    bruno pages NNTP User

    Default Re: build package for 11.1, not possible to install icons


    Hi,

    I first tried without success without the %if

    the problem was these lines was not enough, it is needed to have :

    Code:
    --------------------

    %files
    %dir %{_datadir}/icons/hicolor
    %dir %{_datadir}/icons/hicolor/16x16
    %dir %{_datadir}/icons/hicolor/16x16/apps
    %dir %{_datadir}/icons/hicolor/32x32
    %dir %{_datadir}/icons/hicolor/32x32/apps
    %dir %{_datadir}/icons/hicolor/48x48
    %dir %{_datadir}/icons/hicolor/48x48/apps
    %dir %{_datadir}/icons/hicolor/64x64
    %dir %{_datadir}/icons/hicolor/64x64/apps

    --------------------


    furthermore the line -%dir %{_datadir}/applications- must be removed

    in fact this was an old error in my spec, but in the 11.1 the checks
    was improved and more errors are now detected

    thanks for your answer and happy new year

    Bruno


    --
    bruno_pages
    ------------------------------------------------------------------------
    bruno_pages's Profile: http://forums.opensuse.org/member.php?userid=12891
    View this thread: http://forums.opensuse.org/showthread.php?t=403280


  4. #4
    Monex NNTP User

    Default Re: build package for 11.1, not possible to install icons


    Hi,

    glad to see that you got it working now. I just have one more hint how
    you can disable some of the more strict checks just add "BuildRequires:
    -post-build-checks -rpmlint-Factory" to the spec file

    Happy new year


    --
    Monex
    ------------------------------------------------------------------------
    Monex's Profile: http://forums.opensuse.org/member.php?userid=160
    View this thread: http://forums.opensuse.org/showthread.php?t=403280


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •