Results 1 to 10 of 10

Thread: Yast Applications - Busy Mouse Cursor - takes forever to go

  1. #1
    acompw NNTP User

    Default Yast Applications - Busy Mouse Cursor - takes forever to go


    The YAST Control Center opens instantly BUT...

    opening YAST utilities causes the _pointer_to_become_a_busy_one_ and
    stays there for 7-10 seconds - AFTER, the initial checks w/ the progress
    bars (-starting the software manager- window if using "package manager",
    or -initializing user & group information- window if using "User and
    Group Management.")

    My box is quite fast - quad 2.4 w/ 4gb ram. No matter if I had
    previously opened a YAST util, the time it takes from when I first click
    the utility to the time the busy cursor disappears is still around 7-10
    seconds. The application appears to have been loaded completely, but
    that darn busy cursor is still there.

    I know the utilities can be used with the busy cursor, but I'd like to
    know why it takes so long for it to go away.



    Anyone else experiencing this? Any solutions?


    --
    acompw
    ------------------------------------------------------------------------
    acompw's Profile: http://forums.opensuse.org/member.php?userid=18464
    View this thread: http://forums.opensuse.org/showthread.php?t=403247


  2. #2
    nzlbob23 NNTP User

    Default Re: Yast Applications - Busy Mouse Cursor - takes forever to go


    Try opening it in a terminal and see what output its giving


    --
    nzlbob23
    ------------------------------------------------------------------------
    nzlbob23's Profile: http://forums.opensuse.org/member.php?userid=672
    View this thread: http://forums.opensuse.org/showthread.php?t=403247


  3. #3
    acompw NNTP User

    Default Re: Yast Applications - Busy Mouse Cursor - takes forever to go


    Interesting -> This behavior only occurs when the utility is run from
    the Yast Control Center

    running
    Code:
    --------------------
    /sbin/yast2 sw_single
    --------------------
    in a terminal as root causes the utility to popup quick, and no busy
    pointer. But starting up YAST, and then Software Management causes the
    busy cursor to stay for about 10 seconds.

    No terminal output.

    Is this a bug?

    Also want to mention that this behavior occurs on ALL YAST programs
    I've tried.


    --
    acompw
    ------------------------------------------------------------------------
    acompw's Profile: http://forums.opensuse.org/member.php?userid=18464
    View this thread: http://forums.opensuse.org/showthread.php?t=403247


  4. #4
    baskitcaise NNTP User

    Default Re: Yast Applications - Busy Mouse Cursor - takes forever to go

    acompw wrote:

    >
    > The YAST Control Center opens instantly BUT...
    >
    > opening YAST utilities causes the _pointer_to_become_a_busy_one_ and
    > stays there for 7-10 seconds - AFTER, the initial checks w/ the
    > progress bars (-starting the software manager- window if using
    > "package manager", or -initializing user & group information- window
    > if using "User and Group Management.")
    >
    > My box is quite fast - quad 2.4 w/ 4gb ram. No matter if I had
    > previously opened a YAST util, the time it takes from when I first
    > click the utility to the time the busy cursor disappears is still
    > around 7-10 seconds. The application appears to have been loaded
    > completely, but that darn busy cursor is still there.
    >
    > I know the utilities can be used with the busy cursor, but I'd like to
    > know why it takes so long for it to go away.
    >
    >
    >
    > Anyone else experiencing this? Any solutions?
    >
    >


    Have a look in /home/<user-name>/.kde4/share/config/klaunchrc

    you should see something like:

    <<--snip-->>

    [BusyCursorSettings]
    Blinking=false
    Bouncing=true
    Timeout=10

    [FeedbackStyle]
    BusyCursor=true
    TaskbarButton=true

    [TaskbarButtonSettings]
    Timeout=10

    <<--pins-->>


    You can change the timeout settings here so that the cursor and taskbar notification does not last so long.

    HTH

    --
    Mark....

    Nil illegitimi carborundum

  5. #5
    nzlbob23 NNTP User

    Default Re: Yast Applications - Busy Mouse Cursor - takes forever to go


    Good reply, I also found you can change those settings in Configure
    Desktop>Desktop>Launch Feedback from the main menu. It gives a good help
    article on what its all about too.


    --
    nzlbob23
    ------------------------------------------------------------------------
    nzlbob23's Profile: http://forums.opensuse.org/member.php?userid=672
    View this thread: http://forums.opensuse.org/showthread.php?t=403247


  6. #6
    acompw NNTP User

    Default Re: Yast Applications - Busy Mouse Cursor - takes forever to go


    I'm running GNOME

    Also, the proposed solutions don't actually solve the problem I'm
    having - they're hacks & something should be done about this. Can anyone
    else confirm they're experiencing the same behavior?


    --
    acompw
    ------------------------------------------------------------------------
    acompw's Profile: http://forums.opensuse.org/member.php?userid=18464
    View this thread: http://forums.opensuse.org/showthread.php?t=403247


  7. #7
    baskitcaise NNTP User

    Default Re: Yast Applications - Busy Mouse Cursor - takes forever to go

    acompw wrote:

    >
    > I'm running GNOME


    Ah you should have said in first post :-)

    Sorry don`t do Gnome.
    >
    > Also, the proposed solutions don't actually solve the problem I'm
    > having - they're hacks & something should be done about this. Can
    > anyone else confirm they're experiencing the same behavior?
    >
    >


    They are not `hacks` these are alterations that have been around for years and are included in the desktop settings precisely for that reason.

    HTH

    --
    Mark....

    Nil illegitimi carborundum

  8. #8
    acompw NNTP User

    Default Re: Yast Applications - Busy Mouse Cursor - takes forever to go


    Then, simply - why does the busy cursor remain so long when accessing it
    from YAST but not when I access the application from the terminal?

    baskitcaise;1917495 Wrote:
    > acompw wrote:
    >
    > >
    > > I'm running GNOME

    >
    > Ah you should have said in first post :-)
    >
    > Sorry don`t do Gnome.
    > >
    > > Also, the proposed solutions don't actually solve the problem I'm
    > > having - they're hacks & something should be done about this. Can
    > > anyone else confirm they're experiencing the same behavior?
    > >
    > >

    >
    > They are not `hacks` these are alterations that have been around for
    > years and are included in the desktop settings precisely for that
    > reason.
    >
    > HTH
    >
    > --
    > Mark....
    >
    > Nil illegitimi carborundum



    --
    acompw
    ------------------------------------------------------------------------
    acompw's Profile: http://forums.opensuse.org/member.php?userid=18464
    View this thread: http://forums.opensuse.org/showthread.php?t=403247


  9. #9
    acompw NNTP User

    Default Re: Yast Applications - Busy Mouse Cursor - takes forever to go


    Did a clean 11.1 install, same thing


    --
    acompw
    ------------------------------------------------------------------------
    acompw's Profile: http://forums.opensuse.org/member.php?userid=18464
    View this thread: http://forums.opensuse.org/showthread.php?t=403247


  10. #10
    acompw NNTP User

    Default Re: Yast Applications - Busy Mouse Cursor - takes forever to go


    *Behavior does not occur when Install Software is clicked from Computer
    menu*


    --
    acompw
    ------------------------------------------------------------------------
    acompw's Profile: http://forums.opensuse.org/member.php?userid=18464
    View this thread: http://forums.opensuse.org/showthread.php?t=403247


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •