Results 1 to 10 of 10

Thread: Scratching sounds in opensuse 11.1

  1. #1
    kpt j t kirk NNTP User

    Default Scratching sounds in opensuse 11.1


    Hi ,

    after installing opensuse 11.1 all works well the only
    problem i have is that there comes a strange sound out my speakers off
    my notebook it is a scratching sound .
    Is there a way to make this go away it is the only distribution where i
    have the problem i had it also in opensuse 11.0 normally i use gnome but
    i have the same problem with kde 3.5.10 and kde 4.1.
    what must i do to make this go away because i like to use suse because
    it is my favorite distro please help me


    ps :sorry for my bad english


    --
    kpt_j_t_kirk
    ------------------------------------------------------------------------
    kpt_j_t_kirk's Profile: http://forums.opensuse.org/member.php?userid=2069
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


  2. #2
    zak89 NNTP User

    Default Re: Scratching sounds in opensuse 11.1


    Your english is fine, pal!

    While I imagine oldcpu will be the fellow to help you out, what are
    your mixer settings (look in KMix)? Is the sound constant? Or does it
    just happen occasionally?

    Do you get normal application sounds as well?


    --
    openSUSE 11.0; Kernel 2.6.25-pae; Intel Core 2 Quad Q6600 - 2.4Ghz; 6GB
    DDR2 RAM; M-Audio Delta 44 Audio Interface; 640GB SATA Disk.
    ------------------------------------------------------------------------
    zak89's Profile: http://forums.opensuse.org/member.php?userid=10788
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


  3. #3
    oldcpu NNTP User

    Default Re: Scratching sounds in opensuse 11.1


    kpt_j_t_kirk;1916852 Wrote:
    > after installing opensuse 11.1 all works well the only
    > problem i have is that there comes a strange sound out my speakers off
    > my notebook it is a scratching sound .
    > Is there a way to make this go away it is the only distribution where i
    > have the problem i had it also in opensuse 11.0 normally i use gnome but
    > i have the same problem with kde 3.5.10 and kde 4.1.
    > Some more detail. to support zak89's suggestion, is you could go to YaST
    > Hardware > Sound > Other > Volume and move the volume bars there up to

    75% (about - you need to iterative this to get the best level). Then
    close YaST and go to your mixer, and back off on your PCM and master
    volume.

    If this is a Laptop PC, test this with battery ONLY, and also with
    nominal wired AC power.

    If the above does not help, you could provide more information. To
    provide more information, with your PC connected to the Internet, can
    you provide the output URL of running the following in a gnome-terminal
    or a kde konsole:
    Code:
    --------------------
    /usr/sbin/alsa-info.sh
    --------------------
    When the script completes it will pass you a URL. Please post that URL
    here.

    Also, please copy and paste the following into a gnome-terminal or
    konsole and post the output here.::rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    rpm -q padevchooser pavucontrol pavumeter paman paprefs
    uname -a
    cat /etc/modprobe.d/sound::


    --
    oldcpu
    ------------------------------------------------------------------------
    oldcpu's Profile: http://forums.opensuse.org/member.php?userid=77
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


  4. #4
    ryanbach NNTP User

    Default Re: Scratching sounds in opensuse 11.1


    I have the same issue: http://tinyurl.com/9k97d6


    Code:
    --------------------
    username@linux-dx5z:~/Desktop> rpm -qa | grep alsa
    alsa-oss-32bit-1.0.17-1.37
    alsa-plugins-1.0.18-6.13
    alsa-oss-1.0.17-1.43
    alsa-utils-1.0.18-6.4
    alsa-plugins-pulse-32bit-1.0.18-6.12
    alsa-plugins-jack-32bit-1.0.18-6.12
    alsa-plugins-pulse-1.0.18-6.13
    alsa-plugins-samplerate-32bit-1.0.18-6.12
    alsa-plugins-32bit-1.0.18-6.12
    alsa-1.0.18-8.9
    username@linux-dx5z:~/Desktop> rpm -qa | grep pulse
    pulseaudio-module-lirc-0.9.12-9.5
    libpulse0-0.9.12-9.5
    libpulse-mainloop-glib0-0.9.12-9.5
    pulseaudio-module-zeroconf-0.9.12-9.5
    pulseaudio-module-bluetooth-0.9.12-9.5
    libpulse0-32bit-0.9.12-9.6
    pulseaudio-module-jack-0.9.12-9.5
    pulseaudio-esound-compat-0.9.12-9.5
    libpulse-browse0-0.9.12-9.5
    pulseaudio-utils-0.9.12-9.5
    pulseaudio-0.9.12-9.5
    libpulse-simple0-0.9.10-0.pm.2
    alsa-plugins-pulse-32bit-1.0.18-6.12
    libpulsecore4-0.9.12-9.5
    alsa-plugins-pulse-1.0.18-6.13
    libxine1-pulse-1.1.15-20.8
    pulseaudio-module-gconf-0.9.12-9.5
    pulseaudio-module-x11-0.9.12-9.5
    username@linux-dx5z:~/Desktop> rpm -q libasound2
    libasound2-1.0.18-8.9
    username@linux-dx5z:~/Desktop> rpm -q padevchooser pavucontrol pavumeter paman paprefs
    padevchooser-0.9.4-72.87
    pavucontrol-0.9.7-2.9
    pavumeter-0.9.3-43.118
    paman-0.9.4-4.122
    paprefs-0.9.7-1.30
    username@linux-dx5z:~/Desktop> uname -a
    Linux linux-dx5z 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
    username@linux-dx5z:~/Desktop> cat /etc/modprobe.d/sound

    options snd slots=snd-via82xx
    # Ssy1.5yl6jWle_c3:VT8233/A/8235/8237 AC97 Audio Controller
    alias snd-card-0 snd-via82xx
    --------------------


    --
    ryanbach
    ------------------------------------------------------------------------
    ryanbach's Profile: http://forums.opensuse.org/member.php?userid=17431
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


  5. #5
    oldcpu NNTP User

    Default Re: Scratching sounds in opensuse 11.1


    ryanbach;1917048 Wrote:
    > I have the same issue: http://tinyurl.com/9k97d6

    Thank you for your post.

    I know you are just trying to make it easier (by putting this in a
    thread where you believe a user has the same problem), but in truth this
    makes it much harder for me. I end up having multiple users, on the
    same thread, that I have to support, and I have to keep the users
    separate in my mind as I iterate back and forth with support. I have to
    hunt up and down in the thread to figure out what user is which. What
    post corresponds to what. Plus the users tend to get confused whether
    my support suggestions are for them, or for the other person in the
    thread. This is because 95% of the time, the users have different
    hardware, and that means the problem often has a different solution.

    You did not explain what you have tried. Could you please go to YaST >
    Hardware > Sound > Other > Volume and move the volume bars there up to
    75% (about - you need to iterative this to get the best level). Then
    close YaST and go to your mixer, and back off on your PCM and master
    volume.

    If that does not work, then please let me know.

    And be careful, because it may now be difficult to sort your hardware
    specifics from that of user kpt_j_t_kirk.


    --
    oldcpu
    ------------------------------------------------------------------------
    oldcpu's Profile: http://forums.opensuse.org/member.php?userid=77
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


  6. #6
    kpt j t kirk NNTP User

    Default Re: Scratching sounds in opensuse 11.1


    If the above does not help, you could provide more information. To
    provide more information, with your PC connected to the Internet, can
    you provide the output URL of running the following in a gnome-terminal
    or a kde konsole:
    Code:
    --------------------
    /usr/sbin/alsa-info.sh
    --------------------
    When the script completes it will pass you a URL. Please post that URL
    here.

    Also, please copy and paste the following into a gnome-terminal or
    konsole and post the output here.::rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    rpm -q padevchooser pavucontrol pavumeter paman paprefs
    uname -a
    cat /etc/modprobe.d/sound::


    i have try it via yast but without result.
    Here is the output i made in the terminal

    'git.alsa-project.org Git - alsa-driver.git/history - utils/alsa-info.sh'
    (http://www.alsa-project.org/alsa-info.sh.changelog)


    linux-6rxo:/home/qbashi # rpm -qa | grep alsa
    alsa-oss-1.0.17-1.37
    alsa-utils-1.0.18-6.4
    alsa-plugins-pulse-1.0.18-6.12
    alsa-plugins-1.0.18-6.12
    alsa-1.0.18-8.7
    linux-6rxo:/home/qbashi # rpm -qa | grep pulse
    pulseaudio-0.9.12-9.6
    pulseaudio-module-gconf-0.9.12-9.6
    pulseaudio-module-lirc-0.9.12-9.6
    libpulse-mainloop-glib0-0.9.12-9.6
    alsa-plugins-pulse-1.0.18-6.12
    libpulse-browse0-0.9.12-9.6
    pulseaudio-utils-0.9.12-9.6
    pulseaudio-module-zeroconf-0.9.12-9.6
    libpulse0-0.9.12-9.6
    libpulsecore4-0.9.12-9.6
    pulseaudio-esound-compat-0.9.12-9.6
    pulseaudio-module-x11-0.9.12-9.6
    pulseaudio-module-bluetooth-0.9.12-9.6
    linux-6rxo:/home/qbashi # rpm -q libasound2
    libasound2-1.0.18-8.7
    linux-6rxo:/home/qbashi # rpm -q padevchooser pavucontrol pavumeter paman
    paprefs
    padevchooser-0.9.4-72.88
    pavucontrol-0.9.7-2.9
    pavumeter-0.9.3-43.144
    paman-0.9.4-4.136
    paprefs-0.9.7-1.29
    linux-6rxo:/home/qbashi # uname -a
    Linux linux-6rxo 2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686
    i686 i386 GNU/Linux
    linux-6rxo:/home/qbashi # cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # u1Nb.Xr0+ey1p7G5:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel


    --
    kpt_j_t_kirk
    ------------------------------------------------------------------------
    kpt_j_t_kirk's Profile: http://forums.opensuse.org/member.php?userid=2069
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


  7. #7
    kpt j t kirk NNTP User

    Default Re: Scratching sounds in opensuse 11.1


    I also forgot to say that i also have the problem when the soundvolume
    is off.


    --
    kpt_j_t_kirk
    ------------------------------------------------------------------------
    kpt_j_t_kirk's Profile: http://forums.opensuse.org/member.php?userid=2069
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


  8. #8
    oldcpu NNTP User

    Default Re: Scratching sounds in opensuse 11.1


    kpt_j_t_kirk;1917066 Wrote:
    > 'git.alsa-project.org Git - alsa-driver.git/history -
    > utils/alsa-info.sh' (http://www.alsa-project.org/alsa-info.sh.changelog)


    kpt_j_t_kirk, thats the change history of your updating the diagnostic
    script. Thats not useful to me.

    Please run that script again, please be careful, and this time please
    provide the *correct* URL it provides. You can run the script by
    typing:::/usr/sbin/alsa-info.sh::thanks!


    --
    oldcpu
    ------------------------------------------------------------------------
    oldcpu's Profile: http://forums.opensuse.org/member.php?userid=77
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


  9. #9
    kpt j t kirk NNTP User

    Default Re: Scratching sounds in opensuse 11.1


    oldcpu;1917099 Wrote:
    > kpt_j_t_kirk, thats the change history of your updating the diagnostic
    > script. Thats not useful to me.
    >
    > Please run that script again, please be careful, and this time please
    > provide the *correct* URL it provides. You can run the script by
    > typing:::/usr/sbin/alsa-info.sh::thanks!



    This may be better?

    http://tinyurl.com/7cckjq


    --
    kpt_j_t_kirk
    ------------------------------------------------------------------------
    kpt_j_t_kirk's Profile: http://forums.opensuse.org/member.php?userid=2069
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


  10. #10
    oldcpu NNTP User

    Default Re: Scratching sounds in opensuse 11.1


    kpt_j_t_kirk;1917133 Wrote:
    > This may be better?
    >
    > http://tinyurl.com/7cckjq

    OK, so your PC has a Conexant CX20549, which I believe is another name
    for the CX5045 (from here: 'Search results - AlsaProject'
    (http://tinyurl.com/5nxsbg) ) .

    In an above post, I asked that you go to YaST > Hardware > Sound >
    Other > Volume and move your volume levels up to 75% (about - you need
    to iterative this to get the best level). Then close YaST and go to your
    mixer, and back off on your PCM and master volume.

    You stated you did this.

    But when I look at your mixer output I see this:

    !!Amixer output
    !!-------------

    !!-------Mixer controls for card 0 [Intel]

    Card hw:0 'Intel'/'HDA Intel at 0xde300000 irq 22'
    Mixer name : 'Conexant CX20549 (Venice)'
    Simple mixer control 'Master',0
    Capabilities: pvolume pswitch pswitch-joined
    Front Left: Playback 43 [*100%*] [0.00dB] [on]
    Front Right: Playback 43 [*100%*] [0.00dB] [on]
    Simple mixer control 'PCM',0
    Capabilities: pvolume pswitch
    Front Left: Playback 20 [*100%*] [0.00dB] [on]
    Front Right: Playback 20 [*100%*] [0.00dB] [on]100% in both.
    Clearly you did NOT back off on your master and PCM volume. There is no
    point in us proceeding until you do so, as that could be your problem.


    --
    oldcpu
    ------------------------------------------------------------------------
    oldcpu's Profile: http://forums.opensuse.org/member.php?userid=77
    View this thread: http://forums.opensuse.org/showthread.php?t=403220


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •