Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: The login screen cannot display

  1. #1
    thangola NNTP User

    Default The login screen cannot display


    Last week, after install successful OpenSUSE 11.1 from the KDE4 LiveCD,
    I install the kde4-amarok-2.0 with yast2. The installation was fail and
    after that I cant login to desktop through the login screen. After the
    green boot screen finished loading, this message error box appeared:
    > "No greeter widget plugin loaded."

    After I click the "OK" button of the message box, the screen returned
    to the console login screen.
    I must login with this then use startx to start the X.

    I also cant shutdown, restart or lock my laptop. I can only logout to
    the console screen and then shutdown my laptop here.

    Thanks for read and... Any ideas?

    More infos:
    - I'm use HP6530s laptop
    > linux-ogso:~ # uname -a
    > Linux linux-ogso 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100
    > i686 i686 i386 GNU/Linux



    --
    . ( )
    +--oOO--------OOo--+
    | Think Linux |
    | Think Differently|
    +------------------+
    ------------------------------------------------------------------------
    thangola's Profile: http://forums.opensuse.org/member.php?userid=17492
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


  2. #2
    caf4926 NNTP User

    Default Re: The login screen cannot display


    Boot failsafe and at the login prompt, login with your username and
    password, then
    do this:

    mv /home/*usernme/.kde4 .kde4old

    (*username = replace with your username, and notice the period . )

    when done reboot
    ===============

    see if that helps, it will create a totally new .kde4 folder


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.85) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE 4.1.85 "release 3.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


  3. #3
    thangola NNTP User

    Default Re: The login screen cannot display


    Thanks for reply. But there is no change. I still have to use startx to
    start KDE.


    --
    . ( )
    +--oOO--------OOo--+
    | Think Linux |
    | Think Differently|
    +------------------+
    ------------------------------------------------------------------------
    thangola's Profile: http://forums.opensuse.org/member.php?userid=17492
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


  4. #4
    caf4926 NNTP User

    Default Re: The login screen cannot display


    Post your

    /boot/grub/menu.lst


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.85) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE 4.1.85 "release 3.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


  5. #5
    thangola NNTP User

    Default Re: The login screen cannot display


    caf4926;1914721 Wrote:
    > Post your
    >
    > /boot/grub/menu.lst

    My English is not good, so perharps u haven't understood me. This is my
    problem:
    - The login screen doesn't appear, and there is a dialog with the
    content: "No greeter widget plugin loaded. Check the configuration" and
    an OK button.
    - When I click the OK button, I am brought back to the console login
    screen (lv3 login).
    - I can connect to the X server and start KDE with the command startx.
    - I cannot lock, shutdown or restart my laptop. When I click Lock
    button to lock my session, a dialog appears. And this is its content:
    > Will not lock the session, as unlocking would be impossible:
    > No appropriate greeter plugin confifured.


    Anyway, this is my menu.lst:
    > # cat /boot/grub/menu.lst
    > # Modified by YaST2. Last modification on Fri Dec 19 00:13:42 ICT 2008
    > default 0
    > timeout 8
    > gfxmenu (hd0,1)/boot/message
    > ##YaST - activate
    >
    > ###Don't change this comment - YaST2 identifier: Original name:
    > linux###
    > title openSUSE 11.1
    > root (hd0,1)
    > kernel /boot/vmlinuz-2.6.27.7-9-default
    > root=/dev/disk/by-id/ata-FUJITSU_MHZ2120BH_G2_K615T872G0L1-part2
    > resume=/dev/sda4 splash=silent showopts vga=0x317
    > initrd /boot/initrd-2.6.27.7-9-default
    >
    > ###Don't change this comment - YaST2 identifier: Original name: windows
    > 1###
    > title Win Vista
    > rootnoverify (hd0,0)
    > chainloader +1
    >
    > ###Don't change this comment - YaST2 identifier: Original name:
    > failsafe###
    > title Failsafe -- openSUSE 11.1
    > root (hd0,1)
    > kernel /boot/vmlinuz-2.6.27.7-9-default
    > root=/dev/disk/by-id/ata-FUJITSU_MHZ2120BH_G2_K615T872G0L1-part2
    > showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off
    > powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe
    > vga=0x317
    > initrd /boot/initrd-2.6.27.7-9-default



    --
    . ( )
    +--oOO--------OOo--+
    | Think Linux |
    | Think Differently|
    +------------------+
    ------------------------------------------------------------------------
    thangola's Profile: http://forums.opensuse.org/member.php?userid=17492
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


  6. #6
    deano ferrari NNTP User

    Default Re: The login screen cannot display


    Hi thangola

    This is a strange one. I found a similar thread 'here'
    (http://linux.derkeiler.com/Mailing-L.../msg02722.html).

    As you can see they were missing kde4-kdm package. Check with

    rpm -qa |grep kde4-kdm

    For reference, I get

    > rpm -qa |grep kde4-kdm
    > kde4-kdm-branding-openSUSE-11.0-81.48
    > kde4-kdm-branding-upstream-4.1.3-152.6
    > kde4-kdm-4.1.3-152.6


    Hopefully its something as simple as this.


    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


  7. #7
    thangola NNTP User

    Default Re: The login screen cannot display


    Thanks for reply, deano_ferrari ^^.
    It seems this is my problem. When I check my packages:

    Code:
    --------------------
    rpm -qa |grep kde4-kdm
    kde4-kdm-branding-openSUSE-11.1-66.4
    kde4-kdm-4.1.3-10.1
    --------------------

    I don't have a package kde4-kdm-branding-upstream installed. When I
    choose to install this package with yast, there is a conflict:

    Code:
    --------------------
    kde4-kdm-branding-openSUSE-11.1-66.4.i586 conflicts with namespacetherproviders(kde4-kdm-branding) provided by kde4-kdm-branding-upstream-4.1.85-8.1.i586
    --------------------


    What should I do now?


    --
    . ( )
    +--oOO--------OOo--+
    | Think Linux |
    | Think Differently|
    +------------------+
    ------------------------------------------------------------------------
    thangola's Profile: http://forums.opensuse.org/member.php?userid=17492
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


  8. #8
    caf4926 NNTP User

    Default Re: The login screen cannot display


    Login to a CLI as user
    go su

    then do

    zypper in kde4-kdm-branding

    (I think)

    'Zypper/Usage/11.1 - openSUSE' (http://en.opensuse.org/Zypper/Usage)

    you might just try
    zypper up


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.85) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE 4.1.85 "release 3.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


  9. #9
    deano ferrari NNTP User

    Default Re: The login screen cannot display


    If you have further problems, we may also need to see list of repos you
    have enabled. To get this info:

    zypper lr


    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


  10. #10
    thangola NNTP User

    Default Re: The login screen cannot display


    caf4926;1915372 Wrote:
    > Login to a CLI as user
    > go su
    >
    > then do
    >
    > zypper in kde4-kdm-branding
    >
    >

    The result (^o^)/

    Code:
    --------------------
    "kde4-kdm-branding-openSUSE" providing "kde4-kdm-branding" is already installed... Nothing to do
    --------------------


    --
    . ( )
    +--oOO--------OOo--+
    | Think Linux |
    | Think Differently|
    +------------------+
    ------------------------------------------------------------------------
    thangola's Profile: http://forums.opensuse.org/member.php?userid=17492
    View this thread: http://forums.opensuse.org/showthread.php?t=402823


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •