Results 1 to 8 of 8

Thread: KDE sysinfo:/ incorrect output

  1. #1
    kungfu NNTP User

    Default KDE sysinfo:/ incorrect output


    Hi all I am wondering if anyone else has come across this...

    Im using OpenSuse 11.1
    This is what is displayed

    Code:
    --------------------
    "CPU Information
    Processor (CPU): AMD Athlon(tm) 64 X2 Dual Core Processor 6000+
    Speed: 1,000.00 MHz
    Cores: 2
    Temperature: 28C"
    --------------------

    My CPU should actually be a 3Ghz not 1
    This is only wrong on sysinfo..

    Dave


    --
    Giz a Job
    The Raver
    ------------------------------------------------------------------------
    kungfu's Profile: http://forums.opensuse.org/member.php?userid=1419
    View this thread: http://forums.opensuse.org/showthread.php?t=402695


  2. #2
    caf4926 NNTP User

    Default Re: KDE sysinfo:/ incorrect output


    It looks fine.

    If powersave has cpu setting to dynamic it will automatically cut cpu
    usage when only under light load. If you want it at max all the time,
    switch to performance.


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.85) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.1 | Celeron 550 | (KDE 4.1.85 "release 3.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=402695


  3. #3
    Tilman Schmidt NNTP User

    Default Re: KDE sysinfo:/ incorrect output

    kungfu schrieb:
    > This is what is displayed
    >
    > Code:
    > --------------------
    > "CPU Information
    > Processor (CPU): AMD Athlon(tm) 64 X2 Dual Core Processor 6000+
    > Speed: 1,000.00 MHz
    > Cores: 2
    > Temperature: 28C"
    > --------------------
    >
    > My CPU should actually be a 3Ghz not 1


    It displays the speed your CPU is actually running at right now,
    not the maximum speed it could run at if necessary. Try giving
    it some work and see if the figure rises. :-)

    HTH
    T.

  4. #4
    robopensuse NNTP User

    Default Re: KDE sysinfo:/ incorrect output


    AMD Athlon(tm) 64 X2 5600+ here, and same thing.

    It is not fine it's a kernel bug (/proc/cpuinfo). I have exact same
    thing. I think it comes same with x86_amd, or i586 arch media.

    Every other OS version, and Windows shows 2.8 GHz, only 11.1-RC1, and
    11.1 have shown the suspicious number 1,000 Mhz. It remains at that
    setting no matter what and the bogomips value there is wrong to. It
    doesn't really matter, but it does mean bad data is going into Smolt.

    There's also a bug reported
    https://bugzilla.novell.com/show_bug.cgi?id=436717
    saying the CPU is locked in SMP mode to the lowest frequency, perhaps
    it's same thing.


    --
    robopensuse
    ------------------------------------------------------------------------
    robopensuse's Profile: http://forums.opensuse.org/member.php?userid=17292
    View this thread: http://forums.opensuse.org/showthread.php?t=402695


  5. #5
    robopensuse NNTP User

    Default Re: KDE sysinfo:/ incorrect output


    And here's the workround, to enjoy your processor at full speed, with
    both cores operating full SMP.

    You'll need to alter your boot command line, by altering the GRUB info
    for the 11.1 kernel. When the kernel update to fix comes out, you'll be
    able to turn CPUFREQ back on for power-saving and cooler running mode.

    rob@fir:~> cat /proc/cmdline
    root=/dev/System/Root resume=/dev/sdb5 splash=silent showopts vga=0x346
    CPUFREQ=no
    rob@fir:~> egrep 'model|cpu|bogo' /proc/cpuinfo
    cpu family : 15
    model : 67
    model name : AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
    cpu MHz : 2812.692
    cpu cores : 2
    cpuid level : 1
    bogomips : 5625.38
    cpu family : 15
    model : 67
    model name : AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
    cpu MHz : 2812.692
    cpu cores : 2
    cpuid level : 1
    bogomips : 5625.45
    fir:/mnt/home/rob #


    So add CPUFREQ=no to turn off, the slowness, it really made things
    noticeably faster for me.

    My GRUB entry for the 11.1 kernel now reads :

    title openSUSE 11.1
    root (hd1,7)
    kernel /vmlinuz-2.6.27.7-9-default root=/dev/System/Root
    resume=/dev/sdb5 splash=silent showopts vga=0x346 CPUFREQ=no
    initrd /initrd-2.6.27.7-9-default


    --
    robopensuse
    ------------------------------------------------------------------------
    robopensuse's Profile: http://forums.opensuse.org/member.php?userid=17292
    View this thread: http://forums.opensuse.org/showthread.php?t=402695


  6. #6
    robopensuse NNTP User

    Default Re: KDE sysinfo:/ incorrect output


    OK...

    Had some help investingating this to check thanks to Bugzilla.

    Bottom line is, the initial hunch I had that it was just reporting
    issues was correct.

    Whilst I have yet to do proper benchmarks to test, performance
    comparison, subjective test with it enabled, and investigation showed
    the frequency is not locked. May be my boot with CPUFREQ enabled last
    night, had background stuff running or something to slow the subjective
    test and slow it.

    So contrary to the Bugzilla bug report, the frequency was not locked on
    my system, but it is hard to avoid sampling the frequency when it's not
    on low.

    The fact that cat /proc/cpuinfo shows the slowest frequency and
    pathetic bogomips, sux.

    But I think it's just the way the kernel reports info that's wrong, not
    the actual operation of it.

    Though there may be suspicion that 'going' slow, rather than being fast
    and then idle for longer really saves power. The CPU does run cooler
    with this feature however, so I guess it is a power saver.

    I've lowered the bug report priority from highest and lowered the
    severity from Major, until there's solid evidence of a real performance
    problem.


    --
    robopensuse
    ------------------------------------------------------------------------
    robopensuse's Profile: http://forums.opensuse.org/member.php?userid=17292
    View this thread: http://forums.opensuse.org/showthread.php?t=402695


  7. #7
    kungfu NNTP User

    Default Re: KDE sysinfo:/ incorrect output


    Hi robopensuse

    That actually sorted my speed out... it now registers 3gig instead of
    1..

    Cheers

    Dave


    --
    Giz a Job
    The Raver
    ------------------------------------------------------------------------
    kungfu's Profile: http://forums.opensuse.org/member.php?userid=1419
    View this thread: http://forums.opensuse.org/showthread.php?t=402695


  8. #8
    kungfu NNTP User

    Default Re: KDE sysinfo:/ incorrect output


    I actually have kpowersave running this was set to dynamic put on
    preformace sorted...

    Thanks

    Dave


    --
    Giz a Job
    The Raver
    ------------------------------------------------------------------------
    kungfu's Profile: http://forums.opensuse.org/member.php?userid=1419
    View this thread: http://forums.opensuse.org/showthread.php?t=402695


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •