Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Desktop effects are not supported...

  1. #21
    lostowl NNTP User

    Default Re: Desktop effects are not supported...


    Hi,

    I posted a topic in this forum about ATI, Compiz and Desktop effects.

    I don't know why it's so hard, but after a while, I found the solution
    and it was easy. Try searching for posts by lostowl.

    Go to OpenSuse.org and in the search just type "ati" (or nvidia"

    At the time I wrote this, 1-click wasn't working, but if you follow the
    instructions for what to do if it goes wrong, it works.

    The summary is: for ATI:

    1) Download and install the ATI driver.
    2) Go to init 3
    3) delete or move your xorg.conf file.
    4) run sax2 -r -m 0=radeon
    5) (if you have installed the driver from ATI) run aticonfig --initial
    --input=/etc/X11/xorg.conf
    6) (assuming i didn't typo step 5) run sax2 -r -m 0=fglrx
    7) reboot

    this worked perfectly for me after days of screwing around with an
    X600.

    For nvidia, I just did the 1-click on the opensuse help page. It worked
    fine, but there is also a "the hard way" instructions that also work.

    After I did these very simple steps, Desktop Effects worked perfectly.

    The problem I have now is on my iMac G5, I can't download ATI PPC
    drivers so I can't run the aticonfig to load the fglrx entries into
    xorg.conf. Totally bumming.


    --
    lostowl
    ------------------------------------------------------------------------
    lostowl's Profile: http://forums.opensuse.org/member.php?userid=17723
    View this thread: http://forums.opensuse.org/showthread.php?t=402371


  2. #22
    richyf89 NNTP User

    Default Re: Desktop effects are not supported...


    lostowl;1914636 Wrote:
    > Hi,
    >
    > I posted a topic in this forum about ATI, Compiz and Desktop effects.
    >
    > I don't know why it's so hard, but after a while, I found the solution
    > and it was easy. Try searching for posts by lostowl.
    >
    > Go to OpenSuse.org and in the search just type "ati" (or nvidia"
    >
    > At the time I wrote this, 1-click wasn't working, but if you follow the
    > instructions for what to do if it goes wrong, it works.
    >
    > The summary is: for ATI:
    >
    > 1) Download and install the ATI driver.
    > 2) Go to init 3
    > 3) delete or move your xorg.conf file.
    > 4) run sax2 -r -m 0=radeon
    > 5) (if you have installed the driver from ATI) run aticonfig --initial
    > --input=/etc/X11/xorg.conf
    > 6) (assuming i didn't typo step 5) run sax2 -r -m 0=fglrx
    > 7) reboot
    >
    > this worked perfectly for me after days of screwing around with an
    > X600.
    >
    > For nvidia, I just did the 1-click on the opensuse help page. It worked
    > fine, but there is also a "the hard way" instructions that also work.
    >
    > After I did these very simple steps, Desktop Effects worked perfectly.
    >
    > The problem I have now is on my iMac G5, I can't download ATI PPC
    > drivers so I can't run the aticonfig to load the fglrx entries into
    > xorg.conf. Totally bumming.


    Thanks but this never worked. I did try two attempts, but it just
    doesn't make a difference.. I followed your detailed instructions and
    made sure I had the kernel-source installed. I even re-installed the ATI
    drivers.


    --
    this gospel of the kingdom will be preached in all the world as a
    witness to all the nations, and then the end will come. (Matthew 24)
    ------------------------------------------------------------------------
    richyf89's Profile: http://forums.opensuse.org/member.php?userid=9056
    View this thread: http://forums.opensuse.org/showthread.php?t=402371


  3. #23
    Cryovac NNTP User

    Default Re: Desktop effects are not supported...


    At least with legacy nvidia drivers be sure to use:

    Option "Composite" "Enable"

    Instead of:

    Option "Composite" "On"


    --
    <>---><^>
    ------------------------------------------------------------------------
    Cryovac's Profile: http://forums.opensuse.org/member.php?userid=217
    View this thread: http://forums.opensuse.org/showthread.php?t=402371


  4. #24
    lostowl NNTP User

    Default Re: Desktop effects are not supported...


    I'm sorry to hear that. What type of graphics card do you have?

    It does seem very frustrating that so many people are having trouble
    with this. I wonder if it's something simple that a lot of people just
    miss?

    I can't get Compiz working on my MacIntosh G5 with Suse11.1. I can't
    find a lot of tips out there for it, either.

    Perhaps the reason it works on my ATI desktop is because the card is
    relatively older and the drivers have been more thoroughly vetted.


    --
    lostowl
    ------------------------------------------------------------------------
    lostowl's Profile: http://forums.opensuse.org/member.php?userid=17723
    View this thread: http://forums.opensuse.org/showthread.php?t=402371


  5. #25
    rocketero2007 NNTP User

    Default Re: Desktop effects are not supported...


    Thanks for the comments here I could fix my desktop effect (compiz)

    I opened my xorg.conf and there was a "sessions" and in there composite
    was set to OFF, I changed it to ON and viola it was fixed after
    rebooting.


    --
    rocketero2007
    ------------------------------------------------------------------------
    rocketero2007's Profile: http://forums.opensuse.org/member.php?userid=22268
    View this thread: http://forums.opensuse.org/showthread.php?t=402371


Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •