Results 1 to 4 of 4

Thread: VMware tools update woes

  1. #1
    DroneZone NNTP User

    Default VMware tools update woes


    OK, I'm at the very beginning of learning Linux right now and so even
    the simplest thing gives me a head-ache. Right now I have problems
    updating the VMware tools in VMware workstation 6.5. The VMware help
    file says to run the RPM and then run vmware-config-tools.pl, so it
    should be simple but even this has caused me to come unstuck. I think
    I've installed the RPM ok (I had to uninstall open vmware tools first)
    but when I then run vmware-config-tools.pl it throws an error:

    -----

    The following VMware kernel modules have been found on your system that
    were
    not installed by the VMware Installer. Please remove them then run this

    installer again.

    vmmemctl
    vmhgfs
    vmxnet
    vmblock

    Execution aborted.

    -----

    The message also suggests deleting these files, which I do. When I
    re-run vmware-config-tools.pl it tells me that the above 4 files are now
    missing and asks me whether I want to compile them. Opting for 'yes'
    seems like the logical thing to do but then I get asked for the location
    of the Make app (so I point it to GCC) and the 'header' files (I assume
    the context of C++, and I have no idea where they are). I can't help
    thinking that I shouldn't even be at this stage since the VMware help
    files makes no mention of compiling apps and it all seems too involved.
    Anyone any idea what I've done wrong??

    Thanks

    Rob


    --
    DroneZone
    ------------------------------------------------------------------------
    DroneZone's Profile: http://forums.opensuse.org/member.php?userid=12297
    View this thread: http://forums.opensuse.org/showthread.php?t=402303


  2. #2
    Magic31 NNTP User

    Default Re: VMware tools update woes


    Hi Rob & Welcome,

    You're not really doing anything wrong.

    When running openSUSE 11.0 or 11.1 (or other *recent* Linux distros) as
    a guest on VMWare... you then get the open source version of VMware
    tools installed automatically.

    This gives you the choice to either,
    1) don't install the VMWare native tools.. it should run fine as is.
    2) first remove the opensource version packages -> to do this search
    for 'vmware' using YaST > Software Management and remove the related
    packages. After that the RPM should be able to be installed.

    If you want to install the RPM you will need to compile these.
    Compiling is a way to make the installed RPM files suitable for your
    system. The vmware-config-tools.pl is a script that does the compiling
    for you.

    Not to dazzle... but:
    Before you can compile something there are some software components you
    need first (like pans to kook in )
    Using YaST > Software Management first install;
    kernel-source
    make
    gcc
    gcc++

    After adding those packages (and removing the open version of the
    vmware tools), you should be albe to run the vmware-config-tools.pl
    script.

    Hope that helps,
    Wj


    --
    Have a lot of fun! *WJM*
    ------------------------------------------------------------------------
    Magic31's Profile: http://forums.opensuse.org/member.php?userid=289
    View this thread: http://forums.opensuse.org/showthread.php?t=402303


  3. #3
    DroneZone NNTP User

    Default Re: VMware tools update woes


    Thanks WJ! Installing those extra components seems to have done the
    trick. Re-compiling those 4 modules went well and now VMware Workstation
    is detecting that the new version of Tools is installed. Incidentally
    the open vmware tools work fine except that VMWorkstation 6.5 has some
    features (like ACE) that necessitate the 'genuine' vmware tools.

    I'm learning Linux fast though!

    Rob


    --
    DroneZone
    ------------------------------------------------------------------------
    DroneZone's Profile: http://forums.opensuse.org/member.php?userid=12297
    View this thread: http://forums.opensuse.org/showthread.php?t=402303


  4. #4
    Magic31 NNTP User

    Default Re: VMware tools update woes


    Good to hear you've sorted it! Happy Linux'n!

    Cheers,
    Wj


    --
    Have a lot of fun! *WJM*
    ------------------------------------------------------------------------
    Magic31's Profile: http://forums.opensuse.org/member.php?userid=289
    View this thread: http://forums.opensuse.org/showthread.php?t=402303


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •