Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: X-Fi Driver "make" Problems....

  1. #1
    sloppyfresh NNTP User

    Default X-Fi Driver "make" Problems....


    So this is my first post here, and I'm a relative noob to linux, so
    please bear with me....

    My computer is a Dell 8400, Pentium IV 3.4, 1.5 gig RAM, ATI X800XL,
    Soundblaster X-Fi Xtreme music

    I've been trying to manually install the X-Fi drivers (openSUSE doesn't
    recognize it automatically), but I'm hitting a very early roadblock.

    I extract the .tar.gz package, and go to the extraction directory, and
    type "make". Weather or not I am SU, I get the following error message:


    /*********/

    adam@ALIN:~/Installs/XFiDrv_Linux_Public_US_1.00> make
    make -C /lib/modules/2.6.27.7-9-pae/build
    M=/home/adam/Installs/XFiDrv_Linux_Public_US_1.00
    make[1]: Entering directory `/usr/src/linux-2.6.27.7-9-obj/i386/pae'
    make[1]: *** No targets specified and no makefile found. Stop.
    make[1]: Leaving directory `/usr/src/linux-2.6.27.7-9-obj/i386/pae'
    make: *** [all] Error 2

    /*********/


    Any help or guidance would be greatly appreciated!


    --
    sloppyfresh
    ------------------------------------------------------------------------
    sloppyfresh's Profile: http://forums.opensuse.org/member.php?userid=17584
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


  2. #2
    phi7 NNTP User

    Default Re: X-Fi Driver "make" Problems....


    Tried the same today and have the exact same error as the poster above.


    dhcppc0:/home/phi/Desktop/creative # make
    make -C /lib/modules/2.6.25.5-1.1-pae/build
    M=/home/phi/Desktop/creative
    make[1]: Entering directory `/usr/src/linux-2.6.25.5-1.1-obj/i386/pae'
    make[1]: *** No targets specified and no makefile found. Stop.
    make[1]: Leaving directory `/usr/src/linux-2.6.25.5-1.1-obj/i386/pae'
    make: *** [all] Error 2


    --
    phi7
    ------------------------------------------------------------------------
    phi7's Profile: http://forums.opensuse.org/member.php?userid=3083
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


  3. #3
    gapdragon NNTP User

    Default Re: X-Fi Driver "make" Problems....


    have to have the kernel headers/ also make and gcc installed, i have the
    fatality pro myself and even though i got yhe driver installed and
    modprobed, it STILL doesnt work


    --
    gapdragon
    ------------------------------------------------------------------------
    gapdragon's Profile: http://forums.opensuse.org/member.php?userid=17672
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


  4. #4
    phi7 NNTP User

    Default Re: X-Fi Driver "make" Problems....


    What do you mean with have the Kernel Headers? Make and gcc is
    installed.


    --
    phi7
    ------------------------------------------------------------------------
    phi7's Profile: http://forums.opensuse.org/member.php?userid=3083
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


  5. #5
    sloppyfresh NNTP User

    Default Re: X-Fi Driver "make" Problems....


    This puzzled penguin just got past the make problem:

    Use the YaST2 software installer / package manager, and search for
    "Kernel Header". This gave me one result (which I had to install from
    the original installation CD), which solved the problem with "make".

    I'll post again if I get stuck / get this working, as it appears there
    is at least 1 other person out there in this situation.


    --
    sloppyfresh
    ------------------------------------------------------------------------
    sloppyfresh's Profile: http://forums.opensuse.org/member.php?userid=17584
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


  6. #6
    sloppyfresh NNTP User

    Default Re: X-Fi Driver "make" Problems....


    It all works!

    SU, make install, and I have sound!


    --
    sloppyfresh
    ------------------------------------------------------------------------
    sloppyfresh's Profile: http://forums.opensuse.org/member.php?userid=17584
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


  7. #7
    phi7 NNTP User

    Default Re: X-Fi Driver "make" Problems....


    Cheers mate. Gonna try this tomorrow morning!


    --
    phi7
    ------------------------------------------------------------------------
    phi7's Profile: http://forums.opensuse.org/member.php?userid=3083
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


  8. #8
    phi7 NNTP User

    Default Re: X-Fi Driver "make" Problems....


    Still not working. I already had the kernel header installed - which
    leaves me at the same point as before


    --
    phi7
    ------------------------------------------------------------------------
    phi7's Profile: http://forums.opensuse.org/member.php?userid=3083
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


  9. #9
    phi7 NNTP User

    Default Re: X-Fi Driver "make" Problems....


    Another question: Which SUSE do you use? 10.3?


    --
    phi7
    ------------------------------------------------------------------------
    phi7's Profile: http://forums.opensuse.org/member.php?userid=3083
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


  10. #10
    phi7 NNTP User

    Default Re: X-Fi Driver "make" Problems....


    OK, the drivers are installed now. What I was missing was the Kernel
    Source. But no sound yet


    --
    phi7
    ------------------------------------------------------------------------
    phi7's Profile: http://forums.opensuse.org/member.php?userid=3083
    View this thread: http://forums.opensuse.org/showthread.php?t=402275


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •