Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Issue with Dolphin (Super user mode) - openSuse 11.1

  1. #1
    anantg NNTP User

    Default Issue with Dolphin (Super user mode) - openSuse 11.1


    Hi,

    when I open Dolphin in superuser mode I get following error


    Code:
    --------------------
    could not start process can not talk to Klauncher: The name org.kde.klauncher was not provided by any .service file
    --------------------


    I badly need this to work....

    Please provide me the solution

    Regards,
    Anant


    --
    anantg
    ------------------------------------------------------------------------
    anantg's Profile: http://forums.opensuse.org/member.php?userid=17560
    View this thread: http://forums.opensuse.org/showthread.php?t=402249


  2. #2
    baskitcaise NNTP User

    Default Re: Issue with Dolphin (Super user mode) - openSuse 11.1

    anantg wrote:

    >
    > Hi,
    >
    > when I open Dolphin in superuser mode I get following error
    >
    >
    > Code:
    > --------------------
    > could not start process can not talk to Klauncher: The name
    > org.kde.klauncher was not provided by any .service file
    > --------------------
    >
    >
    > I badly need this to work....
    >
    > Please provide me the solution
    >
    > Regards,
    > Anant
    >
    >


    I have seen this also and was thinking of filing a bug later, will not advise you on the dangers of running apps as root ( but unless you know what you are doing then you can seriously bork your system, totally bad form dontcherknow )

    I personally do not like Dolphin so I either use konqueror super user or krusader superuser.

    However the majority of the time I drop to a console ( Ctrl+Alt+F1 and Alt+F7 to get back to X ) and either use mc or the command line, more powerful that way and I always remember that I am in su.

    HTH
    --
    Mark....

    Nil illegitimi carborundum

  3. #3
    chyrania NNTP User

    Default Re: Issue with Dolphin (Super user mode) - openSuse 11.1


    You can always give konqueror super user mode a try and see if that
    works for you.

    What exactly are you trying to do?


    --
    chyrania
    ------------------------------------------------------------------------
    chyrania's Profile: http://forums.opensuse.org/member.php?userid=298
    View this thread: http://forums.opensuse.org/showthread.php?t=402249


  4. #4
    swerdna NNTP User

    Default Re: Issue with Dolphin (Super user mode) - openSuse 11.1


    baskitcaise;1911223 Wrote:
    >
    > I have seen this also and was thinking of filing a bug later

    This seems to be a recurring theme in the Forum. I too thought of a bug
    report but so far have been too busy with other bugs. Why don't you do
    that and let us know what happens?

    And Dolphin is driving me nuts too, much prefer Konqueror but thought I
    was just being reactionary. Nice to know someone else is crazed too.


    --
    'Enter the Xmas Naming Competition - It's a
    Hoot' (http://tinyurl.com/5kr7qa)
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=402249


  5. #5
    snakedriver NNTP User

    Default Re: Issue with Dolphin (Super user mode) - openSuse 11.1


    anantg;1911193 Wrote:
    > Hi,
    >
    > when I open Dolphin in superuser mode I get following error
    >
    > >

    Code:
    --------------------
    > > could not start process can not talk to Klauncher: The name org.kde.klauncher was not provided by any .service file

    --------------------
    > >

    >
    > I badly need this to work....
    >
    > Please provide me the solution
    >
    > Regards,
    > Anant


    1st, The Devs are trying to make your system more secure.

    2nd, I'm in KDE4 but the process is the same.

    You need to edit "sudoers file" and AFAIK there is only one way and it
    HAS to be done with "vi".
    su to root
    "visudo"
    in the line that reads:

    Code:
    --------------------

    Defaults env_keep = "LANG LC_ADDRESS LC_CTYPE LC_COLLATE LC_IDENTIFICATION LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER LC_TELEPHONE LC_TIME LC_ALL LANGUAGE LINGUAS XDG_SESSION_COOKIE"

    --------------------

    position the cursor after SESSION_COOKIE and press "i" (for insert)
    type "DISPLAY" so it reads:

    Code:
    --------------------

    Defaults env_keep = "LANG LC_ADDRESS LC_CTYPE LC_COLLATE LC_IDENTIFICATION LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER LC_TELEPHONE LC_TIME LC_ALL LANGUAGE LINGUAS XDG_SESSION_COOKIE DISPLAY"

    --------------------


    now pres "esc"
    then, : , then x & enter ( ":x" "enter") to save

    Now we are ready to proceed:

    In KDE
    In a terminal type
    "xhost +"
    then
    "kedsu konqueror"
    you will have to enter the root password.

    works for me

    In Gnome (I assume)
    In a terminal type
    "xhost +"
    then
    "gnomesu dolphin"
    you will have to enter the root password.

    Finally, since you have entered the root password, after you have
    finished your work, I recommend a reboot to clear the system.


    --
    nForce5, AMD 5600+; HP dv9700z, AMD "Puma"; both openSUSE 11.1 x86-64
    ------------------------------------------------------------------------
    snakedriver's Profile: http://forums.opensuse.org/member.php?userid=71
    View this thread: http://forums.opensuse.org/showthread.php?t=402249


  6. #6
    Wilson Phillips NNTP User

    Default Re: Issue with Dolphin (Super user mode) - openSuse 11.1


    They may make it more secure, but not everyone wants to work from
    konsole in vi or nano to edit every file. I know I sure don't.

    Thanks for that info, snakedriver. You're a lifesaver!


    --
    Wilson_Phillips
    ------------------------------------------------------------------------
    Wilson_Phillips's Profile: http://forums.opensuse.org/member.php?userid=144
    View this thread: http://forums.opensuse.org/showthread.php?t=402249


  7. #7
    nzlbob23 NNTP User

    Default Re: Issue with Dolphin (Super user mode) - openSuse 11.1


    There is a bug for this
    https://bugzilla.novell.com/show_bug.cgi?id=449056


    --
    nzlbob23
    ------------------------------------------------------------------------
    nzlbob23's Profile: http://forums.opensuse.org/member.php?userid=672
    View this thread: http://forums.opensuse.org/showthread.php?t=402249


  8. #8
    Wilson Phillips NNTP User

    Default Re: Issue with Dolphin (Super user mode) - openSuse 11.1


    When I run xhost+, I get Command Not Found. Even as SU.

    And there is also a bug reported with KDE that is a month old.


    --
    Wilson_Phillips
    ------------------------------------------------------------------------
    Wilson_Phillips's Profile: http://forums.opensuse.org/member.php?userid=144
    View this thread: http://forums.opensuse.org/showthread.php?t=402249


  9. #9
    Wilson Phillips NNTP User

    Default Re: Issue with Dolphin (Super user mode) - openSuse 11.1


    Found /usr/bin/xhost, but the + flag won't work with it.

    REBELBASE:/home/wilson # /usr/bin/host
    Usage: host [-aCdlriTwv] [-c class] [-N ndots] [-t type] [-W time]
    [-R number] [-m flag] hostname [server]
    -a is equivalent to -v -t ANY
    -c specifies query class for non-IN data
    -C compares SOA records on authoritative nameservers
    -d is equivalent to -v
    -l lists all hosts in a domain, using AXFR
    -i IP6.INT reverse lookups
    -N changes the number of dots allowed before root lookup is
    done
    -r disables recursive processing
    -R specifies number of retries for UDP packets
    -s a SERVFAIL response should stop query
    -t specifies the query type
    -T enables TCP/IP mode
    -v enables verbose output
    -w specifies to wait forever for a reply
    -W specifies how long to wait for a reply
    -4 use IPv4 query transport only
    -6 use IPv6 query transport only
    -m set memory debugging flag (trace|record|usage)


    --
    Wilson_Phillips
    ------------------------------------------------------------------------
    Wilson_Phillips's Profile: http://forums.opensuse.org/member.php?userid=144
    View this thread: http://forums.opensuse.org/showthread.php?t=402249


  10. #10
    swerdna NNTP User

    Default Re: Issue with Dolphin (Super user mode) - openSuse 11.1


    Thanks so muck snakedriver I was quite frustrated before your fix.

    I have some interesting things to report:

    If in a console I enter su to become root and then visudo, the sudoer
    file opens in Kwrite on my KDE4 in 11.1. I don't have any idea why
    (maybe vi not installed so it defaults) and then I edit it like you said
    but in the Kwrite text editor. It works. Most interesting!

    For some strange reason I don't need the bit with "xhost+". Instead:

    When I copy the KDE Superuser Konqueror from the Menu to the Desktop,
    it works like in KDE3. Just fine now, 1 click, one password and
    Konqueror superuser is up.

    To get a superuser vesion of Dolphin I copy an ordinary Dolphin icon to
    the Desktop, R-click and open the Properties --> Application -->
    Advanced --> Run as different user (make it root). So now I have
    superuser Dolphin by clicking an icon! Woo Hoo maybe I keep this
    KantanKerous KDE a day or two more!


    --
    'Enter the Xmas Naming Competition - It's a
    Hoot' (http://tinyurl.com/5kr7qa)
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=402249


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •