Results 1 to 2 of 2

Thread: Problem with using SKIM in KDE/QT applications

  1. #1
    homoludens1000 NNTP User

    Default Problem with using SKIM in KDE/QT applications


    Hi all,

    I've installed SKIM in order to use Japanese as a secondary language on
    system (which is running with English as the primary language), and I'm
    having this annoying little problem with KDE/QT applications.

    The input mode there is set to "scim-bridge", which, for whatever
    reason, doesn't allow me to use the HANKAKU key for switching to
    Japanese (I get an apostrophe ' instead when I press the button; the
    same also for <alt>+<HANKAKU>). Things work fine, however, when I
    choose "scim" from the context menu, so I'd like to set this as the
    default IM. Unfortunately I'm unable to figure out how to do that.

    Any ideas?

    I've checked some relevant environment variables:

    Code:
    --------------------
    XMODIFIERS (=@im=SCIM)
    QT_IM_MODULE (=scim-bridge)
    GTK_IM_MODULE (=scim-bridge)
    --------------------


    I've tried to set QT_IM_MODULE and GTK_IM_MODULE to "scim", but this
    didn't change anything, and the variables were set back to "scim-bridge"
    upon reboot ...

    Things work fine in GTK applications like Firefox and OpenOffice.org,
    by the way.


    --
    homoludens1000
    ------------------------------------------------------------------------
    homoludens1000's Profile: http://forums.opensuse.org/member.php?userid=704
    View this thread: http://forums.opensuse.org/showthread.php?t=401724


  2. #2
    homoludens1000 NNTP User

    Default Re: Problem with using SKIM in KDE/QT applications


    Ok, I solved this issue. The KDE applications work fine (i.e. as
    expected) when the environmental variables above are set to "scim".
    Check this threat here for advice on how to achieve this:

    'Where are environmental variables like XMODIFIERS set? - openSUSE
    Forums' (http://tinyurl.com/8qy2y2)

    Cheers,

    homoludens


    --
    homoludens1000
    ------------------------------------------------------------------------
    homoludens1000's Profile: http://forums.opensuse.org/member.php?userid=704
    View this thread: http://forums.opensuse.org/showthread.php?t=401724


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •