Hi all ppl
I'm try to compile some app (actually yaf(a)ray)

to compile it uses scons


Code:
--------------------
>scons

scons: Reading SConscript files ...
using configuration from config/linux2-config.py
user-config.py not available, doing no user overrides
Checking for C library pthread... yes
Checking for C library z... yes
Checking for C++ library Half... yes
Checking for C++ library Iex... yes
Checking for C++ library Imath... yes
Checking for C++ library IlmImf... yes
Checking for C library xml2... no
Checking for C library jpeg... yes
Checking for C library png... yes
Checking for C library freetype... yes
Error: not all enabled libraries are available!
if they are installed, make sure the paths are setup correctly
if you don't have them, try disabling with the appropriate WITH_YF_* option
--------------------


but if I check both xml2 and xml2-devel is installed


Code:
--------------------
> zypper se xml2

Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+-----------------+-------------------------------------------------------+-----------
| dbusxml2qt3 | Generate Qt3-classes from DBus-introspection data | package
| libwbxml2-0 | WBXML parser and compiler library | package
| libwbxml2-devel | WBXML parser and compiler library | package
i | libxml2 | A Library to Manipulate XML Files | package
| libxml2 | A Library to Manipulate XML Files | srcpackage
| libxml2-devel | Include Files and Libraries mandatory for Development | package
| libxml2-doc | A Library to Manipulate XML Files | package
i | libxml2-python | Python Bindings for libxml2 | package
| libxml2-python | Python Bindings for libxml2 | srcpackage
| wbxml2 | WBXML parser and compiler library | package


--------------------


if i check what xml i have i press tab two times


Code:
--------------------

> xml

xmlcatalog xml-config xmlindexer xmllint xmlproc_parse xmlproc_val xmlwf
--------------------


and also I check $PATH


Code:
--------------------
> $PATH

bash: /home/nd/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin: Нет такого файла или каталога
--------------------


hope somebody help me with this...

I make this on opensuse 11.1 RC-1 actually updated


--
Linux 2.6.25.16-0.1-pae openSUSE 11 i386
#1KM400|Athlon|RAM2GB|FX5200
#2 nforce2|Athlon|Radeon9200|RAM1GB
#3 laptop ASUS x51r|Xpress1100|512MB
------------------------------------------------------------------------
didencool's Profile: http://forums.opensuse.org/member.php?userid=4743
View this thread: http://forums.opensuse.org/showthread.php?t=401630