No matter what I do, I cannot make GTK apps use the Oxygen style in KDE4. It seems to use the same widget (ugly) style, particularly for the buttons and other control elements. For some reason I think the QT4 style is used, but then the buttons are always very ugly, becoming dark grey on hover. I tried to manually edit the file to change the gtk theme, and noticed that menus change, but input boxes and buttons don't.

What is really weird is that I think I used to have it all set up, so I had the Oxygen style in GTK applications (Firefox and Thunderbird included). I must have done something I do not remember, and it's been like this every since. I even tried loading gnome-settings-daemon upon KDE start-up, and it used to work up to some point, but failed afterwords complaining about some murrine thing...

If anyone can offer an insight, I'd be very grateful. No forum thread seemed to help thus far, which is why I am posting.

I run OpenSuse 11, with KDE 4.1.3. I have the kde4-gtk-qt-engine installed, and not the kcm module.

Thanks in advance!