Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: OpenOffice Error Saving to Samba Share

  1. #1
    mooreted NNTP User

    Default OpenOffice Error Saving to Samba Share


    Am connecting to documents on a server with Windows 2000 Pro. I am
    running openSuse 11.0 and Kde 3.5.10. I have upgraded my OpenOffice to
    3.0

    When I try to save a document to the server through Samba I receive the
    following error:

    "Error saving document. General Internet Error Occured."

    Here is my smb.conf file:

    # smb.conf is the main Samba configuration file. You find a full
    commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if
    the
    # samba-doc package is installed.
    # Date: 2008-08-28
    [global]
    workgroup = WORKGROUP
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = Yes
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody
    -s /bin/false %m$
    domain logons = No
    domain master = No
    ldap suffix =
    netbios name = Suse
    passdb backend = smbpasswd
    security = user
    wins server =
    wins support = No
    [homes]
    comment = Home Directories
    valid users = %S, %D%w%S
    browseable = No
    read only = No
    inherit acls = Yes
    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700
    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes
    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    ## Share disabled by YaST
    # [netlogon]


    --
    mooreted
    ------------------------------------------------------------------------
    mooreted's Profile: http://forums.opensuse.org/member.php?userid=633
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


  2. #2
    swerdna NNTP User

    Default Re: OpenOffice Error Saving to Samba Share


    Is the windows 2000 share mounted as a cifs network drive on openSUSE
    or are you saving to a Samba share in a network browser? There's a
    difference in behaviour.


    --
    'Come visit sometime'
    (http://www.swerdna.net.au/linux.html)
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


  3. #3
    mooreted NNTP User

    Default Re: OpenOffice Error Saving to Samba Share


    I open Konqueror, click Network, click Workgroup, click the share I want
    to connect to, and enter my username and password. Once in I can create
    directories, drag and drop files, delete files; so I have rw
    permissions.

    What I eventually had to do was save the file to my desktop, edit the
    file and drag it to the server.


    --
    mooreted
    ------------------------------------------------------------------------
    mooreted's Profile: http://forums.opensuse.org/member.php?userid=633
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


  4. #4
    swerdna NNTP User

    Default Re: OpenOffice Error Saving to Samba Share


    If I want reliable editing of doc and odt files I mount the remote
    directory as a cifs mount with a line in fstab something like this:

    Code:
    --------------------
    //192.168.44.100/share_name /path_to/mount_point cifs
    username=server_user,password=server_password,_netdev,nobrl,uid=client_username,gid=users 0 0
    --------------------

    The thing that fixes it for me is the option "nobrl". 'Here's the
    reference' (http://www.swerdna.net.au/linhowtosambacifs.html).


    --
    'Come visit sometime'
    (http://www.swerdna.net.au/linux.html)
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


  5. #5
    mooreted NNTP User

    Default Re: OpenOffice Error Saving to Samba Share


    Okay, I'm getting "Access Denied" with the following fstab entry:

    //centraldata/Storage\Volume/Vortex\folders /mnt/vortex cifs
    username=ted,password=computer,_netdev,uid=mooreted,gid=users 0 0


    --
    mooreted
    ------------------------------------------------------------------------
    mooreted's Profile: http://forums.opensuse.org/member.php?userid=633
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


  6. #6
    mooreted NNTP User

    Default Re: OpenOffice Error Saving to Samba Share


    From the command-line I'm getting:

    mount -t cifs -o username=ted,password=computer
    //centraldata/Storage\Volume /mnt/vortex
    mount error 113 = No route to host
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

    Which is weird because I can get to it just fine from Konqueror.


    --
    mooreted
    ------------------------------------------------------------------------
    mooreted's Profile: http://forums.opensuse.org/member.php?userid=633
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


  7. #7
    swerdna NNTP User

    Default Re: OpenOffice Error Saving to Samba Share


    The only path you can have referring to a server in the cifs mount is to
    join these two things: the server network name and the server share
    name, so you get like this:
    //windows_server/share_name.
    Note that the slants are all the same direction. "Servername" can be an
    IP address or a (netbios-style) network name. So if you see in Konqueror
    the share like this:
    smb://windows_server/share_name
    then the mount in fstab must be the same (//windows_server/share_name).
    You can't have a deeper path than that in fstab; you drill down further
    after you've mounted the share.


    --
    'Come visit sometime'
    (http://www.swerdna.net.au/linux.html)
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


  8. #8
    mooreted NNTP User

    Default Re: OpenOffice Error Saving to Samba Share


    In Konqueror,the address bar says:

    smb://ted@centraldata/

    I changed fstab to:

    //centraldata/ /mnt/vortex cifs
    username=ted,password=computer,_netdev,uid=mooreted,gid=users 0 0

    It still won't let me in.

    Btw, the Suse firewall is turned off.


    --
    mooreted
    ------------------------------------------------------------------------
    mooreted's Profile: http://forums.opensuse.org/member.php?userid=633
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


  9. #9
    Wilson Phillips NNTP User

    Default Re: OpenOffice Error Saving to Samba Share


    Take a look at mine.

    //192.168.1.2/Volume_1/ /NAS cifs
    username=netuser,password=netuser,uid=1001,gid=100,nobrl,_netdev 0 0

    You may find that you have to use the IP address instead of the
    Server_Name. If you have a DNS or WINS server, you can use the name.

    Notice that you can not just give the //Server_Name/. You must give the
    //Server_Name/Share_Name/ for it to work. Put that folder name in there
    as shown.

    Next comes the folder where the share will mount. Mine is /NAS and you
    must manually create that folder in / or it will not mount there. The
    share will not create the folder automatically.

    The user netuser must be created in Linux before it can be created in
    Samba. This user will also have to have permissions set on the server
    that is sharing the folder.

    UID can be the User_Name or the User_ID_Number. I prefer to use the
    User_ID_Number, but I am just picky that way. Same for GID.

    The nobrl will assist if you have problems saving files in OpenOffice.
    It won't hurt to have it in there anyway.

    _netdev will make the share wait till it is available on the network
    before mounting it.

    I also had to create /home/wilson/.kde4/Autostart/mount.sh and then set
    up wilson as an SUDoer for that script. The only line in the script is
    as follows.

    mount -a

    When KDE starts, it runs that script and mounts the drive. Only root
    can mount a drive, so you have to SUDo to run the script.


    --
    Wilson_Phillips
    ------------------------------------------------------------------------
    Wilson_Phillips's Profile: http://forums.opensuse.org/member.php?userid=144
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


  10. #10
    swerdna NNTP User

    Default Re: OpenOffice Error Saving to Samba Share


    mooreted;1907373 Wrote:
    > In Konqueror,the address bar says:
    >
    > smb://ted@centraldata/
    >
    > I changed fstab to:
    >
    > //centraldata/ /mnt/vortex cifs
    > username=ted,password=computer,_netdev,uid=mooreted,gid=users 0 0
    >
    > It still won't let me in.
    >
    > Btw, the Suse firewall is turned off.

    You need TWO words in the server description. You've left out the name
    of the share. The name of the server is (presumably) centraldata. Make
    the entry like this:
    //centraldata/share_name
    or like this
    //abc.def.ghi.jkl/sharename as per wilson


    --
    'Come visit sometime'
    (http://www.swerdna.net.au/linux.html)
    ------------------------------------------------------------------------
    swerdna's Profile: http://forums.opensuse.org/member.php?userid=84
    View this thread: http://forums.opensuse.org/showthread.php?t=401545


Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •