Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Packman Repo Issue

  1. #1
    deano ferrari NNTP User

    Default Packman Repo Issue


    I've recently experienced trouble with refreshing the Packman repo. So
    far I've tried:

    1) Deleting and adding the repo again (as well as deleting GPG Key).

    2) Using one of the mirrors instead - same error results.

    This is what occurs upon refreshing:

    > zypper ref -f 2
    > Forcing raw metadata refresh
    > Digest verification failed for primary.xml.gz. Expected
    > 77d22cc9e4ebd308cc53ccb09c2c9e316ac6a66e, found
    > 1a9db464021ded7d420f0d260a5d24173007f166. Continue? [yes/NO]: yes
    > Downloading repository 'Packman Repository' metadata [done]
    > Forcing building of repository cache
    > Building repository 'Packman Repository' cache [done]
    > Error building the cache database:
    > 'repo2solv.sh' '-o'
    > '/var/cache/zypp/solv/http:__ftp.skynet.be_pub_packman_suse_11.0_/solv'
    > '/var/cache/zypp/raw/http:__ftp.skynet.be_pub_packman_suse_11.0_'
    >
    > gzip: primary.xml.gz: not in gzip format
    > repo_rpmmd: no element found at line 1:0
    >
    > Skipping repository 'Packman Repository' because of the above error.
    > Could not refresh the repositories because of errors.
    >


    This one's got me beat. Anyone able to shed some light on this?


    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=401386


  2. #2
    Uwe Buckesfeld NNTP User

    Default Re: Packman Repo Issue

    * deano ferrari,

    does it work when you refresh the repo through Yast?

    Uwe

  3. #3
    Shermz NNTP User

    Default Re: Packman Repo Issue


    Think I have a similiar issue, (the only way i know how to install
    things is to use repos at the moment..) everytime i run Yast > Software
    Management > when it does the repo refresh on startup.. Yast seems to
    keep trying to refresh the packman repo again and again for at least 2-3
    times before i can view the list of software screen.. and on my slow
    connection, downloading the gz takes like a minute or two for each
    try..

    Thought maybe it's a packman repo issue.. didn't really bother about it
    since it's not really critical for me..


    --
    Shermz
    ------------------------------------------------------------------------
    Shermz's Profile: http://forums.opensuse.org/member.php?userid=16626
    View this thread: http://forums.opensuse.org/showthread.php?t=401386


  4. #4
    deano ferrari NNTP User

    Default Re: Packman Repo Issue


    > does it work when you refresh the repo through Yast?


    No, I get a 'Wrong Digest' error message reporting that the expected
    checksum does not match the current checksum. It gives me the option to
    use it anyway, but after the refresh process is complete the same error
    message as with zypper process, and the Packman repo is then disabled.


    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=401386


  5. #5
    AlienHealer NNTP User

    Default Re: Packman Repo Issue


    I've had that happen to me as well, so I changed mirrors and that seemed
    to fix what ever was causing the problem

    try

    'Index of /suse/11.1' (http://packman.unixheads.com/suse/11.1/)

    see if you still have problems


    --
    AlienHealer
    ------------------------------------------------------------------------
    AlienHealer's Profile: http://forums.opensuse.org/member.php?userid=596
    View this thread: http://forums.opensuse.org/showthread.php?t=401386


  6. #6
    deano ferrari NNTP User

    Default Re: Packman Repo Issue


    Mirrors for the same repo (opensuse 11) give same result:

    > linux:/home/dean # zypper ar 'Index of /linux/packman/suse/11.0'
    > (http://mirror.pacific.net.au/linux/packman/suse/11.0/) Packman
    > Adding repository 'Packman' [done]
    > Repository 'Packman' successfully added
    > Enabled: Yes
    > Autorefresh: No
    > URI: 'Index of /linux/packman/suse/11.0'
    > (http://mirror.pacific.net.au/linux/packman/suse/11.0/)
    >
    > linux:/home/dean # zypper refresh Packman
    > Digest verification failed for primary.xml.gz. Expected
    > 99c955417bd7d76c985c95534199df229414881e, found
    > b048f2d943d096026cb324b13871dd1e318c5e97. Continue? [yes/NO]: yes
    > Downloading repository 'Packman' metadata [done]
    > Building repository 'Packman' cache [done]
    > Error building the cache database:
    > 'repo2solv.sh' '-o' '/var/cache/zypp/solv/Packman/solv'
    > '/var/cache/zypp/raw/Packman'
    >
    > gzip: primary.xml.gz: not in gzip format
    > repo_rpmmd: no element found at line 1:0
    >
    > Skipping repository 'Packman' because of the above error.
    > Could not refresh the repositories because of errors.



    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=401386


  7. #7
    deano ferrari NNTP User

    Default Re: Packman Repo Issue


    > I've had that happen to me as well, so I changed mirrors and that seemed
    > to fix what ever was causing the problem
    >
    > try
    >
    > Index of /suse/11.1
    >
    > see if you still have problems


    @AlienHealer

    The 11.1 repo refreshes ok. Interesting... I guess I need to notify
    someone. I wonder why others haven't reported problems...


    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=401386


  8. #8
    AlienHealer NNTP User

    Default Re: Packman Repo Issue


    whoops, sorry, didn't realise I gave you the 11.1 link. My head is so
    not with me today, blame the weather, where the bleep is the kiwi summer



    --
    AlienHealer
    ------------------------------------------------------------------------
    AlienHealer's Profile: http://forums.opensuse.org/member.php?userid=596
    View this thread: http://forums.opensuse.org/showthread.php?t=401386


  9. #9
    deano ferrari NNTP User

    Default Re: Packman Repo Issue


    > whoops, sorry, didn't realise I gave you the 11.1 link


    Thats ok, it still helped prove that something is up with the packman
    repo as far as version 11 packages. (Just surprised the problem has
    persisted).

    Agree re random weather


    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=401386


  10. #10
    wpfaff NNTP User

    Default Re: Packman Repo Issue


    I am using OpenSuse 11.0 and haven't any issues with packman repo using
    this url: [url=http://packman.unixheads.com/suse/11.0/[url]


    --
    wpfaff
    ------------------------------------------------------------------------
    wpfaff's Profile: http://forums.opensuse.org/member.php?userid=16816
    View this thread: http://forums.opensuse.org/showthread.php?t=401386


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •